linux-firmware 1.127.5, 1.127.6 causes unstable network connection (likely due to iwlwifi-7260-8.ucode)

Bug #1371425 reported by Andrey Arapov on 2014-09-19
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
linux-firmware (Ubuntu)
Undecided
Seth Forshee

Bug Description

1) Linux Mint 17 Qiana (MATE, x86_64)
2) Having linux-firmware 1.127.5 or 1.127.6 installed on my Sony Vaio Pro 13 ( SVP1322V8EBI product name )
3) It causes loosy network, ping to wireless access point is unstable, it jumps from 1.8ms up to 250 and even more than 2000ms from time to time (every 3-5 minutes), repeatedly dropping packets too (no matter pinging directly a router or an external site), consistently high packet loss (about 33%), impossible to work over ssh as it takes about 10-15 seconds to type a command almost every 3rd or 5th minute, repeatedly disconnects from access point due to a limited range.
4) Normal and stable network connection over WiFi -- without lags, packet loss, disruptions, limited range, etc ...
5) Always with linux-firmware 1.127.5 or 1.127.6

--- Notes ---
And there is absoultely no problem when I downgraded to linux-firmware=1.127.4 , wireless connection perfectly works, no lags, no disruptions, no packet loss, just works as expected.

My Wireless card on Sony Vaio Pro 13:
01:00.0 Network controller: Intel Corporation Wireless 7260 (rev 6b)
 Subsystem: Intel Corporation Dual Band Wireless-AC 7260
 Flags: bus master, fast devsel, latency 0, IRQ 60
 Memory at f7200000 (64-bit, non-prefetchable) [size=8K]
 Capabilities: [c8] Power Management version 3
 Capabilities: [d0] MSI: Enable+ Count=1/1 Maskable- 64bit+
 Capabilities: [40] Express Endpoint, MSI 00
 Capabilities: [100] Advanced Error Reporting
 Capabilities: [140] Device Serial Number 5c-51-4f-ff-ff-XX-XX-XX (NOTE: I changed last 3 bytes to XX)
 Capabilities: [14c] Latency Tolerance Reporting
 Capabilities: [154] Vendor Specific Information: ID=cafe Rev=1 Len=014 <?>
 Kernel driver in use: iwlwifi

Thanks for fixing this problem in advnace, and if you need more outputs from my side, please let me know.

Vlad Orlov (monsta) on 2014-09-20
affects: linuxmint → linux-firmware (Ubuntu)
Lathander (lathanderjk) wrote :

Same ping issue, regularly jump from 0.6-1ms to 100-1000ms (every 3-5min), the are not problem of HW or AP.

Distribution Xubuntu 14.04.1 x86_64 on HP Zbook 14.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux-firmware (Ubuntu):
status: New → Confirmed
Andrey Arapov (andrey-arapov) wrote :

I've just tried newer linux-firmware 1.127.7, and it has the same problem.

arno@mint ~ $ ping 10.0.0.138
PING 10.0.0.138 (10.0.0.138) 56(84) bytes of data.
64 bytes from 10.0.0.138: icmp_seq=1 ttl=64 time=2.65 ms
64 bytes from 10.0.0.138: icmp_seq=2 ttl=64 time=2.00 ms
64 bytes from 10.0.0.138: icmp_seq=9 ttl=64 time=1.56 ms
^C
--- 10.0.0.138 ping statistics ---
12 packets transmitted, 3 received, 75% packet loss, time 11052ms
rtt min/avg/max/mdev = 1.568/2.075/2.652/0.445 ms

Packet loss is very high, unstable network connection and lags.

Andrey Arapov (andrey-arapov) wrote :

Downgraded to 1.127 now and it works without a problem:

(pinging my AP)
--- 10.0.0.138 ping statistics ---
50 packets transmitted, 50 received, 0% packet loss, time 49079ms
rtt min/avg/max/mdev = 1.212/11.625/216.669/41.491 ms

So I'm almost certain that the bug was introduced with the linux-firmware 1.127.5 -- https://launchpad.net/ubuntu/+source/linux-firmware/1.127.5

Looks like similar problems (since 1.127.5 and above):
https://bugs.launchpad.net/ubuntu/+source/linux-firmware/+bug/1293569
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1373552

Lathander (lathanderjk) wrote :

I just tried firmware 1.127 and it has the same problem as 1.127.7

Absolutly same ping spikes as https://communities.intel.com/thread/53294 on Windows OS. Solution for windows OS is in this thread.

I have only ping spikes (every 1-2 minutes) nothing else.

Andrey Arapov (andrey-arapov) wrote :

@Lathander you are right, 1.127 doesn't work as good as 1.127.4 does, but still better than 1.127.5, .6, .7 ones

Even the ping to my AP was without a loss, any other external WAN IP resulted about ~7% packet loss, e.g.:
--- google.com ping statistics ---
33 packets transmitted, 30 received, 9% packet loss, time 32067ms
rtt min/avg/max/mdev = 27.453/55.770/514.347/90.367 ms

So I'll rollback to 1.127.4 that works the best for me.

Andrey Arapov (andrey-arapov) wrote :

To those who are looking for the working version of firmware, can get it here:
http://nixaid.com/linux-firmware_1.127.4_all.deb

here:
https://web.archive.org/web/20140817233853/http://security.ubuntu.com/ubuntu/pool/main/l/linux-firmware/linux-firmware_1.127.4_all.deb

(also tried to attach to this post)

md5:
d6fa4be684a2aaedecbd6f8383bcbba2 linux-firmware_1.127.4_all.deb

sha256:
c634800c17cfd6148dda909a20b839b04fb092b86d6f8a939b2f1124b224b20a linux-firmware_1.127.4_all.deb

Lathander (lathanderjk) wrote :

I found simple solution for ping spikes.

Update network-manager from https://launchpad.net/~sarvatt/+archive/ubuntu/taramar and done.

Tim Gardner (timg-tpi) on 2014-10-08
Changed in linux-firmware (Ubuntu):
assignee: nobody → Seth Forshee (sforshee)
Seth Forshee (sforshee) wrote :

There's a proposed fix to some instability issues with Intel 7260 wireless. Can you install the kernel from the link below and test with the -8 firmware to see if it helps? Thanks!

http://people.canonical.com/~sforshee/lp1361809/linux-3.13.0-37.64+lp1361809v201410060628/

Changed in linux-firmware (Ubuntu):
status: Confirmed → Incomplete
Seth Forshee (sforshee) wrote :

No, sorry, that one is for different hardware. I'm mixing up my Intel wireless bugs. This is the build you should test.

http://people.canonical.com/~sforshee/iwl-ltr/trusty/

Andrey Arapov (andrey-arapov) wrote :

I've installed the linux-image-3.13.0-37-generic_3.13.0-37.64+iwlltr0001_amd64.deb kernel, however after the reboot I didn't see any wlan0 interface, neither there is a iwlwifi module in this kernel.
I've attached the detailed logs to this post.

Andrey Arapov (andrey-arapov) wrote :

I guess this bug can be closed.
I've installed linux-firmware 1.127.8 and also switched to the Channel 13 (Frequency:2.472 GHz).
Not sure which one resolved, but both are definitely made it roll :-)

Andrey Arapov (andrey-arapov) wrote :

Humm.. hurry to refute my previous comment... I went 1 more meter from the AP and the wireless started to get disconnected every minute almost... :-/ so linux-firmware 1.127.8 is not a solution ... rolling back to 1.127.4

Andrey Arapov (andrey-arapov) wrote :

*Updating after testing*
WiFi on 7260 is still buggy with linux-firmware [1.127.5-1.127.10]

Andrey Arapov (andrey-arapov) wrote :

Looks like linux-firmware 1.127.11 resolved the problem I had.
If the problem will occur again, I'll write about it here. Otherwise please feel free to close this case if I don't update it for one-two weeks :-)

Thanks!

https://bugs.launchpad.net/ubuntu/+source/linux-firmware/+bug/1398171

linux-firmware (1.127.11) trusty; urgency=medium

  * iwlwifi: update firmware for 3160 / 7260 / 7265
    -LP: #1398171

 -- Seth Forshee <email address hidden> Mon, 01 Dec 2014 12:21:56 -0600

summary: - linux-firmware 1.127.5, 1.127.6 causes instable network connection
+ linux-firmware 1.127.5, 1.127.6 causes unstable network connection
(likely due to iwlwifi-7260-8.ucode)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers