iwlwifi Intel 7260 Wifi disconnects

Bug #1354975 reported by Steve Breen on 2014-08-11
218
This bug affects 43 people
Affects Status Importance Assigned to Milestone
Unity Linux
New
Undecided
Unassigned
linux-firmware (Ubuntu)
Medium
Unassigned
Nominated for Trusty by Jorge Niedbalski
Nominated for Utopic by Jorge Niedbalski
Nominated for Vivid by Jorge Niedbalski

Bug Description

I experience frequent disconnects and auth issues, never more than 30 minutes without a disconnect. Sometimes dozens of disconnects in a few minutes.

This happens with the default 7260-8 firmware.
Tried replacing the -8 with -9 ucode. Failed to load due to API version. This loaded the -7 driver which seems to be more stable.

Tested against 2.4ghz APs (Apple, Netgear, Linksys).

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: linux-image-3.13.0-32-generic 3.13.0-32.57
ProcVersionSignature: Ubuntu 3.13.0-32.57-generic 3.13.11.4
Uname: Linux 3.13.0-32-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.3
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: steve 2577 F.... pulseaudio
 /dev/snd/controlC1: steve 2577 F.... pulseaudio
CurrentDesktop: Unity
Date: Sun Aug 10 17:49:06 2014
HibernationDevice: RESUME=UUID=374a0c1c-4ac2-456b-a67e-9ea54fe11fe6
InstallationDate: Installed on 2013-12-28 (225 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
MachineType: Dell Inc. XPS 12-9Q33
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-32-generic root=UUID=58deb355-7a09-440b-ade2-69a84fd74460 ro ipv6.disable=1 quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.13.0-32-generic N/A
 linux-backports-modules-3.13.0-32-generic N/A
 linux-firmware 1.127.5
SourcePackage: linux
UpgradeStatus: Upgraded to trusty on 2014-07-06 (35 days ago)
dmi.bios.date: 05/06/2013
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A00
dmi.board.name: XPS 12-9Q33
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: Not Specified
dmi.modalias: dmi:bvnDellInc.:bvrA00:bd05/06/2013:svnDellInc.:pnXPS12-9Q33:pvrA00:rvnDellInc.:rnXPS12-9Q33:rvrA00:cvnDellInc.:ct8:cvrNotSpecified:
dmi.product.name: XPS 12-9Q33
dmi.product.version: A00
dmi.sys.vendor: Dell Inc.

Steve Breen (sbreen) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Steve Breen (sbreen) on 2014-08-11
description: updated
affects: linux (Ubuntu) → linux-firmware (Ubuntu)
Seth Forshee (sforshee) wrote :

Steve: Thanks for filing the bug. On the surface this looks like most of the other reports I'm seeing with Intel 7260 - disconnections due to the driver reporting loss of beacons from the AP. I've got a test build with a couple of fixes from later kernel versions, so I'd appreciate it if you could go ahead and try it out to see if it helps. You can download the build from:

  http://people.canonical.com/~sforshee/lp1349572/linux-3.13.0-32.57+lp1349572v201408111147/

Please let me know your results. Thanks!

Changed in linux-firmware (Ubuntu):
status: Confirmed → Incomplete
Steve Breen (sbreen) wrote :

Thanks Seth. I've installed the patched kernel and verified the -8 firmware is loading. It's been up for 2 hours so far with no disconnects. Looking promising it's never made it 30 minutes when running -8.

Steve Breen (sbreen) wrote :

The patch stops the disconnects but I've been noticing transient throughput issues (max 15Mbps 5ft from AP; extreme high latency trying to watch video/download) as well as times where it will freak out and cause all wifi devices traffic to stop, until the instant the card is disabled.

I've noticed this all with -8, so far -7 hasn't had these issues.

Seth Forshee (sforshee) wrote :

Thanks, Steve. Your disconnections seem to be the same then as in bug #1349572, and we've already picked up the patches for a future update. Technically I guess we should make this bug a duplicate and have you open a new bug for the other issues, but I'm inclined to just go ahead and switch the topic of this bug to address the other issues you're seeing.

For that, the first thing I'd ask is that you test the 3.16 kernel and see if your problems still exist there. You can get packages from:

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.16-utopic/

You want the packages with "generic" in the name, not the "lowlatency" packages. Thanks!

Changed in linux-firmware (Ubuntu):
importance: Undecided → Medium
morinpatmorin (morinpatmorin) wrote :

I can confirm that this bug affects my Dell XPS 13 Haswell with an Intel 7260 rev 6b. Symptoms are identical to those described in the original post.

Using the mainline 3.15.10 kernel seems to have helped, but doesn't detect my Synaptics touchpad, so I never used it for very long. I also tried one of the 3.17rc3, but that wouldn't even boot.

The only workable solution for now is using 3.13.0-35-generic with the -8 ucode moved out of the way so that it uses the -7. This makes the disconnects come hours apart instead of minutes apart.

Seth Forshee (sforshee) wrote :

Steve: Still waiting on results of testing the upstream kernel. Things have moved on since then, so I'd suggest testing this one:

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.17-rc7-utopic/

I also got a new patch from Intel for 7260 wireless issues, so please give this one a try too.

http://people.canonical.com/~sforshee/iwl-ltr/trusty/

Thanks!

LE BIDEAU (elbc) wrote :

Tried both (3.17 kernel and 3.13 with iwl-ltr patch), no changes at all with 3.17 for me, it seems thath with the other one disconnection comes after but persists. My efficient test is to do a fresh download of a big steam game (Borderlands 2). For the moment , I never succeeded to download it completely (disconnections comes between 10 and 30 mn)

LE BIDEAU (elbc) wrote :

Adding more informations to my previous comment, I think it's a "data size" problem : I've been testing with several kernel, several configurations (disable n in /etc/modprobe.d/iwlwifi.conf, disable power management etc , and even tried with experimental iwlwifi-7260-10.ucode firmware) and I've noticed that downloading the big steam game (still a new fresh download of borderlands 2), the disconnection always happened when 1.1 Gb is downloaded (not 1 Go not 1.2 Go ...) I've been testing this about 15 times yesterday and it always happened at the same dowlnloaded size.

LE BIDEAU (elbc) wrote :

tried o a fesh install of ubuntu mate 14.10 (replaced linux mint 17), problem still persists

kris (makkasi) wrote :

linux mint 17
iwlwifi-7260-9.ucode
3.16.3-031603-generic

The connection is very stable as long as I just browse in the web. In the moment I start downloading something bigger then the wifi is disconnecting.

kris (makkasi) wrote :

 and i forgot
linux-firmware 1.127.4
the other versions above are very unstable, but with this firmware I can be connected almost during the day if I just browse and not download

LE BIDEAU (elbc) wrote :

exactly same behaviour as kris with same cnfigurations (and tested utopic linux-firmware package too, same)

kris (makkasi) wrote :

Looks that my internet connection is now stable even when downloading. I'm not sure what of the three things that I did fixed the problem but here what I did so that others can test further:

1. In the /usr/lib/pm-utils/power.d directory in the file wireless I changed in the end of the file with two off so that there is no wireless powersave:
case $1 in
    true) wireless_powersave off ;;
    false) wireless_powersave off ;;
    *) exit $NA ;;
esac
2. I also blacklisted wireless power management creating blacklist file :
sudo nano /etc/pm/config.d/blacklist
HOOK_BLACKLIST="wireless"
3. Third I installed wicd , without removing network manager , and with wicd I checked all other networks with "Never connect to this network" except mine network. So I don't have time to test further but downloading is working with better speed then before and is not interrupting anymore.

Once again my configuration:
linux mint 17
iwlwifi-7260-9.ucode
3.16.3-031603-generic
linux-firmware 1.127.4

LE BIDEAU (elbc) wrote :

kris, I've been trying everything (each methods independently and all in one time), I even removed network manager after that to see if it came from it, no changes for me, downloading stop after 1.1 Go downloaded.

kris (makkasi) wrote :

I haven't tried to download so big file but now I will. I gonna use firefox for that.
sudo lshw -C network
.....................................................................
  *-network
       description: Wireless interface
       product: Wireless 7260
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlan0
       version: 83
       serial: ...........MAC...........
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=3.16.3-031603-generic firmware=23.214.9.0 ip=192.168.1.17 latency=0 link=yes multicast=yes wireless=IEEE 802.11abgn
       resources: irq:48 memory:b0600000-b0601fff

meanwhile you can check whether you have absolutly the same driver and firmware number from above

LE BIDEAU (elbc) wrote :

Yes it is the same except that my version is not 83 but 6b. My two downloading tests are : 1) dowload a linux image through transmission 2) download a big steam game

kris (makkasi) wrote :

I already downloaded 1.9 GB file through firefox. I cannot reproduce transmission behavior as well. I downloaded 1.47GB movie with transmission.

LE BIDEAU (elbc) wrote :

yes, with tranmission it doesn't happen each time for me, and firefox is working good. There is only with steam where I can reproduce it each time ...

LE BIDEAU (elbc) wrote :

Just tried three times this file with transmission : http://torrents.linuxmint.com/torrents/linuxmint-17-kde-dvd-64bit.iso.torrent each time it failed.

kris (makkasi) wrote :

the last torrent I've downloaded two times with trasmission

Confirming that this happens to me as well on a Sager NP7338. I'll update my kernel to 3.16.0 and see if it helps. In the mean time, this is my current configuration:

Ubuntu 14.04

lshw -C network
  *-network
       description: Wireless interface
       product: Wireless 7260
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlan0
       version: 73
       serial: f8:16:54:87:59:9c
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=3.13.0-37-generic firmware=22.24.8.0 ip=192.168.25.11 latency=0 link=yes multicast=yes wireless=IEEE 802.11abgn
       resources: irq:49 memory:f7900000-f7901fff

Linux 3.13.0-37-generic
Linux-firmware 1.127 (it is worse with 1.127.8)

It seems it was fixed. I'm using linux 3.16.0-031600-generic and linux-firmware 1.136

$ sudo lshw -C network
  *-network
       description: Wireless interface
       product: Wireless 7260
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlan0
       version: 73
       serial: f8:16:54:87:59:9c
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=3.16.0-031600-generic firmware=25.222.9.0 ip=192.168.25.11 latency=0 link=yes multicast=yes wireless=IEEE 802.11abgn
       resources: irq:51 memory:f7900000-f7901fff

I've tested by starting downloading a torrent while pinging 8.8.8.8. After ~1h, the torrent has downloaded 4,2 GB and my ping results are:

--- 8.8.8.8 ping statistics ---
4575 packets transmitted, 4462 received, 2% packet loss, time 4580228ms
rtt min/avg/max/mdev = 46.971/76.988/1074.077/63.938 ms, pipe 2

Which seems fine.

LE BIDEAU (elbc) wrote :

Yes, I think I can confirm this (not sure because I've been testing since yesterday but it is working for the moment), with utopic packages (kernel and firmware 1.136) on linux mint 17, I have been able to download big files all the night and this morning network still working.

kris (makkasi) on 2014-10-16
Changed in linux-firmware (Ubuntu):
status: Incomplete → Fix Released
LE BIDEAU (elbc) wrote :

Ok I think I know what's happening : When I'm connected to a 2.4 Ghz Network, connection is stable, disconnections comes only on 5 Ghz Network. Could someone test downloading big files on these two kind of networks to confirm ?

david wood (david-wood) wrote :

X1 Carbon 2014, Ubuntu 14.04, Intel 7260 wireless module, was definitely severely affected by this bug.

Have been "relatively" stable with:

1. In the /usr/lib/pm-utils/power.d directory in the file wireless I changed in the end of the file with two off so that there is no wireless powersave:
case $1 in
    true) wireless_powersave off ;;
    false) wireless_powersave off ;;
    *) exit $NA ;;
esac
2. I also blacklisted wireless power management creating blacklist file :
sudo nano /etc/pm/config.d/blacklist
HOOK_BLACKLIST="wireless"
3. Kernel from Seth Forshee, http://people.canonical.com/~sforshee/iwl-ltr/trusty/ - In other words, 3.13.0-37_3.13.0-37.64+iwlltr0001
4. loaded firmware version 22.24.8.0 op_mode iwlmvm
5. linux-firmware 1.127.7

By this I mean, definitely able to stress the network and only 1-3 incidents of failure within 3 days, which is at least a couple orders of magnitude better than stock 14.04, and I can't say for certain yet if it isn't just working now. I have a subjective sense that the wifi is still not completely solid, but no hard evidence. I have not yet observed a difference between 2.4Ghz and 5Ghz (or N/AC or different channels, etc).

If there's anything else it'd be useful to report - or test - please don't hesitate to ask.

LE BIDEAU (elbc) wrote :

still have disconnections, no matter which kind of network ...

Lior Goikhburg (goikhburg) wrote :

Having disconnects with this kernel http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.17-utopic/
And this firmware http://wireless.kernel.org/en/users/Drivers/iwlwifi?action=AttachFile&do=get&target=iwlwifi-7260-ucode-25.228.9.0.tgz

seeing this a lot in my dmesg:

[91059.976451] wlan0: deauthenticated from d4:ca:6d:0d:e3:ad (Reason: 16=GROUP_KEY_HANDSHAKE_TIMEOUT)
[91060.007299] cfg80211: Calling CRDA to update world regulatory domain
[91060.009159] cfg80211: World regulatory domain updated:
[91060.009162] cfg80211: DFS Master region: unset
[91060.009163] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[91060.009165] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[91060.009166] cfg80211: (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[91060.009168] cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm), (N/A)
[91060.009169] cfg80211: (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[91060.009170] cfg80211: (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[91060.009185] cfg80211: Calling CRDA for country: RU
[91060.011209] cfg80211: Regulatory domain changed to country: RU
[91060.011212] cfg80211: DFS Master region: unset
[91060.011213] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[91060.011215] cfg80211: (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[91060.011217] cfg80211: (5735000 KHz - 5835000 KHz @ 20000 KHz), (N/A, 3000 mBm), (N/A)
[91061.344818] wlan0: authenticate with d4:ca:6d:0d:e3:ad
[91061.346860] wlan0: send auth to d4:ca:6d:0d:e3:ad (try 1/3)
[91061.348595] wlan0: authenticated
[91061.352076] wlan0: associate with d4:ca:6d:0d:e3:ad (try 1/3)
[91061.359677] wlan0: RX AssocResp from d4:ca:6d:0d:e3:ad (capab=0x431 status=0 aid=2)
[91061.361415] wlan0: associated

LE BIDEAU (elbc) wrote :

why is this issue not open again ? Apparently it is still an issue with upstream distributions ...

Seth Forshee (sforshee) wrote :

The bug reporter indicated that his problems were fixed, so the bug has been marked as fixed. If you are still having problems then they are most likely not exactly the same as his issue and should thus be the subject of a different bug report. It's not uncommon with wireless to have similar symptoms with a different root cause. Please open a new bug by running 'ubuntu-bug linux' from a terminal after you've been experiencing problems. Thanks!

As explained above, the problem is "fixed".
What is planned for the correction ?
  - only a work around as described by david wood (2014-10-18)
  - correction into Trusty and/or Utopic and/or Vivid
Thanks to all for investigations (I have the problem on 3 PC I manage) !

Jorge Niedbalski (niedbalski) wrote :

I am still seeing severe issues with firmware iwlwifi-7260-9.ucode and kernel 3.16.0-30-generic from Utopic.

Please note that upstream kernel has updated to iwlwifi-7260-10.ucode ( http://git.kernel.org/cgit/linux/kernel/git/iwlwifi/linux-firmware.git/commit/?id=c3d350ee05a8cf15c119af0fd1a60cd8595379c2 )

Changed in linux-firmware (Ubuntu):
status: Fix Released → Triaged
Daniel Schwen (lp-schwen) wrote :

While this may certainly be a driver bug, all my disconnection issues vanished after upgrading to a new WiFi router.

Old router with iwlwifi disconnect issues:
BUFFALO|WHR-HP-G54 125M R

New Router without any problems:
TP-LINK| ARCHER C7 R

Not ideal, but apparently a feasible "workaround" (if you need a new router anyways).

Seth Forshee (sforshee) wrote :

I put up a test build of linux-firmware for vivid which contains a new firmware version which I've been told helps in at least some cases. I'd appreciate feedback from anyone running vivid who would like to give it a try.

http://people.canonical.com/~sforshee/lp1354975/linux-firmware_1.142~lp1354975v201502191014/

Note that this will not help for any previous releases as the firmware which has been updated will not be used by the 14.04 or 14.10 kernels.

Changed in linux-firmware (Ubuntu):
status: Triaged → Incomplete
Arno (idfafp) wrote :

Hi, I encounter the same issue on an Asus Zenbook UX303LA with an Intel 7260 6b with Ubuntu 14.10, but only on my box : when I use tethering with my Android phone, the connection is stable.

Launchpad Janitor (janitor) wrote :
Download full text (3.4 KiB)

This bug was fixed in the package linux-firmware - 1.143

---------------
linux-firmware (1.143) vivid; urgency=medium

  * Rebase against git://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git cef33368c4d3425f11306496f0250f8ef1cf3c1f
    rtl_nic: update firmware for RTL8168H and RTL8107E
    linux-firmware: Fix qat_895xcc.bin permissions
    linux-firmware: Add QLogic BR Series Adapter Firmware
    linux-firmware: Fix firmware files with executable permission set

  [ Leann Ogasawara ]

  * UBUNTU: Add bnx2x firmware to linux-firmware udeb
    -LP: #1424884

linux-firmware (1.142) vivid; urgency=medium

  * Rebase against git://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git 17657c35869baa999b454e868cd3d5a7e1656425
    linux-firmware: update Marvell USB8797-B0 firmware image
    linux-firmware: update Marvell SD8897-B0 firmware combo image
    linux-firmware: update Marvell PCIe/USB 8897-B0 firmware combo image
    linux-firmware: add Marvell USB8897-B0 firmware combo image
    linux-firmware: update Marvell 8897-B0 firmware images to p73
    linux-firmware: update Marvell SD8787 firmware version p192
    linux-firmware: update Marvell SD8787 firmware version p52
    linux-firmware: update Marvell 8897-B0 firmware images to p103
    linux-firmware: update WHENCE file for Marvell 8897 FW versions
    linux-firmware: update Marvell USB8797-B0 firmware image
    linux-firmware: add Marvell 8887-A2 firmware image
    linux-firmware: add Marvell USB8766-A0 firmware combo image
    linux-firmware: update Marvell 8897-B0 firmware images to p106
    rtlwifi: rtl8192ee: New firmware from Realtek
    linux-firmware: update Marvell 8897-B0 firmware images to p112
    linux-firmware: update Marvell USB8797-B0 firmware image
    linux-firmware: update Marvell SD8897-B0 firmware combo image
    linux-firmware: update Marvell PCIe/USB 8897-B0 firmware combo image
    linux-firmware: add Marvell USB8897-B0 firmware combo image
    linux-firmware: update Marvell 8897-B0 firmware images to p73
    linux-firmware: update Marvell SD8787 firmware version p192
    linux-firmware: update Marvell SD8787 firmware version p52
    linux-firmware: update Marvell 8897-B0 firmware images to p103
    linux-firmware: update WHENCE file for Marvell 8897 FW versions
    linux-firmware: update Marvell USB8797-B0 firmware image
    linux-firmware: add Marvell 8887-A2 firmware image
    linux-firmware: add Marvell USB8766-A0 firmware combo image
    linux-firmware: update Marvell 8897-B0 firmware images to p106
    linux-firmware: update Marvell 8897-B0 firmware images to p112
    Merge branch 'marvell-mwifiex'
    linux-firmware: update firmware for Intel Broadwell SST DSP
    linux-firmware: add sst audio firmware for braswell platforms
    Fix WHENCE entry for smsmdtv
    iwlwifi: add new -12 firmware for 3160 / 7260 / 7265 / 7265D
    linux-firmware: Update firmware patch for Intel Bluetooth 7260 (B3)
    linux-firmware: Update firmware patch for Intel Bluetooth 7260 (B4)
    linux-firmware: Update firmware patch for Intel Bluetooth 7260 (B5)
    linux-firmware: Update firmware patch for Intel Bluetooth 7265 (C0)
    linux-firmware: Up...

Read more...

Changed in linux-firmware (Ubuntu):
status: Incomplete → Fix Released
Svenja (svenja-otten) wrote :

Can someone explain me what it means that a fix is released? When will this fix be available for me? I am using Ubuntu 14.04.2 LTS.
Thank you.

It means that Ubuntu Vivid (15.04) will contain the fix.
On Mar 21, 2015 9:10 PM, "Svenja" <email address hidden> wrote:

> Can someone explain me what it means that a fix is released? When will
> this fix be available for me? I am using Ubuntu 14.04.2 LTS.
> Thank you.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1354975
>
> Title:
> iwlwifi Intel 7260 Wifi disconnects
>
> Status in Unity Linux:
> New
> Status in linux-firmware package in Ubuntu:
> Fix Released
>
> Bug description:
> I experience frequent disconnects and auth issues, never more than 30
> minutes without a disconnect. Sometimes dozens of disconnects in a few
> minutes.
>
> This happens with the default 7260-8 firmware.
> Tried replacing the -8 with -9 ucode. Failed to load due to API version.
> This loaded the -7 driver which seems to be more stable.
>
> Tested against 2.4ghz APs (Apple, Netgear, Linksys).
>
> ProblemType: Bug
> DistroRelease: Ubuntu 14.04
> Package: linux-image-3.13.0-32-generic 3.13.0-32.57
> ProcVersionSignature: Ubuntu 3.13.0-32.57-generic 3.13.11.4
> Uname: Linux 3.13.0-32-generic x86_64
> ApportVersion: 2.14.1-0ubuntu3.3
> Architecture: amd64
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: steve 2577 F.... pulseaudio
> /dev/snd/controlC1: steve 2577 F.... pulseaudio
> CurrentDesktop: Unity
> Date: Sun Aug 10 17:49:06 2014
> HibernationDevice: RESUME=UUID=374a0c1c-4ac2-456b-a67e-9ea54fe11fe6
> InstallationDate: Installed on 2013-12-28 (225 days ago)
> InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64
> (20131016.1)
> MachineType: Dell Inc. XPS 12-9Q33
> ProcFB: 0 inteldrmfb
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-32-generic
> root=UUID=58deb355-7a09-440b-ade2-69a84fd74460 ro ipv6.disable=1 quiet
> splash vt.handoff=7
> RelatedPackageVersions:
> linux-restricted-modules-3.13.0-32-generic N/A
> linux-backports-modules-3.13.0-32-generic N/A
> linux-firmware 1.127.5
> SourcePackage: linux
> UpgradeStatus: Upgraded to trusty on 2014-07-06 (35 days ago)
> dmi.bios.date: 05/06/2013
> dmi.bios.vendor: Dell Inc.
> dmi.bios.version: A00
> dmi.board.name: XPS 12-9Q33
> dmi.board.vendor: Dell Inc.
> dmi.board.version: A00
> dmi.chassis.type: 8
> dmi.chassis.vendor: Dell Inc.
> dmi.chassis.version: Not Specified
> dmi.modalias:
> dmi:bvnDellInc.:bvrA00:bd05/06/2013:svnDellInc.:pnXPS12-9Q33:pvrA00:rvnDellInc.:rnXPS12-9Q33:rvrA00:cvnDellInc.:ct8:cvrNotSpecified:
> dmi.product.name: XPS 12-9Q33
> dmi.product.version: A00
> dmi.sys.vendor: Dell Inc.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/unitylinux/+bug/1354975/+subscriptions
>

Matthieu FAURE (mfaure) wrote :

I am on 14.04 and experiment the same issue. Is there a way to backport the fix ?

Brian C (brianwc) wrote :

I think I am still getting these disconnect issues on firmware iwlwifi-7260-12.ucode (25.16.12.0) on kernel 3.19. Is there something else that I should upgrade to fix this?

Claudio (claudio-enjoy) wrote :

@brianwc
I have unstable WiFi connection on my Thinkpad T440p with 7260-10 with kernel 3.19.0-6/ubuntu 14.10

Maybe this helps to identify some of the troubles: I suddenly experienced repeated disconnects with my Intel 7260 wifi after I switched my modem from a IPv6 to IPv4 internet connection. The modem is a Fritzbox 7360, but I use a D-Link DIR-655 wireless access point (on which I did not change any settings).

The wifi kept disconnecting, nearly every minute, until I switched the internet connection back to IPv6, what it was before. Now the wifi is rock-solid again.

I don't see how it is related, but there is a direct correlation here. So for what it's worth.

Alex (xpk) wrote :

Still an issue with ThinkPad X1 Gen2 on Ubuntu 15.04 (3.19.0-15 / 7260-12).

dmr (dradetsky) wrote :

I fixed this problem on my carbon x1 15.04 by turning off bluetooth with rfkill. I strongly encourage everyone looking at this thread to try doing this.

Background: https://wireless.wiki.kernel.org/en/users/documentation/bluetooth-coexistence

If you actually need bluetooth (I don't), iwlwifi has a driver specific param called bt_coex_active you might want to check out.

Alex (xpk) wrote :

I had disabled Bluetooth in BIOS so it is not related in my case.

$ rfkill list
0: phy0: Wireless LAN
 Soft blocked: no
 Hard blocked: no

Federico Sassi (fsassi) wrote :

On Lenovo T540p (Intel 7260 (rev 83), Ubuntu 14.04, kernel 3.19.1-031901, firmware version 25.15.12.0.

Performance is related to the access point.
With some access point the laptop would not even connect, with other it will connect but not in a stable way, while with others it
will work with no problems.

I'm trying to figure out a statistic but it is very weird...

SkyRaT (rene-pavlik) wrote :

@dradetsky
Thanks.
Fixed by disabling BT using rfkill on Kubuntu 15.04, kernel 3.19, on Lenovo T440s with Intel 7260 (rev 83)

spinxz (spinxz) wrote :

Same problem on Lenovo Carbon X1 gen2 with Intel Wireless 7260 (rev 83).
Using Ubuntu 15.04 with 3.19.0-21 kernel (x86_64).
Bluetooth is soft-blocked with rfkill but this does not solve the problem.

I constantly get disconnects:

wlan0: deauthenticating from ....... by local choice (Reason: 3=DEAUTH_LEAVING)

Alex (xpk) wrote :

I have worked around the issue by setting my wifi router to the 'up to 54 Mbit/s' mode instead of 300 Mbit/s as it was initially. A proper fix would still be much appreciated, but this way it at least stopped constantly disconnecting.

spinxz (spinxz) wrote :

I can confirm that 802.11ac mode seems to make the link more unstable - especially the 5 GHz network.

However, I discovered that with Ubuntu 15.04 and the 3.19.0-21 kernel, turning off power management improves the stability a lot.

Emmanuel Grumbach (egrumbach) wrote :

Intel just released this page, which can be helpful. I don't think that replacing the supplicant is a must. But using the latest driver / firmware seems to be helpful

gronki (gronki) wrote :

With Dell Inspiron 7537, I find connection with version 12 ucode very unstable. Version 9 works the best for me. Is there any way to make kernel use version 9 ucode in Ubuntu Vivid instead of 12?

Seth Forshee (sforshee) wrote :

On Sat, Jun 20, 2015 at 07:54:28PM -0000, gronki wrote:
> With Dell Inspiron 7537, I find connection with version 12 ucode very
> unstable. Version 9 works the best for me. Is there any way to make
> kernel use version 9 ucode in Ubuntu Vivid instead of 12?

@gronki (and others): Posting comments on bugs marked as fixed is
unlikely to get you anywhere. If the reporter's problem is fixed and
yours is not, then it stands to reason that you're suffering from a
different problem. Wireless bugs in particular can have very similar
symptoms with different root causes.

The best course of action is to file a new bug to focus specifically on
your issue your issue by running 'ubuntu-bug linux' from a terminal.
Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers