firmware for linux kernel drivers cannot install

Bug #1300218 reported by Zlatko on 2014-03-31
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux-firmware (Ubuntu)
Undecided
Unassigned

Bug Description

Hello,
I bought dell inspiron 3537 with ubuntu pre-installed. Immediately after turning on, ubuntu updated. First, I lost my wireless connection but could connect by a cable. I managed to fix that, but now it says that it has downloaded firmware for Linux kernel drivers but cannot install them. In details the following message is shown:
installArchives() failed: (Reading database ...
(Reading database ... 5%%
(Reading database ... 10%%
(Reading database ... 15%%
(Reading database ... 20%%
(Reading database ... 25%%
(Reading database ... 30%%
(Reading database ... 35%%
(Reading database ... 40%%
(Reading database ... 45%%
(Reading database ... 50%%
(Reading database ... 55%%
(Reading database ... 60%%
(Reading database ... 65%%
(Reading database ... 70%%
(Reading database ... 75%%
(Reading database ... 80%%
(Reading database ... 85%%
(Reading database ... 90%%
(Reading database ... 95%%
(Reading database ... 100%%
(Reading database ... 214477 files and directories currently installed.)
Preparing to replace linux-firmware 1.79.1 (using .../linux-firmware_1.79.10_all.deb) ...
Unpacking replacement linux-firmware ...
dpkg: error processing /var/cache/apt/archives/linux-firmware_1.79.10_all.deb (--unpack):
 trying to overwrite '/lib/firmware/ar3k/ramps_0x31010000_40.dfu', which is also in package bt-dw1705-firmware 0.1
No apport report written because MaxReports is reached already
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/linux-firmware_1.79.10_all.deb

I am really new to ubuntu and this whole process is new to me, so I think I might have messed up somewhere. What should I do to fix this?
Everything else works fine. I mean, the whole system works fine apart for this installation process.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.5.0-47-generic 3.5.0-47.71~precise1
ProcVersionSignature: Ubuntu 3.5.0-47.71~precise1-generic 3.5.7.30
Uname: Linux 3.5.0-47-generic x86_64
NonfreeKernelModules: fglrx
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.25.
ApportVersion: 2.0.1-0ubuntu17.6
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 1: PCH [HDA Intel PCH], device 0: ALC283 Analog [ALC283 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: zlatko 2172 F.... pulseaudio
 /dev/snd/controlC0: zlatko 2172 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'MID'/'HDA Intel MID at 0xc0810000 irq 63'
   Mixer name : 'Intel Haswell HDMI'
   Components : 'HDA:80862807,80860101,00100000'
   Controls : 6
   Simple ctrls : 1
Card0.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Card1.Amixer.info:
 Card hw:1 'PCH'/'HDA Intel PCH at 0xc0814000 irq 64'
   Mixer name : 'Realtek ALC283'
   Components : 'HDA:10ec0283,102805ea,00100003'
   Controls : 23
   Simple ctrls : 12
Date: Mon Mar 31 14:56:44 2014
DistributionChannelDescriptor:
 # This is a distribution channel descriptor
 # For more information see http://wiki.ubuntu.com/DistributionChannelDescriptor
 canonical-oem-somerville-precise-amd64-20130203-1
HibernationDevice: RESUME=UUID=ce2c08b7-3615-4cc3-af1d-d34ef0ccf332
InstallationMedia: Ubuntu 12.04 "Precise" - Build amd64 LIVE Binary 20130203-13:50
MachineType: Dell Inc. Inspiron 3537
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-47-generic root=UUID=870a5c69-c2cd-4574-aeaf-50c6670cdece ro radeon.modeset=0 quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-47-generic N/A
 linux-backports-modules-3.5.0-47-generic N/A
 linux-firmware 1.79.1
SourcePackage: linux-lts-quantal
StagingDrivers: rts5139
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/12/2013
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A07
dmi.board.name: 0N7YKW
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A07
dmi.modalias: dmi:bvnDellInc.:bvrA07:bd11/12/2013:svnDellInc.:pnInspiron3537:pvrA07:rvnDellInc.:rn0N7YKW:rvrA00:cvnDellInc.:ct8:cvrA07:
dmi.product.name: Inspiron 3537
dmi.product.version: A07
dmi.sys.vendor: Dell Inc.

Zlatko (zsmetisko) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux-lts-quantal (Ubuntu):
status: New → Confirmed
tags: added: bios-outdated-a08
affects: linux-lts-quantal (Ubuntu) → linux-firmware (Ubuntu)
Changed in linux-firmware (Ubuntu):
status: Confirmed → New
Daniel van Vugt (vanvugt) wrote :

Thank you for reporting this bug to Ubuntu.
Ubuntu 12.04 (precise) reached end-of-life on April 28, 2017.

See this document for currently supported Ubuntu releases:
https://wiki.ubuntu.com/Releases

We appreciate that this bug may be old and you might not be interested in discussing it any more. But if you are then please upgrade to the latest Ubuntu version and re-test. If you then find the bug is still present in the newer Ubuntu version, please add a comment here telling us which new version it is in and change the bug status to Confirmed.

Changed in linux-firmware (Ubuntu):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers