rtl8192ce fails to load firmware

Bug #1239414 reported by Koen Roggemans on 2013-10-13
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux-firmware (Ubuntu)
Medium
Unassigned
Precise
Medium
Unassigned

Bug Description

Ubuntu 12.04.3 LTS
linux-firmware 1.79.6

Wireless for Realtek rtl8188ce, based on the module r8192ce, is broken on kernel 3.2.0 since arround release 40.

The error message in dmesg is:
rtl8192ce:rtl92c_init_sw_vars():<0-0> Failed to request firmware!
rtlwifi: rtl_pic_probe():<0-0> Can't init_sw_vars.
rtl8192ce 0000:02:00.0: PCI INT A disabled

Possible cause:
I figured out that it is probably broken, because of updating the drivers in the kernel (see http://git.kernel.org/cgit/linux/kernel/git/stable/linux-stable.git/log/?h=linux-3.2.y&id=e6deaf810cc4b6437d55179660776e131ac059df&qt=grep&q=rtl8192ce&showmsg=1) without updating to the new firmware. That firmware is never added to the linux-firmware package. (rtl8192cfw.bin dates from 2010).

Working solution:
Simply copying the firmware, downloaded from the Realtek website to /lib/firmware/rtlwifi makes wifi work again on kernel 3.2.0-54-generic-pae

Link to the package, containing the firmware: http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=48&PFid=48&Level=5&Conn=4&DownTypeID=3&GetDown=false&Downloads=true#2722

 Please add the new firmware to the linux-firmware package.

Koen Roggemans (koen-roggemans) wrote :
Download full text (3.3 KiB)

More details:

With a clean install of Ubuntu 12.04, upgraded to kernel 3.2.0-54, wireless does not work: error in dmesg "Failed to request firmware!"

From modinfo: required firmware:
firmware: rtlwifi/rtl8192cfwU_B.bin
firmware: rtlwifi/rtl8192cfwU.bin
firmware: rtlwifi/rtl8192cfw.bin

From Larry Finger I received the list of what is found in the kernel git repo for linux-firmware. While testing this, I noticed that rtl8192cfwU_B.bin and rtl8192cfwU.bin where missing and requested by the driver. Copying those two files from the Realtek website makes my wifi work again :-).

missing in the Ubuntu installation:
rtl8188efw
rtl8188eufw
rtl8192cfwU_B
rtl8192cfwU
rtl8192cufw_A
rtl8192cufw_B
rtl8192cufw_TMSC

different:
rtl8192defw
rtl8192sefw
rtl8712u

the same:
rtl8192cfw
rtl8192cufw
rtl8723fw_B
rtl8723fw

Details of test machine:
test@test-Intel-powered-classmate-PC:/lib/firmware$ md5sum rtlwifi/*
748944fbffd3b08b5b1929bb6c7fc537 rtlwifi/rtl8192cfw.bin
943e9b714a926e630b8152d7aad91d2e rtlwifi/rtl8192cufw.bin
7a3b61dbd72e0efb22f892ece8020994 rtlwifi/rtl8192defw.bin
bccf9bf2276621770f101a60736b4004 rtlwifi/rtl8192sefw.bin
8e6396b5844a3e279ae8679555dec3f0 rtlwifi/rtl8712u.bin
ce50dfe07dbb1bfe9e14bdb315a4b28a rtlwifi/rtl8723fw_B.bin
69ccaffbe94cc0ef1b89c25290e19b2e rtlwifi/rtl8723fw.bin
test@test-Intel-powered-classmate-PC:/lib/firmware$ ls -l rtlwifi/
totaal 308
-rw-r--r-- 1 root root 13540 dec 11 2012 rtl8192cfw.bin
-rw-r--r-- 1 root root 16014 dec 11 2012 rtl8192cufw.bin
-rw-r--r-- 1 root root 20526 dec 11 2012 rtl8192defw.bin
-rw-r--r-- 1 root root 88856 dec 11 2012 rtl8192sefw.bin
-rw-r--r-- 1 root root 129304 dec 11 2012 rtl8712u.bin
-rwxr-xr-x 1 root root 22996 jul 11 14:43 rtl8723fw_B.bin
-rwxr-xr-x 1 root root 11662 jul 11 14:43 rtl8723fw.bin

test@test-Intel-powered-classmate-PC:/lib/firmware$ modinfo rtl8192ce
filename: /lib/modules/3.2.0-54-generic-pae/kernel/drivers/net/wireless/rtlwifi/rtl8192ce/rtl8192ce.ko
firmware: rtlwifi/rtl8192cfwU_B.bin
firmware: rtlwifi/rtl8192cfwU.bin
firmware: rtlwifi/rtl8192cfw.bin
description: Realtek 8192C/8188C 802.11n PCI wireless
license: GPL
author: Larry Finger <email address hidden>
author: Realtek WlanFAE <email address hidden>
author: lizhaoming <email address hidden>
srcversion: DA52BF758B7683607AFCB85
alias: pci:v000010ECd00008176sv*sd*bc*sc*i*
alias: pci:v000010ECd00008177sv*sd*bc*sc*i*
alias: pci:v000010ECd00008178sv*sd*bc*sc*i*
alias: pci:v000010ECd00008191sv*sd*bc*sc*i*
depends: rtlwifi,rtl8192c-common,mac80211
intree: Y
vermagic: 3.2.0-54-generic-pae SMP mod_unload modversions 686
parm: swenc:Set to 1 for software crypto (default 0)
 (bool)
parm: ips:Set to 0 to not use link power save (default 1)
 (bool)
parm: swlps:Set to 1 to use SW control power save (default 0)
 (bool)
parm: fwlps:Set to 1 to use FW control power save (default 1)
 (bool)
parm: debug:Set debug level (0-5) (default 0) (int)

*-network UNCLAIMED
                description: Network controller
                product: RTL8188CE 802.11b/g/n WiFi Adapter
                vendor: Realtek Semiconductor Co., Ltd.
                physical id: 0
                bus info: pci@0000:02:00.0
                version: 01
  ...

Read more...

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux-firmware (Ubuntu):
status: New → Confirmed
Tim Gardner (timg-tpi) on 2013-10-15
Changed in linux-firmware (Ubuntu Precise):
status: New → In Progress
Changed in linux-firmware (Ubuntu):
status: Confirmed → Fix Released
Tim Gardner (timg-tpi) wrote :

SRU Justification

Impact: rtl8192ce fails to load firmware

Patch description: Add 2 new firmware files in support of this driver. Upstream linux-firmware cherry-pick e0836e6ec3568f54b7fac24b9e17bbe8c46eb508 adds these 2 new files while also updating firmware files for rtl8192se and rtl8192de to match behaviors expected by the 3.2 kernel.

Hello Koen, or anyone else affected,

Accepted linux-firmware into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/linux-firmware/1.79.7 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in linux-firmware (Ubuntu Precise):
status: In Progress → Fix Committed
Changed in linux-firmware (Ubuntu):
importance: Undecided → Medium
Changed in linux-firmware (Ubuntu Precise):
importance: Undecided → Medium
Koen Roggemans (koen-roggemans) wrote :

Sorry, I can't test earlier then Thursday.
It might be worth while to add the other 5 files too that are in the kernel git. Not necessary for me though.

I notice that synchronising this with e0836e6ec3568f54b7fac24b9e17bbe8c46eb508 has been done for quantal over a year ago (http://launchpadlibrarian.net/109671324/linux-firmware_1.83_source.changes). I know the 3.2.0 is an old kernel to maintain, but it is LTS and necessary for everyone on Intel Cedartrail hardware :-(.

Koen Roggemans (koen-roggemans) wrote :

Performed test:
Clean install Ubuntu 12.04
uname -r 3.2.0-29-generic-pae
enable proposed
apt-get update && apt-get upgrade
uname -r 3.2.0-29-generic-pae
wifi works

apt-get update && apt-get upgrade
uname -r 3.2.0.55-generic-pae
wifi works :-)

(details in attachments)

Koen Roggemans (koen-roggemans) wrote :
description: updated
Koen Roggemans (koen-roggemans) wrote :

I have tested the setup with 3 different access points and the connection is fair to good.

I'm not familiar with the process involved in transferring fixed bugs from proposed to updates.

What time frame do I have to take into account before this happens?
Is there any way I can help in the process?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-firmware - 1.79.7

---------------
linux-firmware (1.79.7) precise-proposed; urgency=low

  * rtlwifi: rtl8192ce: rtl8192se: rtl8192de: Update to rtl_92ce_92se_92de_linux_mac80211_0004.0816.2011 driver
    Upstream cherry-pick e0836e6ec3568f54b7fac24b9e17bbe8c46eb508
    Adds new firmware files rtlwifi/rtl8192cfwU.bin and rtlwifi/rtl8192cfwU_B.bin in support of linux v3.2
    Updates for rtl8192se and rtl8192de
    -LP: #1239414
 -- Tim Gardner <email address hidden> Tue, 15 Oct 2013 09:05:29 -0600

Changed in linux-firmware (Ubuntu Precise):
status: Fix Committed → Fix Released
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers