Possible missing firmware /lib/firmware/radeon/*.bin

Bug #1218691 reported by Phill Whiteside on 2013-08-30
70
This bug affects 14 people
Affects Status Importance Assigned to Milestone
firmware-nonfree (Debian)
Fix Released
Unknown
linux-firmware (Ubuntu)
Low
Tim Gardner
Saucy
Low
Tim Gardner

Bug Description

When updating the kernel today to 3.11.0-4-generic I saw the same warning messages I saw when I upgraded to 3.11.0-3-generic

update-initramfs: Generating /boot/initrd.img-3.11.0-4-generic
W: Possible missing firmware /lib/firmware/radeon/KAVERI_sdma.bin for module radeon
W: Possible missing firmware /lib/firmware/radeon/KAVERI_rlc.bin for module radeon
W: Possible missing firmware /lib/firmware/radeon/KAVERI_mec.bin for module radeon
W: Possible missing firmware /lib/firmware/radeon/KAVERI_ce.bin for module radeon
W: Possible missing firmware /lib/firmware/radeon/KAVERI_me.bin for module radeon
W: Possible missing firmware /lib/firmware/radeon/KAVERI_pfp.bin for module radeon

Further digging found bug 1183777

As mentioned in that bug, I did contact the named person:

"Hi,

I'm still seeing the errors for
KAVERI firmwares
being missing in the latest kernel :
phillw@piglet:~$ uname -a
Linux piglet 3.11.0-3-generic #8-Ubuntu SMP Fri Aug 23 16:49:15 UTC 2013
x86_64 x86_64 x86_64 GNU/Linux
As the 1st Beta is creeping up fast, do you need this raising as a new
bug?
Regards,
Phill."

The reply is:

"As far as I can tell, the KAVERI firmware (and hardware) is not publicly available yet, so that's not a bug with the linux-firmware package. If you want to file a new bug about the warning messages, please file it against the linux (kernel) package. Until the firmware is available, I'm not really sure what the fix for that would be, other than removing/commenting out the relevant Kaveri lines in the radeon kernel code."

Please find attached bug report as requested.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: linux-image-3.11.0-4-generic 3.11.0-4.9
ProcVersionSignature: Ubuntu 3.11.0-3.8-generic 3.11.0-rc6
Uname: Linux 3.11.0-3-generic x86_64
ApportVersion: 2.12.1-0ubuntu2
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: phillw 1965 F.... lxpanel
CRDA: Error: [Errno 2] No such file or directory: 'iw'
Date: Fri Aug 30 02:37:54 2013
HibernationDevice: RESUME=UUID=d98ac0ad-5c96-4382-8195-23b44e056358
InstallationDate: Installed on 2013-06-29 (61 days ago)
InstallationMedia: Lubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130628)
MachineType: Packard Bell EasyNote LJ71
MarkForUpload: True
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcFB: 0 radeondrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.11.0-3-generic root=UUID=69c7aa0f-ccd0-4ac4-8930-e6f0efda9e6b ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.11.0-3-generic N/A
 linux-backports-modules-3.11.0-3-generic N/A
 linux-firmware 1.113
SourcePackage: linux
StagingDrivers: zram
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 09/22/2009
dmi.bios.vendor: Packard Bell
dmi.bios.version: V1.03
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: EasyNote LJ71
dmi.board.vendor: Packard Bell
dmi.board.version: V1.03
dmi.chassis.type: 10
dmi.chassis.vendor: Packard Bell
dmi.chassis.version: V1.03
dmi.modalias: dmi:bvnPackardBell:bvrV1.03:bd09/22/2009:svnPackardBell:pnEasyNoteLJ71:pvrV1.03:rvnPackardBell:rnEasyNoteLJ71:rvrV1.03:cvnPackardBell:ct10:cvrV1.03:
dmi.product.name: EasyNote LJ71
dmi.product.version: V1.03
dmi.sys.vendor: Packard Bell

Phill Whiteside (phillw) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed

The error messages are annoying, but do not affect function. Still, if the firmware is not going to be available by Saucy's release, it would be nice to see this resolved, since it may mislead users of older radeon GPU's into installing fglrx.Catalyst and borking their system.

Changed in linux (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged

The Kaveri firmware is available now: http://people.freedesktop.org/~agd5f/radeon_ucode/

affects: linux (Ubuntu) → linux-firmware (Ubuntu)

I think the next step is getting the kaveri files in: https://git.kernel.org/cgit/linux/kernel/git/firmware/linux-firmware.git/tree/radeon

I tried making a patched linux-firmware .deb, but I'm running into issues because I'm not used to dealing with binary files.

Andy Whitcroft (apw) wrote :

@Daniel -- where did those firmware files come from. We need to know the person offering them even has the right to offer them for us to download, and to put them in the official package we would need some kind of paper trail from the original owners of these files (presumably AMD).

Changed in debian:
status: Unknown → New

@apw: they're in Alex Deucher's (aka agd5f) repo. He is an AMD employee.

Hans-Peter (hanspeterg) wrote :

got a similar message yesterday when updating saucy. My graphics card is a
01:05.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RS780C [Radeon 3100]

Ben Hutchings (benh-debian) wrote :

KAVERI firmware is now included in linux-firmware.git

Tim Gardner (timg-tpi) on 2013-09-30
Changed in linux-firmware (Ubuntu Saucy):
assignee: nobody → Tim Gardner (timg-tpi)
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-firmware - 1.115

---------------
linux-firmware (1.115) saucy; urgency=low

  * Rebase against git://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git b8ac7c7e27dcd13fa3c843aaf62457e9c57ea4db
    linux-firmware: Add Brocade FC/FCOE Adapter firmware files
    radeon: add ucode for KAVERI GPUs (LP: #1218691)
    radeon: add smc ucode for BONAIRE
    linux-firmware: Add firmware patch file for Intel Bluetooth device(3160)
    linux-firmware: add version information for Intel Bluetooth firmware
    cw1200: Add SDD file for the Sagrad SG901-1091/1098 WLAN modules.
    moxa: Fix firmware file names.
 -- Tim Gardner <email address hidden> Mon, 30 Sep 2013 08:33:18 -0600

Changed in linux-firmware (Ubuntu Saucy):
status: Fix Committed → Fix Released
Changed in debian:
status: New → Fix Released
martin suc (martin-suc) wrote :

same bug in ubuntu 15.10

W: Possible missing firmware /lib/firmware/radeon/boniare_mc.bin for module amdgpu
W: Possible missing firmware /lib/firmware/radeon/mullins_sdma1.bin for module amdgpu
W: Possible missing firmware /lib/firmware/radeon/kabini_sdma1.bin for module amdgpu
W: Possible missing firmware /lib/firmware/radeon/kaveri_sdma1.bin for module amdgpu
W: Possible missing firmware /lib/firmware/radeon/hawaii_sdma1.bin for module amdgpu
W: Possible missing firmware /lib/firmware/radeon/bonaire_sdma1.bin for module amdgpu
W: Possible missing firmware /lib/firmware/radeon/mullins_uvd.bin for module amdgpu
W: Possible missing firmware /lib/firmware/radeon/hawaii_uvd.bin for module amdgpu
W: Possible missing firmware /lib/firmware/radeon/kaveri_uvd.bin for module amdgpu
W: Possible missing firmware /lib/firmware/radeon/kabini_uvd.bin for module amdgpu
W: Possible missing firmware /lib/firmware/radeon/bonaire_uvd.bin for module amdgpu
W: Possible missing firmware /lib/firmware/radeon/mullins_vce.bin for module amdgpu
W: Possible missing firmware /lib/firmware/radeon/hawaii_vce.bin for module amdgpu
W: Possible missing firmware /lib/firmware/radeon/kaveri_vce.bin for module amdgpu
W: Possible missing firmware /lib/firmware/radeon/kabini_vce.bin for module amdgpu
W: Possible missing firmware /lib/firmware/radeon/bonaire_vce.bin for module amdgpu

reproducible by run update-initramfs -u -k all

tags: added: wily
summary: - Possible missing firmware /lib/firmware/radeon/KAVERI
+ Possible missing firmware /lib/firmware/radeon/*.bin
madbiologist (me-again) wrote :

@Martin Suc - You actually have a different (albeit related) bug. This bug is about the radeon module. Your bug is abou the amdgpu module, which is the driver to support the Radeon R9 285 "Tonga" and all future GPUs, including Carrizo APUs and the to-be-supported Fiji/Fury GPUs. This AMDGPU driver will live alongside the current "Radeon" DRM driver as the kernel components to AMD's open-source Linux driver offering.

The amdgpu module and it's associated firmware is optional for the GPUs listed in comment #11.

mrl586 (mrl586) wrote :

Maybe we should offer those optional firmware files for Ubuntu users.

madbiologist (me-again) wrote :

That might be a good idea, so as to avoid alarming users. The best way to get that process underway would be to file a new bug report.

affects: debian → firmware-nonfree (Debian)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.