Updating of Atheros firmware for ath9k_htc

Bug #1188459 reported by Teg on 2013-06-07
38
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Debian
Fix Released
Unknown
linux-firmware (Ubuntu)
Undecided
Unassigned

Bug Description

The current linux-firmware package for Precise and above contains non-free firmware in a package meant to contain free firmware. Recently, the htc_7010.fw and htc_9721.fw firmwares were updated by Atheros and re-released under a free software license. More information at https://www.fsf.org/news/ryf-ce.rtification-thinkpenguin-usb-with-atheros-chip.

Recent firmware files can be obtained from http://jxself.org/ath9k-htc/version-1.3.2/ or from the source at https://github.com/qca/open-ath9k-htc-firmware

Please consider updating these two firmware files in a package update for supported Ubuntu versions when possible.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux-firmware (Ubuntu):
status: New → Confirmed
Changed in debian:
status: Unknown → New
Changed in debian:
status: New → Confirmed
Changed in debian:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.