Mini.iso doesn't load wireless drivers

Bug #1047092 reported by cariboo on 2012-09-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-firmware (Ubuntu)
Medium
Unassigned

Bug Description

Now that the alternate installation iso has been discontinued, the developers have suggest that the mini.iso/netinst.iso be used to replace it. THis is a wonderful idea, but the mini/netinst.iso doesn't support wireless devices. THis affects many of the user base that don't have access to an ethernet connection.

I tried using the mini.iso to install Quantal with only a known working wireless device, The install process detected that there was a wireless device plugged in, but not the make/model, so no drivers were loaded. THe device works well running Quantal this is the output of sudo lshw -C network:

*-network
       description: Wireless interface
       physical id: 1
       bus info: usb@1:7
       logical name: wlan0
       serial: 00:02:72:62:80:68
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=zd1211rw driverversion=3.5.0-13-generic firmware=4725 ip=192.168.0.22 link=yes multicast=yes wireless=IEEE 802.11bg

and the output of lsusb:

Bus 001 Device 004: ID 0ace:1215 ZyDAS ZD1211B 802.11g

Is there a way to gather any information about hardware detection and driver loading when running the mini.iso?

To reproduce the problem:

1. plug a usb wireless device in to a usb port
2. boot from the mini.iso
3. At the network setup screen select the wireless device from the list
4 enter the ESSID when asked
5. select wpa from the encryption type screen
6. enter the wpa password
7 go back to step 4

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1047092

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: quantal
cariboo (cariboo) on 2012-09-06
Changed in linux (Ubuntu):
status: Incomplete → New
Brad Figg (brad-figg) on 2012-09-07
Changed in linux (Ubuntu):
status: New → Incomplete
cariboo (cariboo) wrote :

I can't post any logs, as this is just booting from the mini.iso, pressing Alt-F2 brings me to a busybox console, pressing Alt-F4 shows the log output on screen, but there is no way to copy the output to a working system. I did take a picture of the log output on screen. Hope this helps.

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Confirmed
cariboo (cariboo) wrote :

It seems the problem is due to a missing firmware directory. In the regular Live CD there is a directory called /lib/firmware, where all the firmware files needed for wireless devices are located. In order for wireless device to work with the mini.iso this needs to be included.

tags: added: kernel-wifi
Colin Watson (cjwatson) wrote :

The netboot installer includes nic-usb-modules, which includes the zd1211rw driver. Contrary to the reporter's claim, the /lib/firmware directory *is* available (you can check this easily using the shell on Alt-F2), by way of the netboot installer also including nic-firmware. However, while the zd1211 firmware is in the linux-firmware deb, it is not in the nic-firmware udeb.

This will be a simple packaging fix in linux-firmware, so reassigning.

affects: linux (Ubuntu) → linux-firmware (Ubuntu)
Changed in linux-firmware (Ubuntu):
status: Confirmed → Triaged
Colin Watson (cjwatson) wrote :

Incidentally, as well as zd1211, you should add the zd1201 firmware while you're there. In general any network driver shipped in a udeb should have any firmware it requires from the linux-firmware package shipped in the nic-firmware udeb to match.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-firmware - 1.92

---------------
linux-firmware (1.92) quantal; urgency=low

  * Add zd1201.fw and zd1211/* to nic-firmware.lst
    -LP: #1047092
 -- Leann Ogasawara <email address hidden> Fri, 14 Sep 2012 06:22:04 -0700

Changed in linux-firmware (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers