Firmware needs updating for new pi 3 B+

Bug #1761483 reported by Adam Smith on 2018-04-05
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-firmware-raspi2 (Ubuntu)
Undecided
Unassigned
Bionic
High
Unassigned
raspi3-firmware (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned

Bug Description

[Impact]

 * The bionic release currently cannot boot on certain pi models (3B+, CM3+) due to outdated firmware.
 * This is fixed in the disco and eoan releases with firmware revision 20190215, however it would be nice to enable booting on these platforms for the current LTS release.

[Test Case]

 * Attempt to boot the current bionic release on a CM3+; it never gets past the rainbow screen.
 * Flash same image onto a CM3; it boots successfully.
 * Upgrade linux-firmware-raspi2 to the proposed revision. Reboot to ensure CM3 still boots successfully.
 * dd image onto CM3+
 * CM3+ should now boot successfully.

[Regression Potential]

 * Minimal regression potential; I've tested the updated firmware with bionic on a 3B, 3B+, CM3, and CM3+ (to ensure it fixes the issue on the plus platforms, and doesn't regress on the others). All boot successfully with the updated firmware.

[Other Info]

 * Tested with built package (linux-firmware-raspi2 1.20190215-0ubuntu4) in https://launchpad.net/~waveform/+archive/ubuntu/pkg
 * I can attach a debdiff if required, but I'm not sure how useful it'll be given that the important changes are simply updated binary blobs.
 * This is not the very latest firmware available from the github.com/raspberrypi/firmware repo (the very latest includes support for the pi4), but this is intentional (issues have been discovered when testing with the very latest firmware).

Original description:

A new raspberry pi (the 3 B+) was released in March 2018. To enable this to boot the firmware needs updating to the latest version.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1761483

tags: added: iso-testing
Dave Jones (waveform) wrote :

This is now fixed on eoan and disco (which have firmware versions 20190215) and can boot on 3B+ and CM3+. Hopefully Adam won't mind if I hijack his bug to SRU the changes back to bionic so it can boot on these too :)

Dave Jones (waveform) on 2019-07-22
description: updated
Changed in linux-firmware-raspi2 (Ubuntu):
status: New → In Progress
Łukasz Zemczak (sil2100) wrote :

Sponsored for bionic, waiting for SRU team approval. Note to SRU reviewers: this upload, along with the main firmware bump, also includes the addition of bluetooth firmware. This change, being part of the backport, has no effect on the images at all (so no risk of introducing a regression) but might be useful for the future when we decide to backport the bluetooth enablement pieces.

Changed in linux-firmware-raspi2 (Ubuntu):
status: In Progress → Fix Released
Changed in linux-firmware-raspi2 (Ubuntu Bionic):
status: New → In Progress
importance: Undecided → High

Hello Adam, or anyone else affected,

Accepted linux-firmware-raspi2 into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/linux-firmware-raspi2/1.20190215-0ubuntu0.18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in linux-firmware-raspi2 (Ubuntu Bionic):
status: In Progress → Fix Committed
Dave Jones (waveform) wrote :

Verification done with Pi 3B, 3B+, CM3, and CM3+. All went smoothly.

tags: added: verification-done-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-firmware-raspi2 - 1.20190215-0ubuntu0.18.04.1

---------------
linux-firmware-raspi2 (1.20190215-0ubuntu0.18.04.1) bionic; urgency=medium

  * SRU to bionic to support booting RPi 3B+ and CM3+ (LP: #1761483)
    - Update to release 1.20190215
    - Added firmwares for Bluetooth on Raspberry Pi 3B and 3B+
    - Updated d/copyright with comment about origin of bluetooth firmwares

 -- Dave Jones <email address hidden> Thu, 18 Jul 2019 12:27:29 +0000

Changed in linux-firmware-raspi2 (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for linux-firmware-raspi2 has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

David Oliver (d-oliver10) wrote :

This latest update contained RaspberryPi2/3 GPU firmware and bootloaders failed to install on my Raspberry Pi 3B+ running Ubuntu 18.04. All other packages installed properly using the Software Updater program. I have tried to reinstall RaspberryPi2/3 GPU firmware and bootloaders several times and the results are always the same. The attached screenshot shows the details.

Any help would be greatly appreciated.
Thanks,
David

Adam Smith (adamsmith) wrote :

@David that is a problem caused by a package installed from the Ubuntu Flavour Maker PPA. That ppa is maintained by Martin Wimpress and is used by his version of Ubuntu Mate for the pi. He needs to solve it for Ubuntu mate users. I suggest you raise a bug with him.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers