"ngene_18.fw" missing in linux-firmware-nonfree

Bug #938121 reported by fnu on 2012-02-21
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux-firmware-nonfree (Ubuntu)
Medium
Unassigned
Precise
Medium
Unassigned

Bug Description

TEST CASE:
- needs testing by someone with the right hardware

RISK POTENTIAL:
- low, the ngene cards are broken currently without the firmware so little that can break more

The firmware version "ngene_18.fw" is needed for "ngene.ko" in all Precise kernels, thankfully the these rock solid bits did found their way into upstream kernel.

But in linux-firmware-nonfree is only "ngene_fw.15", "ngene_fw.17" included. These to files could be dropped from my point of view, 15 ist far to old and hopefully not used anymore w/ Precise and 17 is unstable, it has IMHO never been officially released by the manufacturer.

===
lsb_release -rd
Description: Ubuntu precise (development branch)
Release: 12.04
===
apt-cache policy linux-firmware-nonfree
linux-firmware-nonfree:
  Installiert: (keine)
  Kandidat: 1.11
  Versionstabelle:
     1.11 0
        500 http://de.archive.ubuntu.com/ubuntu/ precise/multiverse amd64 Packages
===

fnu (fnu) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux-firmware-nonfree (Ubuntu):
status: New → Confirmed
Michael Vogt (mvo) wrote :

I uploaded a version of the package with this included to the PPA:
  https://launchpad.net/~mvo/+archive/linux-firmware-nonfree
I am happy to upload this to precise-proposed too once we got a chance to test the PPA.

fnu (fnu) wrote :

@Michael

Thx for the update. But we don't really need to test it, because we us this firmware since 2011, so far before I opened this case here. And as far as I could see you did only add "ngene_18.fw".

You can kick out the files "ngene_15.fw" && "ngene_17.fw", nobody is able to use it with Ubuntu 12.04 and further kernel drivers. Driver does search for the right firmware, no user can decide which one to use.

Ok, well yes and individual might be able to use "ngene_15.fw", if he does downgrade to any very old driver bits and this will be hard stuff. "ngene_17.fw" has never been used by any official released driver bits, strange enough it's part of the package ...

Cheers
fnu

Michael Vogt (mvo) wrote :

I uploaded this now to raring-proposed and precise-proposed. I hope the SRU team will accept it.

Changed in linux-firmware-nonfree (Ubuntu Precise):
status: New → In Progress
Changed in linux-firmware-nonfree (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → Medium
Changed in linux-firmware-nonfree (Ubuntu Precise):
importance: Undecided → Medium
Michael Vogt (mvo) on 2013-04-12
description: updated
fnu (fnu) wrote :

Dear Michael, finally good news, thx for the effort.

It seems some things need to mature quite a while ... ;-)

Hello fnu, or anyone else affected,

Accepted linux-firmware-nonfree into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/linux-firmware-nonfree/1.11ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in linux-firmware-nonfree (Ubuntu Precise):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-firmware-nonfree - 1.14ubuntu1

---------------
linux-firmware-nonfree (1.14ubuntu1) raring-proposed; urgency=low

  * Add ngene_18.fw (LP: #938121)
 -- Michael Vogt <email address hidden> Fri, 12 Apr 2013 20:14:25 +0200

Changed in linux-firmware-nonfree (Ubuntu):
status: In Progress → Fix Released
fnu (fnu) wrote :

Hello,

I did test the package from precise-proposed && raring upstream. "linux-firmware-nonfree" does contain the correct file "ngene_18.fw" for all effected Micronas based devices using DVB kernel module "ngene.ko". After installation each individual should see this in dmesg/kern.log:

----------
[ 4.037005] ngene: Found Digital Devices DuoFlex PCIe or miniPCIe
[ 4.040455] ngene: Device version 1
[ 4.041498] ngene: Loading firmware file ngene_18.fw.
----------

This firmware file is stable and used since end of 2010, start 2011 in our VDR environments.

Regards

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

tags: added: verification-done
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-firmware-nonfree - 1.11ubuntu2

---------------
linux-firmware-nonfree (1.11ubuntu2) precise-proposed; urgency=low

  * Add ngene_18.fw (LP: #938121)
 -- Michael Vogt <email address hidden> Fri, 12 Apr 2013 20:10:42 +0200

Changed in linux-firmware-nonfree (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers