Hauppauge WinTV MiniStick missing firmware

Bug #581238 reported by Tommy Vestermark on 2010-05-16
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux-firmware-nonfree (Ubuntu)
Wishlist
Chase Douglas

Bug Description

Binary package hint: linux-firmware

Hauppauge WinTV MiniStick does not work with Ubuntu 10.04 due to missing firmware file.

Relevant lsusb line:
Bus 001 Device 007: ID 2040:c000 Hauppauge

Relevant dmesg output:
[ 8747.520107] usb 1-6: new high speed USB device using ehci_hcd and address 7
[ 8747.654106] usb 1-6: configuration #1 chosen from 1 choice
[ 8747.655765] usb 1-6: firmware: requesting sms1xxx-hcw-55xxx-dvbt-02.fw
[ 8747.660939] smscore_set_device_mode: error -2 loading firmware: sms1xxx-hcw-55xxx-dvbt-02.fw, trying again with default firmware
[ 8747.660953] usb 1-6: firmware: requesting dvb_nova_12mhz_b0.inp
[ 8747.670090] smscore_set_device_mode: error -2 loading firmware: dvb_nova_12mhz_b0.inp
[ 8747.670098] smsusb_init_device: line: 383: smscore_start_device(...) failed

How To Fix:
$ wget http://www.steventoth.net/linux/sms1xxx/sms1xxx-hcw-55xxx-dvbt-02.fw
$ sudo mv sms1xxx-hcw-55xxx-dvbt-02.fw /lib/firmware/

And then it works as expected when the MiniStick is inserted!

Tommy Vestermark (tov) wrote :

I believe a newer firmware can be found by extracting it directly from the Hauppauge driver:
$ wget http://www.wintvcd.co.uk/drivers/WinTV-MiniStick_4_2_26_28027_WHQL.zip
$ unzip -j WinTV-MiniStick_4_2_26_28027_WHQL.zip driver17/hcw17dvb.1b0
$ sudo mv hcw17dvb.1b0 /lib/firmware/sms1xxx-hcw-55xxx-dvbt-02.fw

This procedure was inspired by this page: http://ubuconf.buron.eu/2010/03/changing-firmware-for-hauppage-wintv.html

This newer file differ from (is bigger than) the file downloaded from steventoth.net. I have tested with both files and not found any visible difference.

Chase Douglas (chasedouglas) wrote :

Tommy,

Please test out the linux-firmware-nonfree package at http://people.canonical.com/~cndougla/bugs/581238/linux-firmware-nonfree_1.9_all.deb. After installation, the firmware for this device should be present in /lib/firmware. Ensure that the hardware works correctly with the packaged firmware file. If you currently have the firmware file in /lib/firmware, please remove it before installing the package.

Thanks

Changed in linux-firmware (Ubuntu):
assignee: nobody → Chase Douglas (chasedouglas)
status: New → In Progress
importance: Undecided → Wishlist
affects: linux-firmware (Ubuntu) → linux-firmware-nonfree (Ubuntu)
Changed in linux-firmware-nonfree (Ubuntu):
status: In Progress → Incomplete
Chase Douglas (chasedouglas) wrote :

Since the firmware is a new file and there hasn't been any testing by the submitter, I'm going to just assume it's ok. We can fix it later if there are issues, and there's no regression potential.

Changed in linux-firmware-nonfree (Ubuntu):
status: Incomplete → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-firmware-nonfree - 1.9

---------------
linux-firmware-nonfree (1.9) maverick; urgency=low

  * Update dvb-fe-tda10046.fw and dvb-ttpci-01.fw from upstream firmware
    script
  * Add sms1xxx-hcw-55xxx-dvbt-02.fw for Hauppauge WinTV MiniStick
    - LP: #581238
  * Update package description to be mindful of non-DVB firmware
 -- Chase Douglas <email address hidden> Mon, 24 May 2010 17:11:47 -0400

Changed in linux-firmware-nonfree (Ubuntu):
status: In Progress → Fix Released
Tommy Vestermark (tov) wrote :

Installed the package as requested (sorry for the delay). The firmware file is installed correctly and solves this bug. Thanks for the great work of Ubuntu!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers