dvb-usb-af9015 should be updated to the latest version to resolve some issues

Bug #458444 reported by Ofir Klinger on 2009-10-22
112
This bug affects 20 people
Affects Status Importance Assigned to Milestone
linux-firmware-nonfree (Ubuntu)
Low
Unassigned
Nominated for Jaunty by barberio
Nominated for Karmic by barberio
Nominated for Lucid by barberio

Bug Description

Binary package hint: linux-firmware-nonfree

The firmware that comes for af9015 is not the latest version and it has an issue that blasts dmesg with this two error messages:
af9015: command failed:255
dvb-usb: error while querying for an remote control event.

The latest firmware version 0.95 solves this issue:
http://www.otit.fi/~crope/v4l-dvb/af9015/af9015_firmware_cutter/firmware_files/4.95.0/

Related branches

Ofir Klinger (klinger-ofir) wrote :
Peter B. (puk007-gmail) wrote :

hi,

I'm facing problems in Karmic due to this old firmware with device: Genius TVGo DVB-T03
which is not working with firmware version: 4.65.0, but works OK with the latest version: 4.95

dmesg with old firmware:
[ 724.600132] usb 1-4: new high speed USB device using ehci_hcd and address 4
[ 724.754409] usb 1-4: configuration #1 chosen from 1 choice
[ 724.766560] dvb-usb: found a 'Genius TVGo DVB-T03' in cold state, will try to load a firmware
[ 724.766568] usb 1-4: firmware: requesting dvb-usb-af9015.fw
[ 724.773111] dvb-usb: downloading firmware from file 'dvb-usb-af9015.fw'
[ 724.831558] dvb-usb: found a 'Genius TVGo DVB-T03' in warm state.
[ 724.831641] dvb-usb: will pass the complete MPEG2 transport stream to the software demuxer.
[ 724.832432] DVB: registering new adapter (Genius TVGo DVB-T03)
[ 725.225745] af9013: firmware version:4.65.0
[ 725.230877] DVB: registering adapter 1 frontend 0 (Afatech AF9013 DVB-T)...
[ 725.231111] tda18271 8-00c0: creating new instance
[ 725.241505] TDA18271HD/C1 detected @ 8-00c0
[ 727.302787] af9015: bulk message failed:-110 (8/0)
[ 727.302796] af9013: I2C read failed reg:d417

with new:
[ 2716.120132] usb 1-4: new high speed USB device using ehci_hcd and address 8
[ 2716.276917] usb 1-4: configuration #1 chosen from 1 choice
[ 2716.289053] dvb-usb: found a 'Genius TVGo DVB-T03' in cold state, will try to load a firmware
[ 2716.289062] usb 1-4: firmware: requesting dvb-usb-af9015.fw
[ 2716.295308] dvb-usb: downloading firmware from file 'dvb-usb-af9015.fw'
[ 2716.368019] dvb-usb: found a 'Genius TVGo DVB-T03' in warm state.
[ 2716.368105] dvb-usb: will pass the complete MPEG2 transport stream to the software demuxer.
[ 2716.368456] DVB: registering new adapter (Genius TVGo DVB-T03)
[ 2716.757015] af9013: firmware version:4.95.0
[ 2716.762693] DVB: registering adapter 2 frontend 0 (Afatech AF9013 DVB-T)...
[ 2716.762926] tda18271 10-00c0: creating new instance
[ 2716.773443] TDA18271HD/C1 detected @ 10-00c0
[ 2717.140148] dvb-usb: Genius TVGo DVB-T03 successfully initialized and connected.

please fix, because it might make non-tech people feel like this HW is not supported.

thanks

Babstar (debian-lists) wrote :

I can also confirm this bug.

Changed in linux-firmware-nonfree (Ubuntu):
status: New → Confirmed
barberio (barberio) wrote :

(copy-paste from the earlier duplicate)
Confirming this.

The distributed firmware currently at /lib/firmware/dvb-usb-af9015.fw is an old buggy version.

[ 12.559817] dvb-usb: downloading firmware from file 'dvb-usb-af9015.fw'
[ 13.327234] af9013: firmware version:4.65.0
[ 14.083895] af9013: firmware version:4.65.0

This version is known to not work at all with some dual tuner af9013 devices, and the current firmware used for these devices is version 4.95.0.

To fix, the new firmware has to be installed. The device must be removed from usb, ideally plugged into another computer to have it's firmware purged, and then replugged. If the device is detected in a 'warm state' the new firmware will not be loaded, and you'll need unplug it again, and try leaving it disconnected for a longish time.

Firmware 4.65.0 should be replaced with the above attached 4.95.0

Dirk (ubuntu-tobit) wrote :

You should note that this driver DOES NOT WORK with a (virtualbox, but probably others) KVM module installed into the kernel. This is probably because the driver is fiddling with the NMI and the KVM does not like this and attempts to stop access.

So if you have the latest firmware and it used to work without the KVM module, then that's yer problem.

rileyp (petervdv) wrote :

When I use firmware 4.65 the tuner works and lock on all available dvb tv stations but I get the repeated errors in dmesg.
"af9015: command failed:255
dvb-usb: error while querying for an remote control event."

When I use firmware 4.7~ and 4.95 I do not get the errors but the tuner will not lock on a station.
I am using karmic 2.6.31-14 with no updates in Australia
I do not need to use the remote as its on my headless backend.
Is there a way I can disable the polling altogether?

BernardB (b-launchpad) wrote :

rileyp: What hardware do you have?

You should be able to disable polling by passing remote=-1 to the dvb-usb-af9015 module. e.g.
echo "options dvb-usb-af9015 remote=-1" > /etc/modprobe.d/no-af9015-remote.conf
(and reload the module).

rileyp (petervdv) wrote :

Thankyou so much for your help BernardB
It worked as soon as I rebooted!
I have a winfast/leadtek gold dtv dongle.
A leadtek dtv1000s
a gigabyte ga-gc230d (intel atom) motherboard
1 gig of ram (will upgrade to 2gig shortly)
500g wd sata hdd
This polling issue has been annoying me for weeks as it has been stopping the back end from shutting down when not recording/or performing tasks.
Ive made and installed the drivers so many times its silly. (This could be part of my problem perhaps )
Item fixed!
I might buy another now its working!
Yippee!

rileyp (petervdv) wrote :

I havent tried simply adding the 4.95 firmware to a vanilla mythbuntu karmic install and seen what happens... It might just work!
I'll have a go when I get time. I've fiddled way to much with the make and install commands on this system knowing sweet stuff all about what is going on. In karmic one is supposed to install the full kernel source tree according to the mythtv wiki.
http://www.mythtv.org/wiki/Leadtek_Winfast_DTV_Dongle_Gold
I had/have no idea how to do this as I'm a linux noob.
I would like to know though!
Without the full kernel source tree the make fails with a heap of FIREDTV errors.
I over come this though by using this command which was suggested for a hauppage card with a simular requirement of the full kernel source tree.
"make CONFIG_DVB_FIREDTV:=n || return"
Yet the tuner still would not lock with anything but the 4.65 firmware. I was checking each time in dmesg to find out what firmware was loading.
I also noticed some people suggesting to install the firmware in /lib/firmware and others /lib/firmware/$(uname -r)/
what difference does this make?
I'd like to learn a lot more about this stuff
cheers
Rileyp
Thanks again BernardB You made my weekend!

Steven Brown (savvy-steve) wrote :

I have a couple of these Leadtek_Winfast_DTV_Dongle_Gold USB devices now. One I bought about a year ago and had been running fine in karmic after I downloaded the latest drivers and firmware (4.95). Locks onto channels and also the remote works without issue.

However I bought some more the other day with the idea of upgrading the box to dual tuners. The problem is that both the new devices I bought show the same problem as rileyp. Lock channels with 4.65 firmware but remote doesn't work. In the 4.95 firmware the remote works but the device rarely is able to get a lock on channels.

Not sure if this information is helpful as I'm not sure what differences there could be between the device I bought a year ago and the two I bought recently.

I believe the version of the firmware with the bundled CD for windows was 4.95. I also checked the latest version of the Windows drivers which seemed to contain a version 5.10 firmware but the linux drivers output errors after I tried to load up that firmware that it couldn't calibrate various systems and whatever. It also may have just been a problem with the dump I made from the Windows drivers.

I hope this information might help other people having similar issues with these devices.

Borris (djcomber) wrote :

KWorld PCI 160-2T seems to work in single tuner mode under 4.65 but when 4.95 is used it takes a long time to get lock, in most cases well over 1 min. I had to revert back to 4.65 simply to be able to get channel lock within seconds.

I removed the card and installed it in a windows PC and then back into the myth box just to be sure the firmware was updated, however no joy with getting 4.95 working as desired. I could not get the dual tuner to use both tuners on 4.95 either, each time I assign same source to multiple inputs I get both inputs no lock.

rileyp (petervdv) wrote :

 just an update for all and sundry.
I did a clean install of karmic and plugged in my leadtek gold usb tuner purchased ~3 weeks ago
It loads 4.65 firmware and works out of the box but has the polling issue with the remote.
I then removed and plugged into a windows pc and installed the 4.95 firmware on my karmic install.
I plugged it into karmic and it loaded the 4.95 firmware.
It would lock on channels but would take up to 2 minutes to lock.
The polling issue was not present.
So If you want a cheap tuner in Aus these are great for a mythtv backend where the remote isnt required.
All you need do is this:
echo "options dvb-usb-af9015 remote=-1" > /etc/modprobe.d/no-af9015-remote.conf
which will disable the polling and you have a cheap dvb tuner that works great.

Additional AF9015 updates (resolved, see end of thread, but require inclusion in kernel: ) http://ubuntuforums.org/showthread.php?p=8908743

Chase Douglas (chasedouglas) wrote :

Hello all,

I'm interested in helping fix this issue in Ubuntu, but I'm not sure exactly what the fix is. Does the Lucid kernel need an updated driver (totally new driver, or some patch to apply?), or just new firmware?

Thanks

Changed in linux-firmware-nonfree (Ubuntu):
status: Confirmed → Incomplete
importance: Undecided → Low
barberio (barberio) wrote :

Just new firmware, the firmware currently in linux-firmware-nonfree needs to be replaced with this one - http://www.otit.fi/~crope/v4l-dvb/af9015/af9015_firmware_cutter/firmware_files/4.95.0/

Changed in linux-firmware-nonfree (Ubuntu):
status: Incomplete → Fix Released
status: Fix Released → Confirmed
Chase Douglas (chasedouglas) wrote :

@barberio:

I see there's already a a dvb-fe-9015.fw file in lucid's linux-firmware-nonfree. It does differ from the file you linked to. Is the current linux-firmware-nonfree file incorrect?

Chase Douglas (chasedouglas) wrote :

In my last comment, I meant the dvb-usb-af9015.fw file.

Changed in linux-firmware-nonfree (Ubuntu):
status: Confirmed → Incomplete
Chase Douglas (chasedouglas) wrote :

Sorry, I got caught up doing some stuff, and when I came back I thought this bug was for a new firmware. After reading through again I see that the firmware needs to be updated. I'm working on this now.

Changed in linux-firmware-nonfree (Ubuntu):
assignee: nobody → Chase Douglas (chasedouglas)
status: Incomplete → In Progress
Chase Douglas (chasedouglas) wrote :

I've uploaded a test package to my ppa. Please install and test it:

$ sudo add-apt-repository ppa:chasedouglas/linux-firmware-nonfree
$ sudo apt-get update
$ sudo apt-get upgrade linux-firmware-nonfree

Thanks

Changed in linux-firmware-nonfree (Ubuntu):
status: In Progress → Incomplete
MarcRandolph (mrand) wrote :

Anders, B&M, Lasse Kärkkäinen, Ofir Klinger, typek_pb, or anyone else with a card that uses this firmware: sooner than later, could any of you test out the firmware that Chase has uploaded? Thanks!

I cannot get TV signal with either firmware. Apparently the signal level is too low here (which is quite strange, as it shouldn't). I get about 20 % with the small antenna connected, 15 % from the wall socket and 0 % with nothing connected.

@MarcRandolph & others. I've just tested on a fully patched but "clean" Lucid beta and I get the following error:

Apr 2 16:45:45 test-laptop kernel: [ 105.992119] usb 1-2: new high speed USB device using ehci_hcd and address 2
Apr 2 16:45:45 test-laptop kernel: [ 106.129562] usb 1-2: configuration #1 chosen from 1 choice
Apr 2 16:45:45 test-laptop kernel: [ 106.291874] af9015: tuner id:179 not supported, please report!
Apr 2 16:45:45 test-laptop kernel: [ 106.291936] usbcore: registered new interface driver dvb_usb_af9015
Apr 2 16:45:45 test-laptop kernel: [ 106.338251] usbcore: registered new interface driver hiddev
Apr 2 16:45:45 test-laptop kernel: [ 106.339243] usbcore: registered new interface driver usbhid
Apr 2 16:45:45 test-laptop kernel: [ 106.340619] usbhid: v2.6:USB HID core driver
Apr 2 16:48:41 test-laptop kernel: [ 282.288694] usb 1-2: USB disconnect, address 2
Apr 2 16:48:41 test-laptop kernel: [ 282.288883] dvb-usb: generic DVB-USB module successfully deinitialized and disconnected.

I followed the instructions to add the PPA, updated then ran
$ sudo apt-get upgrade linux-firmware-nonfree
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages have been kept back:
  parted udisks
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.

Could someone please advise on how to test further?

Also, please see additional info about the af9015: tuner id:179 not supported problem

https://patchwork.kernel.org/patch/82493/
http://ubuntuforums.org/showthread.php?t=606487&page=5 (and subsequent pages)

Changed in linux-firmware-nonfree (Ubuntu):
status: Incomplete → Confirmed
Chase Douglas (chasedouglas) wrote :

@Anders:

I wrote the wrong command to install the updated linux-firmware-nonfree package. The third command should be:

$ sudo apt-get install linux-firmware-nonfree

That will install the package if it wasn't already installed, and it will upgrade it if it was. Please try this and retest.

Thanks

Changed in linux-firmware-nonfree (Ubuntu):
status: Confirmed → Incomplete

Broken package in the PPA?

$ sudo apt-get install linux-firmware-nonfree
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed
  linux-firmware-nonfree
0 upgraded, 1 newly installed, 0 to remove and 2 not upgraded.
Need to get 1,517kB of archives.
After this operation, 2,953kB of additional disk space will be used.
Get: 1 http://ppa.launchpad.net/chasedouglas/linux-firmware-nonfree/ubuntu/ lucid/main linux-firmware-nonfree 1.8~ppa1 [1,517kB]
Fetched 1,517kB in 2s (631kB/s)
Selecting previously deselected package linux-firmware-nonfree.
(Reading database ... 176524 files and directories currently installed.)
Unpacking linux-firmware-nonfree (from .../linux-firmware-nonfree_1.8~ppa1_all.deb) ...
dpkg: error processing /var/cache/apt/archives/linux-firmware-nonfree_1.8~ppa1_all.deb (--unpack):
 trying to overwrite '/lib/firmware/v4l-cx23885-enc.fw', which is also in package linux-firmware 0:1.33
E: Sub-process /usr/bin/dpkg returned an error code (1)

Changed in linux-firmware-nonfree (Ubuntu):
status: Incomplete → Confirmed
Chase Douglas (chasedouglas) wrote :

@Anders:

Yep, I made a mistake in that version. I've updated it and tested it out again. The new package has been pushed to my ppa as version 1.8~ppa2. Please do the following and then retest:

$ sudo apt-get update
$ sudo apt-get install linux-firmware-nonfree

Thanks

@Chase: installed the updated package from your PPA (works fine now), then plugged the USB stick:

Apr 3 13:17:39 test-laptop kernel: [ 434.396075] usb 1-1: new high speed USB device using ehci_hcd and address 2
Apr 3 13:17:40 test-laptop kernel: [ 434.532882] usb 1-1: configuration #1 chosen from 1 choice
Apr 3 13:17:40 test-laptop kernel: [ 435.308218] af9015: tuner id:179 not supported, please report!
Apr 3 13:17:40 test-laptop kernel: [ 435.308276] usbcore: registered new interface driver dvb_usb_af9015
Apr 3 13:17:40 test-laptop kernel: [ 435.354536] usbcore: registered new interface driver hiddev
Apr 3 13:17:40 test-laptop kernel: [ 435.355527] usbcore: registered new interface driver usbhid
Apr 3 13:17:40 test-laptop kernel: [ 435.356934] usbhid: v2.6:USB HID core driver
Apr 3 13:18:23 test-laptop kernel: [ 478.247388] usb 1-1: USB disconnect, address 2
Apr 3 13:18:23 test-laptop kernel: [ 478.247578] dvb-usb: generic DVB-USB module successfully deinitialized and disconnected.

I suspect this means my problem is (or might be) a different problem to the original reporter's problem.

See my previous comments and http://ubuntuforums.org/showthread.php?t=606487&page=5 (and subsequent pages)

toad (toad-rubikon) wrote :

This Bug affects me too with a MSI DIGIVOX Duo,
changing the firmware successfully fixes the problem.

Chase Douglas (chasedouglas) wrote :

@Anders:

Unfortunately, the Lucid driver does not support your tuner card. It does look like there is a patch to the driver that would enable functionality, but at this point we can't include this patch into Lucid due to the possibility of introducing regressions for others. You should be able to build the drivers with the patch (which may be included upstream by now) if you care to.

Chase Douglas (chasedouglas) wrote :

@toad:

Can you explain what you did to make your card work for you? Did you install my updated linux-firmware-nonfree package or did you manually install some firmware?

Thanks

toad (toad-rubikon) wrote :

@Chase:

I just copy the firmware to /lib/firmware:

toad@cubu:~$ ls -l /lib/firmware/dvb-usb-af*
-rw-r--r-- 1 root root 15913 2010-03-28 21:42 /lib/firmware/dvb-usb-af9015.fw
-rw-r--r-- 1 root root 12700 2010-03-08 22:41 /lib/firmware/dvb-usb-af9015.fw.old
toad@cubu:~$

I know this issue and so i did not investigate in searching the ubuntu bugtracker,
some days later I remember that announcing this bug maybe fixes the bug for the next release.

Chase Douglas (chasedouglas) wrote :

@toad:

Can you move out your firmware and install my linux-firmware-nonfree package? We need to be sure the firmware in my package is working right before we publish it, if possible.

Thanks

toad (toad-rubikon) wrote :

No problem, but how how I can later go back to the normal repositories and then back to the "normal" package state ?

Sorry, not an apt expert :-()

Chase Douglas (chasedouglas) wrote :

@toad:

If you want to revert the package you can do the following:

$ sudo apt-get install ppa-purge
$ sudo ppa-purge ppa:chasedouglas/linux-firmware-nonfree

If you really wanted to, you could get rid of ppa-purge after you are done with it:

$ sudo apt-get remove ppa-purge

but that's not really necessary

toad (toad-rubikon) wrote :

Good work, the new package works for me.

pripps (shurik-home) wrote :

Hi

Wanted to test it also but get this:
Get:4 http://archive.canonical.com karmic/partner Sources [1,870B]
Fetched 14.7kB in 0s (40.8kB/s)
W: Failed to fetch http://ppa.launchpad.net/chasedouglas/linux-firmware-nonfree/ubuntu/dists/karmic/main/binary-amd64/Packages.gz 404 Not Found

KR

Chase Douglas (chasedouglas) wrote :

@pripps:

I haven't uploaded a new firmware package for Karmic. The package I've asked for testing is for Lucid. As it seems everything has gone well, I will look into backporting the changes into Karmic once they get into Lucid.

lebreton (hugo-lebreton) wrote :

I confirm it works under Lucid.

@Chase: in order to get the updated kernel/driver into lucid-backports, should I file a separate bug or do you reckon it will trickle through at some point?

Chase Douglas (chasedouglas) wrote :

@Anders:

We don't have any mechanism in place for backports of the dvb drivers. Due to the nature of the issue, it unfortunately would not be high on our priority list of things to do in the kernel team either.

I suggest you do one of the following, depending on your interest and skill level:

1. Compile the newer module yourself manually
2. Create a dkms package to build the module automatically whenever the kernel changes
3. Modify the lucid backport modules package to include dvb drivers

If you do 2 or 3 you can publish it in your personal package archive for others. If you do 3, we may be able to look at importing it into the Ubuntu l-b-m package. Let me know if you have any questions. I'm sorry I can't help much about this at this late stage (if this were known a month or two ago we could have looked at backporting directly into the lucid kernel).

Thanks

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-firmware-nonfree - 1.8

---------------
linux-firmware-nonfree (1.8) lucid; urgency=low

  * Added dvb firmware for AVerTV HD A180 tuner card and derivatives
    -LP: #508317
  * Clean up packaging, fixing lintian warnings
    - Added packaging copyright assigned to Tim Gardner
  * Updated dvb-usb-af9015.fw to newer version
    -LP: #458444
  * Add Update_firmware script and many dvb firmware files
  * Add Broadcom Crystal HD firmware
 -- Chase Douglas <email address hidden> Tue, 06 Apr 2010 10:59:46 -0400

Changed in linux-firmware-nonfree (Ubuntu):
status: Confirmed → Fix Released
Peter B. (puk007-gmail) wrote :

great news! looking forward for lucid release

@Chase:

Quite a few people are having problems with tuning of Peak 221544 / Kworld PC160 dual tuner cards with af9015 firmware - long thread with people reporting issues - http://ubuntuforums.org/showthread.php?t=1458234 .
After messing around with Mythbubtu 9.10 and the firmware up to 4.95, I wiped and installed 10.4 Mythbuntu and found I got 'No channels found', so then tried reverting to early firmware incrremently - here's a relevant section from my last post on that thread :
---------------------
Between each firmware change, deleting of channels and cards, then cold reboot. Long channel scan timeouts.

4.65 firmware - 13 channels found, very little usable, no main stream but did get price drop tv - 4.65 has a sense of humour; does anyone who takes the effort to build a myth box actually enable that type of channel except for laughs?...
4.71 firmware - it too has a sense of humour, 13 channels and it thinks I should be bidding for an over priced exercise bike.
4.73 firmware - 52 channels but crazy numbering - starting from 4168 and only getting partial lock when trying to view a channel, so can't bid on that medalian on a chain that looked so tasteful...
4.95 firmware - just for consistency reverted - 23 channels found, little main stream (Again no BBC etc.) - crazy numbering - started from 8384.

Now from https://bugs.launchpad.net/ubuntu/+s...44/comments/19 did :

$ sudo add-apt-repository ppa:chasedouglas/linux-firmware-nonfree
$ sudo apt-get update
$ sudo apt-get install linux-firmware-nonfree

Appeared I had the latest non free firmware anyway, cold reboot.

For the hell of it upped the card channel scan timeouts (Signal, channel) from 6000 ms, 12000 ms to 12000 ms, 18000 ms and now gone full circle and back to "No Channels Found".

--------------------------------------
I can see Mythbuntu 10.4 ilooks good and is more responsive than 9.10 so would really like to get the firmware working with card on 10.4, so if you can tackle it and want any log messages or try out other firmware - I quite glady use the box to test.

Chase Douglas (chasedouglas) wrote :

Paul Everill,

First, if you believe there's a bug in some firmware and there's a different version that can fix it, please open a new bug so we can track it properly. Don't hesitate to open new bugs :). If you want, you can open a new bug and reply to this comment there.

I read through your comment, but I'm not sure I understand how to fix this issue. It seems none of the firmware available will make this card work right. Until there's firmware that makes things work right for the card, I think we should leave things as they are. Other cards may use the same firmware file, and we don't want to introduce a regression for them, especially when the change doesn't really fix another card. Also, if this card is weird and requires its own special firmware version we may not be able to accommodate it through the Ubuntu linux-firmware-nonfree package since it needs to be hardware agnostic.

I hope I haven't missed the overall point of your comment.

Thanks

barberio (barberio) wrote :

I2C Errors cropping up on specific af9015 platforms is a known problem due to this chipset's implementations having a lot of variability and the linux driver tending to lag behind new hardware versions quite a bit.

Checking on the V4L wiki, the Peak/K-World PC-160-T is known to be buggy with the current linux driver. I'm afraid you'll have to wait for upstream support fixes for this specific hardware from Linux TV and I'll have to refer you to http://www.linuxtv.org/

Thanks for the reply Chase

You may be right about non of the firmware being available will help solve this issue for the 221544/Kworld PC160 chipset. I bought the card specifically for Mythbuntu due to a 'works out of the box' statement with the new firmware on the Mythbuntu hardware listing pages (Couldn't afford to stretch to a dual tuner Hauppage card).

The above tests of different firmware were done on the latest 10.4 Mythbuntu, on the recommendation of someone else I'm going to try reverting to 9.10 Mythbunto and trying the old 4.65 firmware; if that works I'll post a new bug report.

if it doesn't work I think it's time to throw in the towel with Mythbuntu because if the firmware isn't going to be sorted out (And I understand that at the end of day it's always someone's precious free time that's got to be used to sort it out) it's just a glorified DVD player to me, shame really wanted a LAMP stack media centre but although I would hate to admit defeat it'll then be a Windows Media Centre.

barberio (barberio) wrote :

The MythTV Wiki (which is where the Mythbuntu hardware requirements page links to) is not a reliable location for hardware driver support or information on which devices are suitable and stable. This is however well beyond the scope of this bug ticket, and should be taken up with the MythTV/Mythbuntu projects.

Blackpaw (blackpaw) wrote :

Paul, one caveat with the firmware - it won't be reloaded onto cards that are still in a "warm" state and USB cards often retain that status even after a reboot - if you look at dmesg you can usually see a message along the lines of "warm state, firmware not uploaded" on some such.

Before chucking the towel in :) I'd recommend installing the *4.95* firmware, shutting down the PC, unplugging it from the wall and physically removing the usb tuner. Give it a few minutes, plug the tuner back in and turn the PC back on.

Review your dmesg output (dmesg|less) and see if you can find mention of your card - a seach for af90 should find it. See if its uploading the firmware and what version it is.

Then if it all seems ok, move onto tuning.

Cheers,

Lindsay

Thanks Barberio, I wish i'd known about that before purchasing the card.

And thanks Lindsay for the disconnect advice. Early on when trying to get this all working in 9.10 Mythbuntu I was checking the dmesg log for the firmware version going to 4.95, but have to admit hadn't done the same with 10.4 Mythbuntu - will check it's 4.95 firmware before giving it the wipe.

Gunars Rodins (uwix) wrote :

Still in 4.95 firmware fails in hardware level if someway in attempt to scan channels it has tuned on frequency, but has not managed in set timeout (default 3 sec) to identify digital channels. So after it gets

af9015: recv bulk message failed:-71

If this happends, only what helps - plug out hardware off power for 2 min.

Reboots and other things doesnot help - you will get "af9015: command failed:2" (in MythTV tuner will hang in "I__" state or "LMs_" state.

> dmesg |grep af
[ 6.271426] af9013: firmware version:4.95.0
[ 6.883379] af9013: found a 'Afatech AF9013 DVB-T' in warm state.
[ 6.886368] af9013: firmware version:4.95.0
[ 6.899866] af9015: command failed:2
[ 6.903617] af9015: command failed:2
[ 7.130711] af9013: firmware version:4.95.0
[ 7.708393] af9013: found a 'Afatech AF9013 DVB-T' in warm state.
[ 7.711028] af9013: firmware version:4.95.0
[ 7.724643] af9015: command failed:2
[ 7.728392] af9015: command failed:2
[ 7.738046] usbcore: registered new interface driver dvb_usb_af9015
[ 17.752743] af9015: recv bulk message failed:-71
[ 17.752990] af9015: recv bulk message failed:-75
[ 17.752992] af9013: I2C read failed reg:d417
[ 25.379433] af9015: recv bulk message failed:-71
[ 25.379677] af9015: recv bulk message failed:-75
[ 25.379679] af9013: I2C read failed reg:d417

Gunni (fgunni) wrote :

I got the same problem here with a Terratec Cinergy RC (MK II) 0ccd:0097
Should have found that bug before i bought this stick, i bought it just because i wanted to get away from that buggy linux driver for my hauppauge HVR 1300 ...
This problems still exists on Ubuntu 11.10 alpha1 Firmware is 4.95.0, Kernel is 2.6.39-3

Gunni (fgunni) wrote :

To clarify: My problem is the same as Gunars Rodins in comment #49

Changed in linux-firmware-nonfree (Ubuntu):
assignee: Chase Douglas (chasedouglas) → nobody
Tenho Tuhkala (muppis) wrote :

I got same problem as #49 and #50 with three of 15a4:9016 Afatech Technologies, Inc. AF9015 DVB-T USB2.0 sticks
After day or two dvb modules causes segfault and dies. Only rebooting helps, but I'd like to find more sophisticated solution for this.
System is Ubuntu 11.10 LTSP and kernel is 3.0.0-14-generic #23-Ubuntu SMP

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers