instance had no console output

Bug #588725 reported by Scott Moser on 2010-06-02
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
Natty
Medium
Unassigned
Precise
Medium
Unassigned
linux-ec2 (Ubuntu)
Medium
Unassigned
Natty
Medium
Unassigned
Precise
Medium
Unassigned

Bug Description

During ISO testing for maverick alpha-1 (20100601) I found an instance with no console output:

INSTANCE i-44f67e33 ami-65321811 ec2-79-125-38-9.eu-west-1.compute.amazonaws.com ip-10-228-98-226.eu-west-1.compute.internal running ec2-keypair.eu-west-1 4 m1.small 2010-06-02T00:58:42+0000 eu-west-1b aki-c35e74b7 monitoring-disabled 79.125.38.9 10.228.98.226 instance-store

After reaching the instance, running some tests, collecting console data of 4 other instances, and then retrying for at least 240 seconds (24 sleeps of 10 seconds) the instance had no console output.

Note, this could possibly be a duplicate of bug 588715, but since this was an instance-store instance, it was not shut down.

Below is describe-images for this image:
IMAGE ami-65321811 099720109477/ubuntu-images-testing/ubuntu-maverick-daily-i386-server-20100601 099720109477 available public i386 machine aki-c35e74b7 instance-store

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: linux-ec2 2.6.32.305.6
ProcVersionSignature: User Name 2.6.32-305.9-ec2 2.6.32.11+drm33.2
Uname: Linux 2.6.32-305-ec2 i686
Architecture: i386
Date: Wed Jun 2 13:49:10 2010
Ec2AMI: ami-65321811
Ec2AMIManifest: ubuntu-images-testing-eu/ubuntu-maverick-daily-i386-server-20100601.manifest.xml
Ec2AvailabilityZone: eu-west-1b
Ec2InstanceType: m1.small
Ec2Kernel: aki-c35e74b7
Ec2Ramdisk: unavailable
ProcEnviron:
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: linux-meta-ec2

related bugs:
  * bug 588715: instance had only post-shutdown console output

Scott Moser (smoser) wrote :
tags: added: iso-testing
kernel-janitor (kernel-janitor) wrote :

Hi Scott,

This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux 588725

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Scott Moser (smoser) on 2010-10-08
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Confirmed
Scott Moser (smoser) wrote :

I really think this is related to bug 588715 . And I really think its hypervisor / aws failure.
I saw it reported on forums at http://developer.amazonwebservices.com/connect/thread.jspa?threadID=52656&tstart=0 . I asked to see what kernel/ami was being run.

Scott Moser (smoser) on 2011-01-28
Changed in linux-meta-ec2 (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Scott Moser (smoser) on 2011-01-28
affects: linux-meta-ec2 (Ubuntu) → linux-ec2 (Ubuntu)
Scott Moser (smoser) wrote :

It appears that this is happening more frequently now. awstrial has been using the same kernel since launch. At the beginning of this maverick offering, there were rarely any such failures. Yesterday I looked at 9 instances, of them 6 did not have console output (that 6 includes 1 that had "post-shutdown only" -- bug 588715).

Jeremy Foshee (jeremyfoshee) wrote :

Marking Natty as Won't Fix for now. Can you confirm this is an issue still in Natty? I have left the development task open so that this issue stays on our radar.

Thanks!

~JFo

Changed in linux (Ubuntu Natty):
status: Confirmed → Won't Fix
Joseph Salisbury (jsalisbury) wrote :

@Scott

Do you happen to know if this is still an issue with Oneiric?

Scott Moser (smoser) wrote :

As I've stated elsewhere, I really think its a hypervisor bug, something beyond Ubuntu's control.

description: updated
Ben Howard (utlemming) wrote :

Amazon is asking for users that see this bug report it on the AWS Forums.

Please post instance ID and AMI ID in your forum post.

https://forums.aws.amazon.com/forum.jspa?forumID=30

Scott Moser (smoser) wrote :

per kirkland in ubuntu-server irc just now:
<kirkland> smoser: fyi, i just launched a precise t1.micro, it's up and running, but 30 minutes later, no console output

so i marked this as affecting precise.

Scott Moser (smoser) wrote :

I've posted a thread at https://forums.aws.amazon.com/thread.jspa?threadID=86174 . If you see this, please append the requested data to that thread.

Dustin Kirkland  (kirkland) wrote :

Possibly worth mentioning... I subsequently started another instance, which did come up and run just fine. Until I tried to apt-get install something, and then I started hanging on:
0% [Connecting to us-east-1.ec2.archive.ubuntu.com (10.210.205.172)]

I ctrl-c cancelled that operation, and then retried, and the install worked just fine.

So I wonder if perhaps a dead or non-responsive archive might cause ubuntu instances to not boot all the way?

Dustin Kirkland  (kirkland) wrote :

Troublesome ami and id:

RESERVATION r-46926926 357813986684 default
INSTANCE i-f700a492 ami-051acb6c terminated ec2-keypair 0 t1.micro 2012-01-31T21:53:35+0000 us-east-1d aki-825ea7eb monitoring-disabled ebs paravirtual xen sg-d5d135bc default

Dustin Kirkland  (kirkland) wrote :

Again. This time, a cc2.8xlarge.

us-east-1/hvm/ubuntu-precise-alpha1-amd64-server-20111130
i-5fbc163a

RESERVATION r-9e4b89fe 357813986684 default
INSTANCE i-5fbc163a ami-11dd1678 ec2-72-44-50-148.compute-1.amazonaws.com ip-10-58-113-227.ec2.internal running ec2-keypair 0 cc2.8xlarge 2012-02-02T17:07:26+0000 us-east-1a monitoring-disabled 72.44.50.148 10.58.113.227 ebs hvm xen sg-d5d135bc default
BLOCKDEVICE /dev/sda1 vol-58986d34 2012-02-02T17:07:41.000Z

Dustin Kirkland  (kirkland) wrote :

Happened again:

RESERVATION r-9a5391fa 357813986684 default
INSTANCE i-718a2014 ami-11dd1678 ec2-184-72-183-147.compute-1.amazonaws.com ip-10-58-6-213.ec2.internal shutting-down ec2-keypair 0 cc2.8xlarge 2012-02-02T17:15:06+0000 us-east-1a monitoring-disabled 184.72.183.147 10.58.6.213 ebs hvm xen sg-d5d135bc default
BLOCKDEVICE /dev/sda1 vol-7c867310 2012-02-02T17:15:22.000Z

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Confirmed → Won't Fix
dino99 (9d9) on 2013-05-18
tags: removed: maverick
Rolf Leggewie (r0lf) wrote :

natty has seen the end of its life and is no longer receiving any updates. Marking the natty task for this ticket as "Won't Fix".

Changed in linux-ec2 (Ubuntu Natty):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers