BUG: soft lockup - CPU#1 stuck for 66s! [swapper:0]

Bug #540378 reported by Scott Moser on 2010-03-17
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux-ec2 (Ubuntu)
Medium
Unassigned

Bug Description

In testing for beta1, found this in a console log:
[ 169.099102] BUG: soft lockup - CPU#1 stuck for 66s! [swapper:0]

I will attach the whole console log, but I don't think it is of much use.

ProblemType: Bug
Architecture: amd64
Date: Wed Mar 17 17:00:06 2010
DistroRelease: Ubuntu 10.04
Ec2AMI: ami-d984afad
Ec2AMIManifest: ubuntu-images-testing-eu/ubuntu-lucid-daily-amd64-server-20100317.manifest.xml
Ec2AvailabilityZone: eu-west-1b
Ec2InstanceType: m1.large
Ec2Kernel: aki-e58da691
Ec2Ramdisk: unavailable
Package: linux-ec2 2.6.32.303.4
ProcEnviron:
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: User Name 2.6.32-303.7-ec2
SourcePackage: linux-meta-ec2
Uname: Linux 2.6.32-303-ec2 x86_64

Related branches

Scott Moser (smoser) wrote :
tags: added: iso-testing
Scott Moser (smoser) wrote :

In beta1 testing I saw this on x86_64 instances only. 3 times out of the 41 x86_64 instances.

INSTANCE i-26ea4751 ami-d984afad ec2-79-125-40-23.eu-west-1.compute.amazonaws.com ip-10-228-179-175.eu-west-1.compute.internal running ec2-keypair.eu-west-1 3 m1.large 2010-03-17T16:27:09+0000 eu-west-1b aki-e58da691 monitoring-disabled 79.125.40.23 10.228.179.175 instance-store

INSTANCE i-6708a70c ami-2530df4c ec2-184-73-58-38.compute-1.amazonaws.com ip-10-194-211-176.ec2.internal running ec2-keypair.us-east-1 0 m1.large 2010-03-17T17:22:48+0000 us-east-1c aki-11c72878 monitoring-disabled 184.73.58.38 10.194.211.176 instance-store

INSTANCE i-7d08a716 ami-2530df4c ec2-174-129-172-202.compute-1.amazonaws.com ip-10-194-103-160.ec2.internal running ec2-keypair.us-east-1 5 m1.large 2010-03-17T17:22:48+0000 us-east-1c aki-11c72878 monitoring-disabled 174.129.172.202 10.194.103.160 instance-store

Jeremy Foshee (jeremyfoshee) wrote :

[This is an automated message. Apologies if it has reached you inappropriately.]

This bug was reported against the linux-meta package when it likely should have been reported against the linux package instead. We are automatically transitioning this to the linux kernel package so that the appropriate teams are notified and made aware of this issue.

If this bug really is a bug in the linux-meta package you can move it back to linux-meta and tag it kj-linux-meta, or contact us on the #ubuntu-kernel channel on the FreeNode IRC server. Thanks.

affects: linux-meta-ec2 (Ubuntu) → linux-ec2 (Ubuntu)
Matej.Pastor (georgewh) wrote :

look at https://bugs.launchpad.net/ubuntu/+source/linux-ec2/+bug/538057

a have tested some karmic daily build ami and have same problem.

Steve Langasek (vorlon) on 2010-03-23
Changed in linux-ec2 (Ubuntu):
importance: Undecided → High
importance: High → Medium
Launchpad Janitor (janitor) wrote :
Download full text (20.3 KiB)

This bug was fixed in the package linux-ec2 - 2.6.32-304.8

---------------
linux-ec2 (2.6.32-304.8) lucid; urgency=low

  [ Andy Whitcroft ]

  * rebase to Ubuntu-2.6.32-19.28
  * updateconfigs after rebase to Ubuntu-2.6.32-19.28

  [ John Johansen ]

  * [Config] fix EC2 config to remove soft lockup issue
    - LP: #527208, #540378

  [ Ubuntu: 2.6.32-19.28 ]

  * [Config] enable various multitouch devices
    - LP: #541453
  * (pre-stable): input: ALPS - Add signature for HP Pavilion dm3 laptops
    - LP: #545307
  * SAUCE: Disable function tracing after hitting __schedule_bug
  * SAUCE: Reduce ACPI resource conflict message to KERN_INFO, printf
    cleanup
    - LP: #440470
  * SAUCE: drm/i915: don't change DRM configuration when releasing load
    detect pipe
    - LP: #488328
  * SAUCE: AppArmor: Remove null_profile's use of PFLAG_NO_LIST_REF
    - LP: #539437
  * SAUCE: AppArmor: Stop page allocation warnings that can occur on policy
    load
    - LP: #458299
  * SAUCE: AppArmor: Return string len rather than the allocation size
    - LP: #551844
  * SAUCE: AppArmor: Fix oops in profile verification if profile unpack
    fails.
  * [Config] Enable Nouveau DRM module on powerpc
  * SAUCE: Pull in thinkpad-acpi from v2.6.34-rc1
    - LP: #357673
  * [Config] Enable thinkpad-acpi ALSA volume control
    - LP: #357673
  * SAUCE: drm/i915: Disable FBC on 915GM and 945GM
    - LP: #492392, #539609
  * Revert "(pre-stable) drm/i915: blacklist lid status: Sony VGN-BX196VP,
    Dell Inspiron 700m"
    - LP: #515246
  * (pre-stable) softlockup: Stop spurious softlockup messages due to
    overflow
    - LP: #551068
  * backlight: mbp_nvidia_bl - add five more MacBook variants
    - LP: #511965
  * drm/nv04-nv40: Fix up the programmed horizontal sync pulse delay.
    - LP: #529130
  * drm/nouveau: Fix fbcon corruption with font width not divisible by 8
    - LP: #544739
  * (pre-stable) USB: fix usbfs regression
  * drm/radeon/bo: add some fallback placements for VRAM only objects.
    - LP: #507148
  * drm/radeon/kms: don't print error on -ERESTARTSYS.
    - LP: #507148
  * Input: add the ABS_MT_PRESSURE event
    - LP: #541453
  * HID: Support for 3M multitouch panel
    - LP: #541453
  * HID: make 3M PCT touchscreen driver standalone config option
    - LP: #541453
  * HID: add support for Stantum multitouch panel
    - LP: #541453
  * HID: make Stantum driver standalone config option
    - LP: #541453
  * HID: add support for Acer T230H multitouch
    - LP: #541453
  * HID: add support for Pixart Imaging Optical Touch Screen
    - LP: #541453
  * HID: fixed bug in single-touch emulation on the stantum panel
    - LP: #541453
  * HID: add pressure support for the Stantum multitouch panel
    - LP: #541453
  * HID: Support for MosArt multitouch panel
    - LP: #541453
  * HID: hid-ntrig add multi input quirk and clean up
    - LP: #541453
  * HID: n-trig: remove unnecessary tool switching
    - LP: #541453
  * HID: hid-ntrig: multitouch cleanup and fix
    - LP: #541453
  * HID: hid-ntrig: Single touch mode tap
    - LP: #541453
  * hid: ntrig touch events
    - LP: #541453
  * (pre-stable) x86-32, resume: do a global tlb flush in S4 resume
  ...

Changed in linux-ec2 (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers