ec2 instance fails boot, no console output on c1.xlarge

Bug #527208 reported by Scott Moser on 2010-02-24
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-ec2 (Ubuntu)
High
John Johansen
Lucid
High
John Johansen

Bug Description

This instance failed to come up:

RESERVATION r-f44c8683 950047163771 default
INSTANCE i-8a8e55fd ami-97b992e3 pending ec2-keypair.eu-west-1 0 c1.xlarge 2010-02-24T16:35:14+0000 eu-west-1b aki-e3d5fe97 monitoring-disabled instance-store

ami-97b992e3 is ubuntu-lucid-daily-amd64-server-20100224.2.manifest.xml
That is in eu-west-1. The instance never had any console output, and hung on "shutting down".

I'm marking this "low" priority as I believe it is a ec2 issue.

Related branches

tags: added: iso-testing
Scott Moser (smoser) wrote :

I just noticed that the other c1.xlarge instance that I ran also hung, with no console output, and both instances are seemingly stuck in "shutting down".

Info for the second is:
INSTANCE i-19d12872 ami-7d58b414 ec2-67-202-52-127.compute-1.amazonaws.com domU-12-31-39-0B-C1-61.compute-1.internal shutting-down ec2-keypair.us-east-1 0 c1.xlarge 2010-02-24T17:01:07+0000us-east-1b aki-e3db378a monitoring-disabled 67.202.52.127 10.214.198.143 instance-store

Changed in linux-ec2 (Ubuntu):
importance: Low → Medium
Scott Moser (smoser) wrote :

The kernel in both cases is ubuntu-lucid-amd64-linux-image-2.6.32-302-ec2-v-2.6.32-302.6-kernel.img.manifest.xml

Scott Moser (smoser) wrote :

just a reference, http://aws.amazon.com/ec2/instance-types/ describes instance types.
c1.xlarge:
  7 GB of memory
  20 EC2 Compute Units (8 virtual cores with 2.5 EC2 Compute Units each)

I have booted an m1.xlarge successfully, which is:
  15 GB memory
  8 EC2 Compute Units (4 virtual cores with 2 EC2 Compute Units each)

Scott Moser (smoser) on 2010-02-24
summary: - ec2 instance failed boot, no console output
+ ec2 instance fails boot, no console output on c1.xlarge
Scott Moser (smoser) wrote :

Given how reproducible this is, moving it to High.

Scott Moser (smoser) wrote :

Its not a lot of use, but there was some console output for i-19d12872.
That instance shows (still):
RESERVATION r-18f1b670 950047163771 default
INSTANCE i-19d12872 ami-7d58b414 ec2-67-202-52-127.compute-1.amazonaws.com domU-12-31-39-0B-C1-61.compute-1.internal shutting-down ec2-keypair.us-east-1 0 c1.xlarge 2010-02-24T17:01:07+0000us-east-1b aki-e3db378a monitoring-disabled 67.202.52.127 10.214.198.143 instance-store

Scott Moser (smoser) on 2010-02-26
Changed in linux-ec2 (Ubuntu):
milestone: none → ubuntu-10.04-beta-1
importance: Medium → High
Thierry Carrez (ttx) wrote :

Assigning to jjohansen based on yesterdays discussion.

Changed in linux-ec2 (Ubuntu Lucid):
assignee: nobody → John Johansen (jjohansen)
John Johansen (jjohansen) wrote :

The cause of this wasn't found in time for beta1 deadline. It is being worked on and will happen post beta1.

Changed in linux-ec2 (Ubuntu Lucid):
milestone: ubuntu-10.04-beta-1 → ubuntu-10.04-beta-2
John Johansen (jjohansen) wrote :

If you have been affected by this bug, please try the following test kernel.

aki-5b658a32
ari-5d658a34

Launchpad Janitor (janitor) wrote :
Download full text (20.3 KiB)

This bug was fixed in the package linux-ec2 - 2.6.32-304.8

---------------
linux-ec2 (2.6.32-304.8) lucid; urgency=low

  [ Andy Whitcroft ]

  * rebase to Ubuntu-2.6.32-19.28
  * updateconfigs after rebase to Ubuntu-2.6.32-19.28

  [ John Johansen ]

  * [Config] fix EC2 config to remove soft lockup issue
    - LP: #527208, #540378

  [ Ubuntu: 2.6.32-19.28 ]

  * [Config] enable various multitouch devices
    - LP: #541453
  * (pre-stable): input: ALPS - Add signature for HP Pavilion dm3 laptops
    - LP: #545307
  * SAUCE: Disable function tracing after hitting __schedule_bug
  * SAUCE: Reduce ACPI resource conflict message to KERN_INFO, printf
    cleanup
    - LP: #440470
  * SAUCE: drm/i915: don't change DRM configuration when releasing load
    detect pipe
    - LP: #488328
  * SAUCE: AppArmor: Remove null_profile's use of PFLAG_NO_LIST_REF
    - LP: #539437
  * SAUCE: AppArmor: Stop page allocation warnings that can occur on policy
    load
    - LP: #458299
  * SAUCE: AppArmor: Return string len rather than the allocation size
    - LP: #551844
  * SAUCE: AppArmor: Fix oops in profile verification if profile unpack
    fails.
  * [Config] Enable Nouveau DRM module on powerpc
  * SAUCE: Pull in thinkpad-acpi from v2.6.34-rc1
    - LP: #357673
  * [Config] Enable thinkpad-acpi ALSA volume control
    - LP: #357673
  * SAUCE: drm/i915: Disable FBC on 915GM and 945GM
    - LP: #492392, #539609
  * Revert "(pre-stable) drm/i915: blacklist lid status: Sony VGN-BX196VP,
    Dell Inspiron 700m"
    - LP: #515246
  * (pre-stable) softlockup: Stop spurious softlockup messages due to
    overflow
    - LP: #551068
  * backlight: mbp_nvidia_bl - add five more MacBook variants
    - LP: #511965
  * drm/nv04-nv40: Fix up the programmed horizontal sync pulse delay.
    - LP: #529130
  * drm/nouveau: Fix fbcon corruption with font width not divisible by 8
    - LP: #544739
  * (pre-stable) USB: fix usbfs regression
  * drm/radeon/bo: add some fallback placements for VRAM only objects.
    - LP: #507148
  * drm/radeon/kms: don't print error on -ERESTARTSYS.
    - LP: #507148
  * Input: add the ABS_MT_PRESSURE event
    - LP: #541453
  * HID: Support for 3M multitouch panel
    - LP: #541453
  * HID: make 3M PCT touchscreen driver standalone config option
    - LP: #541453
  * HID: add support for Stantum multitouch panel
    - LP: #541453
  * HID: make Stantum driver standalone config option
    - LP: #541453
  * HID: add support for Acer T230H multitouch
    - LP: #541453
  * HID: add support for Pixart Imaging Optical Touch Screen
    - LP: #541453
  * HID: fixed bug in single-touch emulation on the stantum panel
    - LP: #541453
  * HID: add pressure support for the Stantum multitouch panel
    - LP: #541453
  * HID: Support for MosArt multitouch panel
    - LP: #541453
  * HID: hid-ntrig add multi input quirk and clean up
    - LP: #541453
  * HID: n-trig: remove unnecessary tool switching
    - LP: #541453
  * HID: hid-ntrig: multitouch cleanup and fix
    - LP: #541453
  * HID: hid-ntrig: Single touch mode tap
    - LP: #541453
  * hid: ntrig touch events
    - LP: #541453
  * (pre-stable) x86-32, resume: do a global tlb flush in S4 resume
  ...

Changed in linux-ec2 (Ubuntu Lucid):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers