linux-dell300x 4.15.0-1017.21 source package in Ubuntu

Changelog

linux-dell300x (4.15.0-1017.21) bionic; urgency=medium

  [ Ubuntu: 4.15.0-142.146 ]

  * overlayfs calls vfs_setxattr without cap_convert_nscap
    - vfs: move cap_convert_nscap() call into vfs_setxattr()
  * CVE-2021-29154
    - SAUCE: bpf, x86: Validate computation of branch displacements for x86-64

 -- Stefan Bader <email address hidden>  Tue, 13 Apr 2021 13:40:47 +0200

Upload details

Uploaded by:
Stefan Bader on 2021-04-13
Uploaded to:
Bionic
Original maintainer:
Ubuntu Kernel Team
Architectures:
all amd64
Section:
devel
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Builds

Bionic: [FULLYBUILT] amd64

Downloads

File Size SHA-256 Checksum
linux-dell300x_4.15.0.orig.tar.gz 150.4 MiB c33b8ba5c45a40b689979caa2421c4d933864cd70eb93c00eb69adf43e9a24fc
linux-dell300x_4.15.0-1017.21.diff.gz 11.6 MiB ac4bf506e4963d915aa3852073abb1209df6014d6183031088577d5db05cbc23
linux-dell300x_4.15.0-1017.21.dsc 3.9 KiB f213f0c9ad6c8c9b9dba17e8cbe899ac7f9ee13b6b38af63bc6d60b0ce6fc16f

View changes file

Binary packages built by this source

linux-buildinfo-4.15.0-1017-dell300x: Linux kernel buildinfo for version 4.15.0 on 64 bit x86 SMP

 This package contains the Linux kernel buildinfo for version 4.15.0 on
 64 bit x86 SMP.
 .
 You likely do not want to install this package.

linux-dell300x-headers-4.15.0-1017: Header files related to Linux kernel version 4.15.0

 This package provides kernel header files for version 4.15.0, for sites
 that want the latest kernel headers. Please read
 /usr/share/doc/linux-dell300x-headers-4.15.0-1017/debian.README.gz for details

linux-dell300x-tools-4.15.0-1017: Linux kernel version specific tools for version 4.15.0-1017

 This package provides the architecture dependant parts for kernel
 version locked tools (such as perf and x86_energy_perf_policy) for
 version 4.15.0-1017 on
 64 bit x86.
 You probably want to install linux-tools-4.15.0-1017-<flavour>.

linux-headers-4.15.0-1017-dell300x: Linux kernel headers for version 4.15.0 on 64 bit x86 SMP

 This package provides kernel header files for version 4.15.0 on
 64 bit x86 SMP.
 .
 This is for sites that want the latest kernel headers. Please read
 /usr/share/doc/linux-headers-4.15.0-1017/debian.README.gz for details.

linux-image-unsigned-4.15.0-1017-dell300x: Linux kernel image for version 4.15.0 on 64 bit x86 SMP

 This package contains the unsigned Linux kernel image for version 4.15.0 on
 64 bit x86 SMP.
 .
 Supports Dell-edge-300x processors.
 .
 Geared toward Dell Edge Gateway 300x systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-dell300x meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-image-unsigned-4.15.0-1017-dell300x-dbgsym: Linux kernel debug image for version 4.15.0 on 64 bit x86 SMP

 This package provides the unsigned kernel debug image for version 4.15.0 on
 64 bit x86 SMP.
 .
 This is for sites that wish to debug the kernel.
 .
 The kernel image contained in this package is NOT meant to boot from. It
 is uncompressed, and unstripped. This package also includes the
 unstripped modules.

linux-modules-4.15.0-1017-dell300x: Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP

 Contains the corresponding System.map file, the modules built by the
 packager, and scripts that try to ensure that the system is not left in an
 unbootable state after an update.
 .
 Supports Dell-edge-300x processors.
 .
 Geared toward Dell Edge Gateway 300x systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-dell300x meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-tools-4.15.0-1017-dell300x: Linux kernel version specific tools for version 4.15.0-1017

 This package provides the architecture dependant parts for kernel
 version locked tools (such as perf and x86_energy_perf_policy) for
 version 4.15.0-1017 on
 64 bit x86.