linux-base 4.5ubuntu1 source package in Ubuntu

Changelog

linux-base (4.5ubuntu1) artful; urgency=low

  * Merge from Debian unstable.  Remaining changes:
    - do not install /usr/bin/perf, perf.8, bash-completion/perf
      which are provided by linux-tools-common (LP: #1008713)

linux-base (4.5) unstable; urgency=medium

  [ Salvatore Bonaccorso ]
  * Update Danish debconf template translation.
    Thanks to Joe Dalton <email address hidden> (Closes: #830587)
  * Update Brazilian Portuguese debconf templates translation.
    Thanks to Diego Neves <email address hidden> (Closes: #830691)

  [ Ben Hutchings ]
  * Update Dutch debconf template translations (Frans Spiesschaert)
    (Closes: #837097)
  * perf: Drop support for versions older than 3.2
  * Use dh with debhelper compat level 9
  * Add bash completion wrapper for perf (Closes: #702482)

linux-base (4.4) unstable; urgency=medium

  [ Ben Hutchings ]
  * Update debconf template translations:
    - Portuguese (Américo Monteiro) (Closes: #826779)
    - Polish (Łukasz Dulny)
    - Japanese (Victory)
    - Russian (Yuri Kozlov) (Closes: #828772)
    - German (Markus Hiereth)
    - French (Jean-Pierre Giraud) (Closes: #830171)
  * linux-check-removal: Fix substitution of package name in debconf title

  [ Salvatore Bonaccorso ]
  * Update Swedish debconf template translation.
    Thanks to Martin Bagge <email address hidden> (Closes: #828725)
  * Update Czech debconf template translation.
    Thanks to Michal Simunek <email address hidden> (Closes: #828944)

linux-base (4.3) unstable; urgency=medium

  * Add linux-check-removal command for use by package prerm scripts
    - Override lintian warning and error for this unusual debconf usage

linux-base (4.2) unstable; urgency=medium

  * Change source format to 3.0 (native) so that .git directory is excluded
    by default
  * Add manual page for linux-update-symlinks
  * read_kernelimg_conf(): Quietly ignore settings used only by kernel-package
  * debian/rules: Add build-{arch,indep} targets
  * debian/control: Update policy version to 3.9.8; no changes required

linux-base (4.1) unstable; urgency=medium

  * Adjust for migration to git:
    - Add .gitignore files
    - debian/control: Update Vcs-* fields (Closes: #824748)
  * Add image_stem() and read_kernelimg_conf() functions to Perl module
  * Add linux-update-symlinks command for use by package maintainer scripts

 -- Andy Whitcroft <email address hidden>  Fri, 28 Apr 2017 05:16:31 +0100

Upload details

Uploaded by:
Andy Whitcroft on 2017-04-28
Uploaded to:
Artful
Original maintainer:
Debian kernel team
Architectures:
all
Section:
kernel
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section
Bionic release on 2017-10-24 main kernel
Artful release on 2017-04-28 main kernel

Builds

Artful: [FULLYBUILT] amd64

Downloads

File Size SHA-256 Checksum
linux-base_4.5ubuntu1.tar.xz 21.0 KiB 1c4908478657adcd2f719e3df33f0a7e861971d0c128ff4cc959aa2ebd2433db
linux-base_4.5ubuntu1.dsc 1.7 KiB 8f68887836dbcdfdfd2ecb01a97dafe248354641f0edb5ab4c137a6afc3a2a6c

Available diffs

View changes file

Binary packages built by this source

linux-base: Linux image base package

 This package contains files and support scripts for all Linux
 images.