update linux-base on xenial and earlier

Bug #1766728 reported by Thadeu Lima de Souza Cascardo on 2018-04-24
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux-base (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Andy Whitcroft
Trusty
Undecided
Andy Whitcroft
Xenial
Undecided
Unassigned
Artful
Undecided
Andy Whitcroft

Bug Description

[Impact]

After some changes on linux package on bionic, linux-azure-edge and linux-hwe-edge, which are based on that package, now require a linux-base that provides linux-update-symlinks and linux-check-removal. Using the latest version also means translations will be present.

[Test Case]

Installing the latest linux-azure-edge will fail the config stage because maintainer scripts call into non-existing linux-update-symlinks and linux-check-removal.

Test result: It works with xenial kernels and fixes the problem with hwe-edge.

[Regression Potential]

New functions on perl module are tested during build time. It could break symlinks creation for other kernels. perf bash completion is not distributed, so does not conflict with linux-tools-common. Older kernels still have their links working.

description: updated
description: updated
tags: added: patch
description: updated
Tyler Hicks (tyhicks) wrote :

cascardo asked me to sponsor his upload to xenial-proposed. I've compare the build logs between the 4.0ubuntu1 version currently in xenial to the build logs from his 4.5ubuntu1~16.04.1 change. The build logs are clean with no surprises. I also compared the binary packages and was able to confirm his assertion that the perf bash completion file is not distributed.

Outside of the added linux-update-symlinks and linux-check-removal commands which motivate this upload, there's only one other notable code change:

   * Add image_stem() and read_kernelimg_conf() functions to Perl module

Those two new functions are only used by the new linux-update-symlinks command.

I think this is safe to SRU to Xenial and, therefore, have sponsored the upload.

Hello Thadeu, or anyone else affected,

Accepted linux-base into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/linux-base/4.5ubuntu1~16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in linux-base (Ubuntu Xenial):
status: New → Fix Committed

I can confirm this fixes 4.17-rc2 from mainline ppa for xenial. Thank you!

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux-base (Ubuntu):
status: New → Confirmed
tags: added: verification-done verification-done-xenial
RBL Admin (rbladmin) wrote :

Fixed installing mainline PPA 4.17.0-041700rc2-generic on 16.04.4.

Andy Whitcroft (apw) wrote :

We will not need this in artful as we will not backport kernels there which need it.

Changed in linux-base (Ubuntu Artful):
status: New → Invalid
assignee: nobody → Andy Whitcroft (apw)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-base - 4.5ubuntu1~16.04.1

---------------
linux-base (4.5ubuntu1~16.04.1) xenial; urgency=low

  * Update xenial to the latest linux-base. (LP: #1766728)

linux-base (4.5ubuntu1) artful; urgency=low

  * Merge from Debian unstable. Remaining changes:
    - do not install /usr/bin/perf, perf.8, bash-completion/perf
      which are provided by linux-tools-common (LP:1008713)

linux-base (4.5) unstable; urgency=medium

  [ Salvatore Bonaccorso ]
  * Update Danish debconf template translation.
    Thanks to Joe Dalton <email address hidden> (Closes: #830587)
  * Update Brazilian Portuguese debconf templates translation.
    Thanks to Diego Neves <email address hidden> (Closes: #830691)

  [ Ben Hutchings ]
  * Update Dutch debconf template translations (Frans Spiesschaert)
    (Closes: #837097)
  * perf: Drop support for versions older than 3.2
  * Use dh with debhelper compat level 9
  * Add bash completion wrapper for perf (Closes: #702482)

linux-base (4.4) unstable; urgency=medium

  [ Ben Hutchings ]
  * Update debconf template translations:
    - Portuguese (Américo Monteiro) (Closes: #826779)
    - Polish (Łukasz Dulny)
    - Japanese (Victory)
    - Russian (Yuri Kozlov) (Closes: #828772)
    - German (Markus Hiereth)
    - French (Jean-Pierre Giraud) (Closes: #830171)
  * linux-check-removal: Fix substitution of package name in debconf title

  [ Salvatore Bonaccorso ]
  * Update Swedish debconf template translation.
    Thanks to Martin Bagge <email address hidden> (Closes: #828725)
  * Update Czech debconf template translation.
    Thanks to Michal Simunek <email address hidden> (Closes: #828944)

linux-base (4.3) unstable; urgency=medium

  * Add linux-check-removal command for use by package prerm scripts
    - Override lintian warning and error for this unusual debconf usage

linux-base (4.2) unstable; urgency=medium

  * Change source format to 3.0 (native) so that .git directory is excluded
    by default
  * Add manual page for linux-update-symlinks
  * read_kernelimg_conf(): Quietly ignore settings used only by kernel-package
  * debian/rules: Add build-{arch,indep} targets
  * debian/control: Update policy version to 3.9.8; no changes required

linux-base (4.1) unstable; urgency=medium

  * Adjust for migration to git:
    - Add .gitignore files
    - debian/control: Update Vcs-* fields (Closes: #824748)
  * Add image_stem() and read_kernelimg_conf() functions to Perl module
  * Add linux-update-symlinks command for use by package maintainer scripts

 -- Thadeu Lima de Souza Cascardo <email address hidden> Tue, 24 Apr 2018 18:36:02 -0300

Changed in linux-base (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for linux-base has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

I tested upgrades from xenial to bionic or linux-hwe-edge upgrades from xenial-updates to xenial-proposed after a linux-base upgrade to the one in xenial-proposed.

tags: removed: verification-done
kostas (kiprisliss) on 2018-06-04
Changed in linux-base (Ubuntu Xenial):
assignee: nobody → kostas (kiprisliss)
Andy Whitcroft (apw) on 2018-07-25
summary: - update linux-base on xenial
+ update linux-base on xenial and later
summary: - update linux-base on xenial and later
+ update linux-base on xenial and earlier
Andy Whitcroft (apw) on 2018-07-25
Changed in linux-base (Ubuntu Xenial):
assignee: kostas (kiprisliss) → nobody
Changed in linux-base (Ubuntu Trusty):
status: New → In Progress
Changed in linux-base (Ubuntu Precise):
status: New → In Progress
Changed in linux-base (Ubuntu Trusty):
assignee: nobody → Andy Whitcroft (apw)
Changed in linux-base (Ubuntu Precise):
assignee: nobody → Andy Whitcroft (apw)

Hello Thadeu, or anyone else affected,

Accepted linux-base into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/linux-base/4.5ubuntu1~14.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-trusty to verification-done-trusty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-trusty. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in linux-base (Ubuntu Trusty):
status: In Progress → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers