Ubuntu

[STAGING] package linux-tools-common (not installed) failed to install/upgrade: trying to overwrite '/usr/share/man/man1/perf.1.gz', which is also in package linux-base 3.4ubuntu2

Reported by AhmedUX on 2012-06-04
106
This bug affects 16 people
Affects Status Importance Assigned to Milestone
linux-base (Ubuntu)
High
Tim Gardner
Precise
Undecided
Tim Gardner
Quantal
High
Tim Gardner

Bug Description

error when installing linux-tools-common package

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: linux-tools-common (not installed)
ProcVersionSignature: Ubuntu 3.2.0-25.40-generic 3.2.18
Uname: Linux 3.2.0-25-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu8
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: PCH [HDA Intel PCH], device 0: ALC269VB Analog [ALC269VB Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ahusam 1891 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xb0700000 irq 51'
   Mixer name : 'Intel CougarPoint HDMI'
   Components : 'HDA:10ec0269,10250504,00100100 HDA:80862805,80860101,00100000'
   Controls : 26
   Simple ctrls : 12
Date: Mon Jun 4 23:22:11 2012
DuplicateSignature:
 Unpacking linux-tools-common (from .../linux-tools-common_3.2.0-25.40_all.deb) ...
 dpkg: error processing /var/cache/apt/archives/linux-tools-common_3.2.0-25.40_all.deb (--unpack):
  trying to overwrite '/usr/share/man/man1/perf.1.gz', which is also in package linux-base 3.4ubuntu2
ErrorMessage: trying to overwrite '/usr/share/man/man1/perf.1.gz', which is also in package linux-base 3.4ubuntu2
HibernationDevice: RESUME=UUID=861eb5c3-dcd7-47c3-b6e7-76f223559112
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
MachineType: Acer Aspire 5755G
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.2.0-25-generic root=/dev/mapper/vg_clump-root ro acpi_osi=Linux quiet splash vt.handoff=7
PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No PulseAudio daemon running, or not running as session daemon.
RelatedPackageVersions: grub-pc 1.99-21ubuntu3.1
SourcePackage: linux
StagingDrivers: mei
Title: [STAGING] package linux-tools-common (not installed) failed to install/upgrade: trying to overwrite '/usr/share/man/man1/perf.1.gz', which is also in package linux-base 3.4ubuntu2
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 03/16/2012
dmi.bios.vendor: Acer
dmi.bios.version: V1.20
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: JV51_HR
dmi.board.vendor: Acer
dmi.board.version: Base Board Version
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: V1.20
dmi.modalias: dmi:bvnAcer:bvrV1.20:bd03/16/2012:svnAcer:pnAspire5755G:pvrV1.20:rvnAcer:rnJV51_HR:rvrBaseBoardVersion:cvnAcer:ct10:cvrV1.20:
dmi.product.name: Aspire 5755G
dmi.product.version: V1.20
dmi.sys.vendor: Acer

AhmedUX (ahmed-elsersi) wrote :
Brad Figg (brad-figg) on 2012-06-04
Changed in linux (Ubuntu):
status: New → Confirmed
tags: removed: need-duplicate-check
Changed in linux (Ubuntu):
importance: Undecided → Medium
Ricardo Salveti (rsalveti) wrote :

This bug is still happening on both Precise and Quantal.

In the case of the Omap images, where flash-kernel depends directly on the linux-base package, the user is unable to install linux-tools-common because of the file conflict.

Changed in linux (Ubuntu):
importance: Medium → High
Ricardo Salveti (rsalveti) wrote :

Moving to high because if the image uses flash-kernel (most ARM images), the user will be unable to install perf because flash-kernel depends on linux-base.

Tim Gardner (timg-tpi) on 2012-09-25
Changed in linux (Ubuntu Quantal):
assignee: nobody → Tim Gardner (timg-tpi)
status: Confirmed → In Progress
Tim Gardner (timg-tpi) wrote :

SRU Justification

Impact: conflict with linux-base and linux-tools-common
Patch Description: Do not package the perf man page in linux-base.

Changed in linux (Ubuntu Precise):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → In Progress
Tim Gardner (timg-tpi) on 2012-09-26
Changed in linux (Ubuntu Precise):
status: In Progress → Fix Committed
Changed in linux (Ubuntu Quantal):
status: In Progress → Fix Committed
Changed in linux (Ubuntu Quantal):
milestone: none → ubuntu-12.10
Tim Gardner (timg-tpi) on 2012-10-05
affects: linux (Ubuntu Precise) → linux-base (Ubuntu Precise)
Changed in linux-base (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in linux-base (Ubuntu Quantal):
status: Fix Committed → Fix Released
Changed in linux-base (Ubuntu Precise):
status: Fix Released → Fix Committed

Hello AhmedUX, or anyone else affected,

Accepted into precise-proposed. The package will build now and be available in a few hours in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Tim Gardner (timg-tpi) wrote :

Installed https://launchpad.net/ubuntu/+source/linux-base/3.4ubuntu3/+build/3885707/+files/linux-base_3.4ubuntu3_all.deb alongside linux-tools:

dpkg -l|egrep "linux-tools|linux-base"
ii linux-base 3.4ubuntu3 Linux image base package
ii linux-tools 3.2.0.32.35 Linux kernel versioned Tools
ii linux-tools-3.2.0-24 3.2.0-24.39 Linux kernel version specific tools for version 3.2.0-24
ii linux-tools-3.2.0-25 3.2.0-25.40 Linux kernel version specific tools for version 3.2.0-25
ii linux-tools-3.2.0-26 3.2.0-26.41 Linux kernel version specific tools for version 3.2.0-26
ii linux-tools-3.2.0-27 3.2.0-27.43 Linux kernel version specific tools for version 3.2.0-27
ii linux-tools-3.2.0-29 3.2.0-29.46 Linux kernel version specific tools for version 3.2.0-29
ii linux-tools-3.2.0-30 3.2.0-30.48 Linux kernel version specific tools for version 3.2.0-30
ii linux-tools-3.2.0-31 3.2.0-31.50 Linux kernel version specific tools for version 3.2.0-31
ii linux-tools-3.2.0-32 3.2.0-32.51 Linux kernel version specific tools for version 3.2.0-32
ii linux-tools-common 3.2.0-32.51 Linux kernel version specific tools for version 3.2.0

Marking verified for Precise.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-base - 3.4ubuntu3

---------------
linux-base (3.4ubuntu3) precise-proposed; urgency=low

  * Remove perf man page since its provided by (and conflicts with)
    linux-tools-common.
    -LP: #1008713
 -- Tim Gardner <email address hidden> Tue, 25 Sep 2012 14:37:02 -0600

Changed in linux-base (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.