[MIR] linux-base

Bug #1006717 reported by Martin Pitt on 2012-05-31
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-base (Ubuntu)
High
Oliver Grawert

Bug Description

The new flash-kernel package in Quantal now depends on linux-base.

linux-base is a very simple package that currently only contains a "linux-version" script to do version checks, a simple /usr/share/perl5/DebianLinux.pm Perl module (used by linux-version), and (for some curious reason) the manpage for "perf".

It has no important Debian bugs, and is reasonably well maintained. I see no problems with promoting it to main.

Martin Pitt (pitti) wrote :

Oliver just pointed out the postinst, and this is indeed absurd. This needs to be sorted out (dropping postinst or dropping the dependency) before it can go to main.

Changed in linux-base (Ubuntu):
assignee: nobody → Oliver Grawert (ogra)
status: New → Incomplete
Oliver Grawert (ogra) wrote :

currently it comes with a postinst that parses lots of config files of the system it gets installed on to potentially rewrite HDD device entries to UUIDs. so if someone manually set one of these files to use a device entry instead of a UUID this will be rewritten.

also the postinst does not know about any arm bootloaders which results in a debconf error message being presented by default, telling you to manually update your configs. this message isnt preseedable and has no way of hiding it.

Oliver Grawert (ogra) wrote :

i uploaded a version that does not contain the postinst to quantal:

linux-base (3.5ubuntu3) quantal; urgency=low

  * remove the postinst script, in ubuntu we did the UUID transition
    years ago and it does not seem to take u-boot into account as a
    bootloader. this results in a debconf error message on all arm
    systems.

 -- <email address hidden> Thu, 31 May 2012 17:39:54 +0200

happy to get this MIR approved now ...

Robie Basak (racb) on 2012-05-31
Changed in eilt:
importance: Undecided → High
Robie Basak (racb) on 2012-05-31
Changed in linux-base (Ubuntu):
status: Incomplete → New
Jamie Strandboge (jdstrand) wrote :

* There is nothing in the package that requires a security audit. There is no previous security history.
* The packaging looks sane and builds fine with only packages from main
* no testsuite
* as noted, Ubuntu does carry a delta, but it is to add quilt, not ship the 'perf' tool and remove a problematic postinst script.
* since there is an Ubuntu delta, it would be good if there was a team subscribed to the bug, but I won't block the MIR on that
* package is not lintian clean:
$ lintian ./*dsc
E: linux-base source: patch-modifying-debian-files 0001-remove-bin-perf.patch debian/linux-base.install
W: linux-base source: patch-system-but-no-source-readme
W: linux-base source: debian-rules-missing-recommended-target build-arch
W: linux-base source: debian-rules-missing-recommended-target build-indep
W: linux-base source: out-of-date-standards-version 3.9.1 (current is 3.9.3)$ lintian ./*deb
E: linux-base: no-debconf-config

Since the first lintian error and lintian warning were introduced by the Ubuntu delta, this should be cleaned up. I have filed bug #1008565 for this issue.

ACK, but please fix bug 1008565.

Changed in linux-base (Ubuntu):
status: New → Fix Committed
Jamie Strandboge (jdstrand) wrote :

2012-06-04 15:26:46 INFO Override Component to: 'main'
2012-06-04 15:26:46 INFO 'linux-base - 3.5ubuntu3/universe/kernel' source overridden
2012-06-04 15:26:47 INFO 'linux-base-3.5ubuntu3/universe/kernel/OPTIONAL' binary overridden in quantal/amd64
2012-06-04 15:26:47 INFO 'linux-base-3.5ubuntu3/universe/kernel/OPTIONAL' binary overridden in quantal/armel
2012-06-04 15:26:47 INFO 'linux-base-3.5ubuntu3/universe/kernel/OPTIONAL' binary overridden in quantal/armhf
2012-06-04 15:26:47 INFO 'linux-base-3.5ubuntu3/universe/kernel/OPTIONAL' binary overridden in quantal/i386
2012-06-04 15:26:47 INFO 'linux-base-3.5ubuntu3/universe/kernel/OPTIONAL' binary overridden in quantal/powerpc

Changed in linux-base (Ubuntu):
status: Fix Committed → Fix Released
Mathew Hodson (mhodson) on 2015-11-12
Changed in linux-base (Ubuntu):
importance: Undecided → High
affects: eilt → ubuntu
no longer affects: ubuntu
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints