Add compat-wireless-2.6.37 package

Bug #673245 reported by Leann Ogasawara on 2010-11-09
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-backports-modules-2.6.32 (Ubuntu)
Undecided
Unassigned
Lucid
Medium
Leann Ogasawara
Maverick
Undecided
Unassigned
linux-backports-modules-2.6.35 (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned
Maverick
Medium
Leann Ogasawara
linux-meta (Ubuntu)
Undecided
Unassigned
Lucid
Medium
Leann Ogasawara
Maverick
Medium
Leann Ogasawara

Bug Description

SRU Justification:

As part of the linux-backports-modules package, we periodically provide an updated compat-wireless stack. linux-backports-modules already has pending pull requests to add the 2.6.36 compat-wireless stack to both Lucid and Maverick LBM. It's come to our attention that future requests for newer versions of the compat-wireless stack will be coming down the pipeline. In preparation, add infrastructure to start tracking the 2.6.37 compat-wireless stack for Lucid and Maverick.

Impact:
There is no impact at the moment as we're just adding the infrastructure to enable the 2.6.37 compat-wireless stack. We will wait to actually enable and build it until 2.6.37 is final. However, once we do enable this, linux-backports-modules is an elective install and a 2.6.37 compat-wireless update hasn't existed previously, so there should be no risk of regression.

Test Case: Enable the ability to build the compat-wireless-2.6.37 stack in the linux-backports-modules package and confirm that a 2.6.37 compat-wireless binary is created.

Changed in linux-backports-modules-2.6.35 (Ubuntu Maverick):
assignee: nobody → Leann Ogasawara (leannogasawara)
importance: Undecided → Medium
status: New → In Progress
Changed in linux-backports-modules-2.6.35 (Ubuntu):
status: New → Invalid
Changed in linux-meta (Ubuntu Maverick):
assignee: nobody → Leann Ogasawara (leannogasawara)
importance: Undecided → Medium
status: New → In Progress
Changed in linux-meta (Ubuntu):
status: New → Invalid
description: updated
Changed in linux-backports-modules-2.6.32 (Ubuntu Maverick):
status: New → Invalid
Changed in linux-backports-modules-2.6.32 (Ubuntu):
status: New → Invalid
Changed in linux-backports-modules-2.6.32 (Ubuntu Lucid):
assignee: nobody → Leann Ogasawara (leannogasawara)
importance: Undecided → Medium
status: New → In Progress
Changed in linux-backports-modules-2.6.35 (Ubuntu Lucid):
status: New → Invalid
Changed in linux-meta (Ubuntu Lucid):
assignee: nobody → Leann Ogasawara (leannogasawara)
importance: Undecided → Medium
status: New → In Progress
description: updated
Tim Gardner (timg-tpi) on 2010-11-17
Changed in linux-backports-modules-2.6.35 (Ubuntu Maverick):
status: In Progress → Fix Committed
Changed in linux-meta (Ubuntu Maverick):
status: In Progress → Fix Committed

Accepted linux-backports-modules-2.6.32 into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in linux-backports-modules-2.6.32 (Ubuntu Lucid):
status: In Progress → Fix Committed
tags: added: verification-needed
Martin Pitt (pitti) wrote :

Accepted linux-backports-modules-2.6.35 into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-backports-modules-2.6.32 - 2.6.32-26.25

---------------
linux-backports-modules-2.6.32 (2.6.32-26.25) lucid-proposed; urgency=low

  [ Leann Ogasawara ]

  * Add compat-wireless-2.6.36
    - LP: #671052
  * Add compat-wireless-2.6.37
    - LP: #673245
 -- Stefan Bader <email address hidden> Fri, 01 Oct 2010 09:55:38 +0200

Changed in linux-backports-modules-2.6.32 (Ubuntu Lucid):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-backports-modules-2.6.35 - 2.6.35-23.13

---------------
linux-backports-modules-2.6.35 (2.6.35-23.13) maverick-proposed; urgency=low

  [ Brad Figg ]

  * Changed the Vcs line in the control.stub.in to point at the
    correct git repo.

  [ Leann Ogasawara ]

  * Allow multiple versions of compat-wireless
    - LP: #673191
  * Add compat-wireless-2.6.37
    - LP: #673245

  [ Stefan Bader ]

  * Add input drivers backports
    - LP: #527912

  [ Tim Gardner ]

  * Update to iwlwifi-6000-ucode-9.221.4.1
  * Add iwlwifi-6050 firmware
  * Added compat-wireless-2.6.36

  [ Leann Ogasawara ]

  * ABI bump
 -- Brad Figg <email address hidden> Thu, 18 Nov 2010 08:53:54 -0800

Changed in linux-backports-modules-2.6.35 (Ubuntu Maverick):
status: Fix Committed → Fix Released
Tim Gardner (timg-tpi) on 2011-01-31
Changed in linux-meta (Ubuntu Lucid):
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

Accepted linux-meta into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Rolf Leggewie (r0lf) wrote :

maverick has seen the end of its life and is no longer receiving any updates. Marking the maverick task for this ticket as "Won't Fix".

Changed in linux-meta (Ubuntu Maverick):
status: Fix Committed → Won't Fix
Rolf Leggewie (r0lf) wrote :

lucid has seen the end of its life and is no longer receiving any updates. Marking the lucid task for this ticket as "Won't Fix".

Changed in linux-meta (Ubuntu Lucid):
status: Fix Committed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers