Ubuntu

linux-backports-modules-nouveau should replace nouveau-kernel-source

Reported by Chris Halse Rogers on 2010-03-03
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux-backports-modules-2.6.32 (Ubuntu)
Undecided
Unassigned

Bug Description

Users who already use nouveau and upgrade to Lucid will have nouveau-kernel-source installed. The l-b-m-nouveau package should force the removal of nouveau-kernel-source, which is unnecessary, is likely to fail to build, and the nouveau.ko built may conflict with lbm_nouveau.ko.

The attached diff makes lbm-nouveau conflict/replaces nouveau-kernel-source to achieve this.

Lorenzo De Liso (blackz) on 2010-03-24
tags: added: patch

On 2.6.32-16 (and -15), xvinfo tells me i have Xvideo. On the current -23, it says "no adapters present".

concerning lbm-nouveau.ko and nouveau.ko, i found this on my disk:

$ locate nouveau.ko
/lib/modules/2.6.32-15-generic/updates/nouveau/lbm_nouveau.ko
/lib/modules/2.6.32-16-generic/kernel/drivers/gpu/drm/nouveau/nouveau.ko
/lib/modules/2.6.32-16-generic/updates/nouveau/lbm_nouveau.ko
/lib/modules/2.6.32-22-generic/kernel/drivers/gpu/drm/nouveau/nouveau.ko
/lib/modules/2.6.32-23-generic/kernel/drivers/gpu/drm/nouveau/nouveau.ko

So, what can i do to also have lbm_nouveau.ko modules for the newer kernels?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers