2.6.31-12.14 breaks wireless

Bug #444885 reported by Mathieu Marquer on 2009-10-06
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux-backports-modules-2.6.31 (Ubuntu)
Low
Unassigned

Bug Description

Using Ubuntu Karmic on a Samsung NC10 with Atheros AR5001 wireless card (ath5k driver)

Using 2.6.31-12.14 breaks the wireless support in Ubuntu : the driver is correctly loaded and unloaded using modprobe (and correctly shown with dmesg), but ifconfig shows no more wlan0, ifconfig wlan0 up has no effect. Uninstalling backport modules or booting on 2.6.31-11 kernel (with or without backport modules) make it working fine again.

I don't have a wired connexion, so I can't report the bug direcly through ubuntu-bug. Please let me know which logs you need to track this issue.

tags: added: regression-potential
Steve Langasek (vorlon) wrote :

Marking as low priority since backports-modules are not installed by default and you should only install them in the first place if you need them in order to support your wireless chip.

Changed in linux-backports-modules-2.6.31 (Ubuntu):
importance: Undecided → Low
Jeremy (maxthibault) wrote :

I have a acer aod250 nebook with 9.10 remix on it. all update done (2.6.31-16-generic).
My wireless is a Atheros AR928X driver ath9K
I experience the same beavior, working for a while and than stop. every thing else is still workin but when i tried to shutdown the system freeze.
i install 9.04 same driver and there is no problem with the wireless network.
Wire network is working fine for me.
I tried at my house and at work with the same behaviour.

tags: removed: regression-potential
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers