Intel WiFi Link 5100 (iwlagn) power management regression in 2.6.31

Bug #405158 reported by Matthew Lai on 2009-07-27
44
This bug affects 6 people
Affects Status Importance Assigned to Milestone
linux-backports-modules-2.6.31 (Ubuntu)
Undecided
Unassigned

Bug Description

It seems like power management is no longer supported with the Intel WiFi Link 5100 card (using iwlagn driver) with 2.6.31.

cyberfish@cyberfish-laptop:~$ sudo iwconfig wlan0 power on
[sudo] password for cyberfish:
Error for wireless request "Set Power Management" (8B2C) :
    SET failed on device wlan0 ; Operation not supported.
cyberfish@cyberfish-laptop:~$ iwconfig wlan0
wlan0 IEEE 802.11abgn ESSID:"LAI"
          Mode:Managed Frequency:2.412 GHz Access Point: 00:1C:10:B2:14:AA
          Bit Rate=54 Mb/s Tx-Power=15 dBm
          Retry long limit:7 RTS thr:off Fragment thr:off
          Power Management:off
          Link Quality=48/70 Signal level=-62 dBm Noise level=-88 dBm
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Used to work in 2.6.30.

This bug has a big effect on battery life, because it can save about 2W of power consumption, and my laptop (Acer TImeline 3810t) only consumes about 8-9W.

Thanks!

ProblemType: Bug
Architecture: i386
Date: Mon Jul 27 14:21:10 2009
DistroRelease: Ubuntu 9.10
HibernationDevice: RESUME=UUID=6f9ae10f-02b2-4a96-a7d7-700e22184757
MachineType: Acer Acer Project
Package: linux-image-2.6.31-4-generic 2.6.31-4.22
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-4-generic root=UUID=b6d9abe7-e298-4e5e-984c-336ff8330d98 ro quiet splash
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-4.22-generic
RelatedPackageVersions: linux-backports-modules-2.6.31-4-generic N/A
SourcePackage: linux
Uname: Linux 2.6.31-4-generic i686
dmi.bios.date: 05/27/2009
dmi.bios.vendor: Acer
dmi.bios.version: V1.04
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Acer Project
dmi.board.vendor: Acer
dmi.board.version: PSMBOU-1234567
dmi.chassis.asset.tag: None
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: None
dmi.modalias: dmi:bvnAcer:bvrV1.04:bd05/27/2009:svnAcer:pnAcerProject:pvrV1.04:rvnAcer:rnAcerProject:rvrPSMBOU-1234567:cvnAcer:ct10:cvrNone:
dmi.product.name: Acer Project
dmi.product.version: V1.04
dmi.sys.vendor: Acer

Matthew Lai (cyberfish) wrote :

Same Problem on x64 install

icelord (dteplitsky) wrote :

Same with intel 5350 on 2.6.31, intel firmware: 8.24.2.12

icelord (dteplitsky) wrote :

power management back to "available" after installing "linux-backports-modules-karmik"

Matthew Lai (cyberfish) wrote :

Hmm strange. I can't install that package anymore.

cyberfish@cyberfish-laptop:~$ sudo apt-get install linux-backports-modules-karmic
[sudo] password for cyberfish:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  linux-backports-modules-karmic: Depends: linux-backports-modules-karmic-generic (= 2.6.31.5.16) but it is not going to be installed
E: Broken packages
cyberfish@cyberfish-laptop:~$ sudo apt-get install linux-backports-modules-karmic-generic
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  linux-backports-modules-karmic-generic: Depends: linux-backports-modules-2.6.31-5-generic but it is not installable
E: Broken packages

It seems like it was used to get drivers from 2.6.31-5.

I installed 2.6.31-5, but the issue remains.

icelord (dteplitsky) wrote :

i'm using 2.6.31-4-general from karmik install with backports.
Power management - OK

root@ice-lenovo:~# uname -a
Linux ice-lenovo 2.6.31-4-generic #23-Ubuntu SMP Mon Jul 27 18:39:51 UTC 2009 i686 GNU/Linux

root@ice-lenovo:~# iwconfig wlan0
wlan0 IEEE 802.11abgn ESSID:"N"
          Mode:Managed Frequency:2.417 GHz Access Point: 00:14:D1:C4:86:9D
          Bit Rate=1 Mb/s Tx-Power=14 dBm
          Retry long limit:7 RTS thr:off Fragment thr:off
          Encryption key:off
          Power Management:on
          Link Quality=40/70 Signal level=-70 dBm
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Sounds fixed using linux-backports-modules-karmic. Mathew, feel free to reopen if this is not resolved for you after installing linux-backports-modules-karmic. If you still have trouble with installing, try posting to answers.launchpad.net . Thanks.

affects: linux (Ubuntu) → linux-backports-modules-2.6.31 (Ubuntu)
Changed in linux-backports-modules-2.6.31 (Ubuntu):
status: New → Fix Released
Matthew Lai (cyberfish) wrote :

Installing the package fixes it indeed. I suppose it was just broken for a second when the repository was updating to 2.6.31-5.

BTW, since it's in backports, does it mean the fix will eventually be merged into mainline? And where is it backported from? I thought the karmic kernel is already the newest.

Joan Tur (joantur) wrote :

Hi! What about people using custom kernels? How can I set the power savings of my Intel 5100agn on when running my selfcompiled kernel?

TIA

Matthew Lai (cyberfish) wrote :

Still doesn't work out of the box on alpha 4 (with 2.6.31-6). Is it going to be merged into mainline?

trendzetter (trendzetter) wrote :

I am expiercing the same problem as Matthew Lai

The following packages have unmet dependencies:
  linux-backports-modules-karmic-generic: Depends: linux-backports-modules-2.6.31-5-generic but it is not installable
E: Broken packages

trendzetter (trendzetter) wrote :

I have linux-backports-modules-2.6.31-9-generic available for installation but linux-backports-modules-2.6.31-10-generic
is required by linux-backports-modules-karmic-generic-2.6.31-10.21

In synaptic:
linux-backports-modules-karmic-generic:
 Depends: linux-backports-modules-2.6.31-10-generic but it is not installable

the backport solution is not a viable one, I get a very unreliable connection of 1mbit/s, so I can forget about wifi-N all together. When I disable the backports I get a nice transferrate of 6-8MByte/s, but of course not the power management.

Is there a better solution?

Matthew Lai (cyberfish) wrote :

That is strange.

I thought the backport version should be newer ("backported" to this release, although I don't know from where). If that's the case, you are seeing some big regression. May be a good idea to open another bug.

fowie (fowdawgg) wrote :

I have the same problem as above including the issue with not having the correct linux-backports-modules-`uname -r`-generic available. It seems that the latest version of that package available in synaptic is always one version _older_ than the version required by linux-backports-modules-karmic-generic. Running Karmic beta x64, Linux 2.6.31-13-generic #44-Ubuntu SMP Sat Oct 10 15:27:14 UTC 2009 x86_64 GNU/Linux

Matthew Lai (cyberfish) wrote :

Yeap, did an apt-get upgrade to beta and now the backports package is broken again and still no power management.

I will reopen this bug so people will look at it.

Changed in linux-backports-modules-2.6.31 (Ubuntu):
status: Fix Released → New
Pär Lindfors (paran) wrote :

For those who asked, the modules are "backported" from compat-wireless
http://linuxwireless.org.

This is code that will go into newer versions of the Linux kernel,
which will then go into newer versions of Ubuntu.

The upstream developers disabled power management on iwlagn some time
after 2.6.30 because it was buggy. It was only recently re-enabled,
after the problems was fixed. This did not make it into 2.6.31 and is
therefore not in karmic's kernel. My guess is that the changes are too
intrusive to backport into the default kernel iwlagn.

(Note, I am not a kernel developer, but the above is how I think it
is)

Pär Lindfors (paran) wrote :

I meant to intrusive to backport into the default _karmic_ kernel iwlagn.

Matthew Lai (cyberfish) wrote :

Thanks! That makes sense.

Also, the backports package is working again (upgrade to the newest kernel), so I'm marking it back to Fix Released.

Changed in linux-backports-modules-2.6.31 (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers