Very weak signal using ath9k compared to Windows driver on same machine

Bug #379861 reported by Dean Sadites on 2009-05-23
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Linux
Invalid
Medium
linux-backports-modules-2.6.28 (Ubuntu)
Undecided
Unassigned

Bug Description

This is on a Fujitsu u820 with the AR928X wireless chipset. If I boot Windows Vista I get a strong signal (typically 85% - 92%). When I boot into Ubuntu 9.10 using the ath9k driver I can connect fine, but I only get between 10% and 16% strength. Also, annoying disconnects are frequent. I can also confirm that the same thing occurred in Ubuntu 8.10. I've downloaded and compiled the nightly build (May 23) of compatible-wireless but am experiencing the same problems with weak signal and instability.

Dean Sadites (dsadites) wrote :

Of course, I meant Ubuntu 9.04, not 9.10.

Luis R. Rodriguez (mcgrof) wrote :

A patch is available to test, please try it:

http://bugzilla.kernel.org/show_bug.cgi?id=12930

This is not merged upstream yet so you will have to use wireless-testing directly. If you don't know what I am talking about then perhaps just try linux-backports-modules directly or compat-wireless:

http://wireless.kernel.org/en/users/Download

exogenetic (exogenetic) wrote :

I have a similar problem with ath9k with the AR928X wireless chipset. (Asus N50vn) It is not as pronounced, however, I only get 80 percent reception holding my laptop directly on top of my wireless router's antenna.

I downloaded the source for 2.6.28 and 2.6.30-r8. Unfortunately, the above patch is for 2.6.29, and one cannot simply include the lines and recompile for either kernel (Jaunty or Karmic.) This problem does seem solvable upstream.

The 2.6.30-r8 athk9.h file is very similar to the 2.6.29 driver code cited in the attachment at:
http://bugzilla.kernel.org/show_bug.cgi?id=12930

This following blueprint for karmic may prove useful:
https://blueprints.launchpad.net/ubuntu/+spec/kernel-karmic-wifi

It may be possible for an Ubuntu developer to communicate with Senthil Balasubramanian and still apply this patch.

exogenetic (exogenetic) wrote :

I also loaded the "bleeding edge" drivers from wireless.kernel.org. When I unpacked, it only had an updated ath5k driver.

I did not try the stable branch, because I am assuming that is what is being used in karmic. This same bug appears in Karmic Alpha 1.

iwconfig does not allow me to change options such as sensitivity or modulation.

If you have any other suggestions, I will gladly give it a try.

exogenetic (exogenetic) on 2009-06-06
Changed in ubuntu:
status: New → Confirmed
exogenetic (exogenetic) on 2009-06-06
affects: ubuntu → linux-backports-modules-2.6.28 (Ubuntu)
Changed in linux:
status: Unknown → In Progress
Changed in linux:
status: In Progress → Invalid
exogenetic (exogenetic) wrote :

The current Linux backports has solved this issue for me using Karmic:

linux-backports-modules-2.6.31-14-generic

The wireless appears to outperform my Windows 7 partition slightly.

Please remove this bug.

Changed in linux:
status: Invalid → Unknown
Changed in linux:
importance: Unknown → Medium
Changed in linux:
status: Unknown → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.