wireless network lags - rt61pci driver

Bug #287711 reported by Thorsten Hirsch on 2008-10-22
24
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
linux-backports-modules-2.6.27 (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: kernel-image-2.6.27-7-generic-di

I've got constant network lags with all kernel 2.6.27 images. A lag occurs about every 2 minutes. This bug is very annoying when playing online games.

1) Ubuntu 8.10 beta, latest updates
2) linux-image-2.6.27-7-generic 2.6.27-7.13
3) no lags
4) lags

My wireless card has a rt61 chip, using the rt61pci kernel module that comes from the rt2x00 project. I'm not sure how to further analyze this bug. There are no entries in the dmesg output. I guess the easiest way to reproduce the bug is to play an online game and have a look at the netgraph. Maybe you can also see the lag whith ping. I just pinged google.de 50 times and there was (only) one high ping (900ms vs. ~35ms in average).

Hi Thorsten,

You might want to try installing the linux-backports-modules package. It recently pulled in an updated version of the compat-wireless stack:

https://edge.launchpad.net/ubuntu/+source/linux-backports-modules-2.6.27

linux-backports-modules-2.6.27 (2.6.27-7.3) intrepid; urgency=low

  [Tim Gardner]

  * Added iwlwifi firmware
  * Added the upstream compat-wireless-2.6 tree.
  * Updated compat-wireless to wireless-testing tag master-2008-10-14
  * Set CONFIG_WIRELESS_OLD_REGULATORY=y by default.

It may help here. Let us know. Thanks.

Changed in linux:
status: New → Incomplete
Thorsten Hirsch (t-hirsch) wrote :

I installed linux-backports-modules-intrepid-generic, which was the following deb file:

linux-backports-modules-2.6.27-7-generic_2.6.27-7.4_amd64.deb

But (after rebooting) the wireless network didn't work at all. The module rt61pci wasn't loaded. When I tried it manually, I got these errors:

WARNING: Error inserting rt2x00lib (/lib/modules/2.6.27-7-generic/updates/rt2x00lib.ko): Unknown symbol in module, or unknown parameter (see dmesg)
WARNING: Error inserting rt2x00pci (/lib/modules/2.6.27-7-generic/updates/rt2x00pci.ko): Unknown symbol in module, or unknown parameter (see dmesg)
FATAL: Error inserting rt61pci (/lib/modules/2.6.27-7-generic/updates/rt61pci.ko): Unknown symbol in module, or unknown parameter (see dmesg)

Running "sudo depmod -a" didn't help. Maybe it's just a mismatch between the backports modules package and the kernel image. I'll try it again later.

Hi Thorsten,

When you try again, and if you still have issues, care to attach your full dmesg output as it should reveal some more information. Thanks.

Thorsten Hirsch (t-hirsch) wrote :

Still no luck. Now I was using these packages:

linux-backports-modules-2.6.27-7-generic 2.6.27-7.4
linux-backports-modules-intrepid 2.6.27.7.11
linux-backports-modules-intrepid-generic 2.6.27.7.11
linux-image-2.6.27-7-generic 2.6.27-7.14

These are the latest ones, no further upgrade available.
And here are the unknown symbols reported in dmesg:

[ 75.226259] rt2x00lib: no symbol version for lbm_cw_lbm_cw_ieee80211_iterate_active_interfaces_atomic
[ 75.226268] rt2x00lib: Unknown symbol lbm_cw_lbm_cw_ieee80211_iterate_active_interfaces_atomic
[ 75.228824] rt2x00pci: Unknown symbol rt2x00lib_suspend
[ 75.228921] rt2x00pci: Unknown symbol rt2x00lib_probe_dev
[ 75.230195] rt2x00pci: Unknown symbol rt2x00lib_rxdone
[ 75.230290] rt2x00pci: Unknown symbol rt2x00queue_get_entry
[ 75.230385] rt2x00pci: Unknown symbol rt2x00lib_remove_dev
[ 75.230666] rt2x00pci: Unknown symbol rt2x00lib_resume
[ 75.233391] rt61pci: Unknown symbol rt2x00mac_add_interface
[ 75.234087] rt61pci: Unknown symbol rt2x00mac_get_stats
[ 75.234216] rt61pci: Unknown symbol rt2x00pci_initialize
[ 75.234337] rt61pci: Unknown symbol rt2x00pci_uninitialize
[ 75.234429] rt61pci: Unknown symbol rt2x00queue_get_entry
[ 75.234548] rt61pci: Unknown symbol rt2x00pci_suspend
[ 75.234640] rt61pci: Unknown symbol rt2x00mac_config_interface
[ 75.234770] rt61pci: Unknown symbol rt2x00pci_remove
[ 75.234862] rt61pci: Unknown symbol rt2x00mac_remove_interface
[ 75.234954] rt61pci: Unknown symbol rt2x00lib_txdone
[ 75.235046] rt61pci: Unknown symbol rt2x00mac_config
[ 75.235138] rt61pci: Unknown symbol rt2x00queue_get_queue
[ 75.235230] rt61pci: Unknown symbol rt2x00mac_conf_tx
[ 75.237587] rt61pci: Unknown symbol rt2x00mac_start
[ 75.237682] rt61pci: Unknown symbol rt2x00mac_stop
[ 75.237805] rt61pci: Unknown symbol rt2x00mac_configure_filter
[ 75.237898] rt61pci: Unknown symbol rt2x00mac_tx
[ 75.237990] rt61pci: Unknown symbol rt2x00pci_resume
[ 75.238106] rt61pci: Unknown symbol rt2x00pci_probe
[ 75.238198] rt61pci: Unknown symbol rt2x00mac_get_tx_stats
[ 75.238391] rt61pci: Unknown symbol rt2x00pci_rxdone
[ 75.238498] rt61pci: Unknown symbol rt2x00mac_bss_info_changed
[ 75.238590] rt61pci: Unknown symbol rt2x00pci_write_tx_data

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → High
status: Incomplete → Triaged
Thorsten Hirsch (t-hirsch) wrote :

Again, though there's a new kernel package, the rt2x00 drivers in the backports package don't match. These are my installed packages:

linux-image-2.6.27-7-generic 2.6.27-7.15
linux-backports-modules-2.6.27-7-generic 2.6.27-7.4

And here are the unresolved symbols:

[ 12.840833] rt61pci: Unknown symbol rt2x00mac_add_interface
[ 12.840989] rt61pci: Unknown symbol rt2x00mac_get_stats
[ 12.841064] rt61pci: Unknown symbol rt2x00pci_initialize
[ 12.841136] rt61pci: Unknown symbol rt2x00pci_uninitialize
[ 12.841189] rt61pci: Unknown symbol rt2x00queue_get_entry
[ 12.841260] rt61pci: Unknown symbol rt2x00pci_suspend
[ 12.841313] rt61pci: Unknown symbol rt2x00mac_config_interface
[ 12.841391] rt61pci: Unknown symbol rt2x00pci_remove
[ 12.841445] rt61pci: Unknown symbol rt2x00mac_remove_interface
[ 12.841499] rt61pci: Unknown symbol rt2x00lib_txdone
[ 12.841552] rt61pci: Unknown symbol rt2x00mac_config
[ 12.841606] rt61pci: Unknown symbol rt2x00queue_get_queue
[ 12.841659] rt61pci: Unknown symbol rt2x00mac_conf_tx
[ 12.841766] rt61pci: Unknown symbol rt2x00mac_start
[ 12.841819] rt61pci: Unknown symbol rt2x00mac_stop
[ 12.841893] rt61pci: Unknown symbol rt2x00mac_configure_filter
[ 12.841946] rt61pci: Unknown symbol rt2x00mac_tx
[ 12.842000] rt61pci: Unknown symbol rt2x00pci_resume
[ 12.842068] rt61pci: Unknown symbol rt2x00pci_probe
[ 12.842122] rt61pci: Unknown symbol rt2x00mac_get_tx_stats
[ 12.842234] rt61pci: Unknown symbol rt2x00pci_rxdone
[ 12.842297] rt61pci: Unknown symbol rt2x00mac_bss_info_changed
[ 12.842350] rt61pci: Unknown symbol rt2x00pci_write_tx_data

Hi,

I searched for known bugs concerning the rt61pci driver and suspending/hibernation.

Also I did not get this error, I thought I could install the backport-package (to see, if it fixes my problems). And I can confirm that the backports package does have problems. See the attached file.

The only reason for answering here is to provide the missing dmesg-output, which the original author did not give.

So the original author and I are unable to use the backport package.

Christian

Thorsten Hirsch (t-hirsch) wrote :

No update after 2 weeks and the backport modules still don't work with the kernel. Isn't anybody responsible for the backport modules package?!

Thorsten Hirsch (t-hirsch) wrote :

fixed in linux-backports-modules-2.6.27-9-generic 2.6.27-9.5

Changed in linux-backports-modules-2.6.27:
status: Triaged → Fix Released
Thorsten Hirsch (t-hirsch) wrote :

Sorry, I mean: the backports-modules now work with the kernel, but the rt61pci driver still lags.

Changed in linux-backports-modules-2.6.27:
status: Fix Released → Confirmed

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Andy Whitcroft (apw) on 2009-03-17
Changed in linux:
importance: Undecided → Medium

Hi t-hirsch,

This bug was reported while ago and there hasn't been any activity in it recently. We were wondering is this still an issue? Can you try with the latest development release of Ubuntu? (ISO CD images are available from http://cdimage.ubuntu.com/releases/)

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux-image-`uname -r` 287711

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: needs-verification
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete

Architecture: amd64
DistroRelease: Ubuntu 9.04
HibernationDevice: RESUME=/dev/sda1
MachineType: MICRO-STAR INTERNATIONAL CO.,LTD MS-7519
NonfreeKernelModules: nvidia
Package: linux-image-2.6.28-11-generic 2.6.28-11.42
PackageArchitecture: amd64
ProcCmdLine: root=UUID=4616b377-aab4-4e3d-bccd-0439346680ee ro quiet splash vga=795
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=de_DE.UTF-8
ProcVersionSignature: Ubuntu 2.6.28-11.42-generic
Uname: Linux 2.6.28-11-generic x86_64
UserGroups: adm admin audio cdrom dialout floppy games lpadmin operator plugdev sambashare scanner video

Thorsten Hirsch (t-hirsch) wrote :
Thorsten Hirsch (t-hirsch) wrote :
Thorsten Hirsch (t-hirsch) wrote :
Thorsten Hirsch (t-hirsch) wrote :
Thorsten Hirsch (t-hirsch) wrote :
Thorsten Hirsch (t-hirsch) wrote :
Thorsten Hirsch (t-hirsch) wrote :
Thorsten Hirsch (t-hirsch) wrote :
Thorsten Hirsch (t-hirsch) wrote :
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: removed: needs-kernel-logs
tags: removed: needs-verification

Architecture: i386
DistroRelease: Ubuntu 9.04
HibernationDevice: RESUME=UUID=b2525f32-5d23-4ba2-8334-1651335c9d3e
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 002: ID 413c:2105 Dell Computer Corp.
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: MICRO-STAR INTERNATIONAL CO., LTD MS-7125
NonfreeKernelModules: nvidia
Package: linux-image-2.6.28-11-generic 2.6.28-11.42
PackageArchitecture: i386
ProcCmdLine: root=UUID=8171d637-0213-4982-af43-1ce511c19473 ro quiet splash
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_GB.UTF-8
ProcVersionSignature: Ubuntu 2.6.28-11.42-generic
Uname: Linux 2.6.28-11-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Hi, I've been having the same problem as described by Thorsten for some months now. Like he says, it's most noticable in online games where every minute or so there's an outage that lasts ~1sec - during which time I usually die!

I had been assuming that it was because I bought a cheap crummy router, but having recently replaced the router I've found the problem continues unabated. Found this bug report after doing lsmod to find the name of my wireless driver and then googling it to see if anyone else was having trouble.

Output from apport-collect is posted above, let me know if there's any other info I can provide.

I'm also affected by what most likely is this bug. The network is experiencing repeated ping spikes where everything is unavailable. In my case they last longer than 1 sec, maybe 20-ish: long enough to cause IM-clients and music-streaming services to disconnect, and in general just making Internet impossible to use for a short period of time.

Gabriel Rauter (raetiacorvus) wrote :

on Karmic i have to turn of the power managment of the driver
sudo iwconfig wlan0 power off

if I don't do this it is realy slow and lags.
I don't know if this is releated to this bug.

Hi,

I just gave it a try, but it makes no difference. The lags are still
there when power management is turned off.

Thorsten

2009/8/26 sirblackheart <email address hidden>:
> on Karmic i have to turn of the power managment of the driver
> sudo iwconfig wlan0 power off
>
> if I don't do this it is realy slow and lags.
> I don't know if this is releated to this bug.

With the latest version of the Linux kernel ,version 2.6.31, I do not have any trouble with the RT61PCI driver, with the latest firmware. Note that this is the driver that ships with the Linux kernel, not the one from the driver developer's website. I'm using a "custom" kernel, set to be a low-latency preemptive kernel with a clock rate of 1000HZ instead of the 250HZ that the Ubuntu kernel is compiled with.

One of the changes from 2.6.24 to 2.6.31 is how the driver behaves.

Before, parameters could not be set unless you issued a ifconfig wlan0 up command, with 2.6.31, you can not configure the device is down (eg ifconfig wlan0 down)-- exactly the opposite.

The WiFi device WILL NOT come up right away. It will take about a minute to connect to the network... ether that, or it's due to me using a hacked Android-based Google G1 phone to share my 3G network connection via it's WiFi interface and http://code.google.com/p/android-wifi-tether/ but anyway..

I'd like to point out I WAS NOT able get the PCI card to work with stock Ubuntu kernels and drivers.

Thorsten Hirsch (t-hirsch) wrote :

Well, I just tried Karmic Alpha6 (kernel 2.6.31) and I still experience the lag. :-(
I've attached the output of...

modinfo rt61pci
modinfo nvidia
dmesg
uname -a

...in lags.txt
You can see 2 disassociations in the dmesg output, but i don't think, that they represent the lags, because I experienced ~6 lags (each took ~1 sec) when I was playing urban terror. I joined different servers to make sure that the lags are not caused by the game server.

Matthew Eaton (powder) wrote :

I am also experiencing this same issue. I'm not sure what logs are needed so I attached the same logs as Thorsten.

Matthew Eaton (powder) wrote :

Here is a screenshot of the lag in Open Arena (the red bar).

Sikiatriko (arturober) wrote :

Same problem here with Kubuntu Karmic updated until today (21st oct.).

Jeremy Foshee (jeremyfoshee) wrote :

Thorsten,
      Would you mind testing this with the latest Lucid Alpha?

Thanks!

-JFo

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Thorsten Hirsch (t-hirsch) wrote :

Hi Jeremy,

I'd really like to, but somehow I can't boot the alphas. I tried both,
alpha-1 and alpha-2, but they both only show me grub's boot prompt and
I can't boot any kernel image. I also tried kubuntu's alpha-2, but
still the same problem. There must be something wrong here.
Actually I'm waiting for alpha-3 and if I still have the same problem,
I'll investigate it further.

Thorsten

2010/2/11 Jeremy Foshee <email address hidden>:
> Thorsten,
>      Would you mind testing this with the latest Lucid Alpha?
>
> Thanks!
>
> -JFo
>
> ** Changed in: linux (Ubuntu)
>       Status: Confirmed => Incomplete
>
> --
> wireless network lags - rt61pci driver
> https://bugs.launchpad.net/bugs/287711
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Fail2Ban (failtoban) on 2010-02-20
tags: added: hw-specific kernel-bug verification-needed
Mitch Towner (kermiac) wrote :

@ Fail2Ban: please do not assign tags without first reading https://wiki.ubuntu.com/Bugs/Tags
Thanks in advance!

tags: removed: kernel-bug verification-needed

I am also experiencing this bug. I've mainly noticed problems when trying to use Skype, and getting frequent drop-outs.

If I ping my wifi router, I see a string of 0.5-5ms latencies, and then every oncein a while (every minute or two) it stops producing output for a few seconds, and then I see about a half-dozen responses show up at the same time with 6sec, 5sec, 4sec, etc. latencies.

I'm using the most up-to-date karmic (2.6.31-20-generic kernel) 64-bit.

Thanks!

-spencer

Thorsten Hirsch (t-hirsch) wrote :

Jeremy,

meanwhile I could test Lucid Beta and unfortunately the issue is still present!

Regards,
Thorsten

Matthew Eaton (powder) wrote :

I just played OpenArena for about an hour with no network lags in Lucid Beta (updated to 4/1/2010).

Linux deathstar 2.6.32-19-generic #28-Ubuntu SMP Thu Apr 1 10:39:41 UTC 2010 x86_64 GNU/Linux

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Incomplete → Won't Fix
Thorsten Hirsch (t-hirsch) wrote :

My computer experienced this bug up to 12.04 (kernel 3.2). Now in 12.10 (kernel 3.5) it's finally fixed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers