2.6.27: loads ath_pci instead of ath5k

Bug #262516 reported by Martin Emrich on 2008-08-29
30
Affects Status Importance Assigned to Milestone
linux-backports-modules-2.6.27 (Ubuntu)
Undecided
Unassigned

Bug Description

Since the upgrade to the new 2.6.27 kernel, the old madwifi driver (ath_pci) for my wireless card is loaded again instead of the new ath5k driver. With 2.6.26, it loaded ath5k by default. Ath5k works better than madwifi (faster association, connection more stable).

For now, I have blacklisted the ath_pci module.

Steffen Röcker (sroecker) wrote :

I can confirm this. I also have blacklisted ath_pci. It doesn't work anymore for me because network-manager dropped all workarounds for connecting with hidden aps.

Maybe ath_pci should be blacklisted by default?
(a user at bug #253881 says he needs ath_pci but that could have changed with 2.6.27)

damagedspline (icpazi) wrote :

I can confirm this as well on a Fujitsu-Seimens Amilo A1650g
$ uname -a
Linux asaf-laptop 2.6.27-2-generic #1 SMP Thu Aug 28 17:20:02 UTC 2008 i686 GNU/Linux

$ cat /etc/issue
Ubuntu intrepid (development branch) \n \l

Jeffrey Baker (jwbaker) wrote :

Confirmed on a ThinkPad X61. ath_pci and ath5k are both loaded. Because of this, the wifi never works on resume from suspend.

Changed in linux-meta:
status: New → Confirmed

Can confirm this on a Vaio VGN-N21S.

$ uname -a
Linux sincity 2.6.27-3-generic #1 SMP Wed Sep 10 16:18:52 UTC 2008 x86_64 GNU/Linux

$ cat /etc/issue
Ubuntu intrepid (development branch) \n \l

Hi All,

There haven't been any recent comments to this bug but I think this issue should have been resolved by installing linux-backports-modules-intrepid which provides the ath5k driver and should subsequently load ath5k instead of ath_pci. I'm marking this Fix Released for now, but if this is not the case, feel free to post a comment and set the status back to New. Thanks.

Changed in linux-meta:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers