Intel Wireless 4965AGN (iwl4965) & network-manager doesn't work

Bug #194091 reported by Bastian Becker on 2008-02-21
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-backports-modules-2.6.27 (Ubuntu)
Undecided
Unassigned
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned

Bug Description

I have a Intel Wireless 4965 AGN chip. If I have installed a fresh copy of Ubuntu, the first time I've start Ubuntu it works fine using the Gnome Network-Manager and 4965 chip. But if I restart my computer, he doesn't connect to my network. Some other problems with it:

* If I change or disconnect a wireless network, gnome-network-manager can't connect
* No connection on startup
* No information about connectivity (80%, 90% and so on...)

It works only if I type in a terminal "sudo modprobe -r iwl4965" and then reinitialize the module. Then I have to type "sudo ifdown wlan0" and "sudo ifup wlan0", sometimes more than 5 times. If I type "iwlist scan" he says "No wireless networks found" or he displays nothing about my wlan-adapter. Now I use wicd instead of the gnome network-manager, but sometimes wicd get also no connection and I have to restart my computer or reinitialize the module.

System: Ubuntu Gutsy Gibbon with all updates
Toshiba Satellite P200-1E9

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately we can't fix it, because your description does not yet have enough information.

Please include the following additional information, if you have not already done so (pay attention to lspci's additional options), as required by the Ubuntu Kernel Team:
1. Please include the output of the command "uname -a" in your next response. It should be one, long line of text which includes the exact kernel version you're running, as well as the CPU architecture.
2. Please run the command "dmesg > dmesg.log" after a fresh boot and attach the resulting file "dmesg.log" to this bug report.
3. Please run the command "sudo lspci -vvnn > lspci-vvnn.log" and attach the resulting file "lspci-vvnn.log" to this bug report.

For your reference, the full description of procedures for kernel-related bug reports is available at [WWW] http://wiki.ubuntu.com/KernelTeamBugPolicies. Thanks in advance!

Hi, enclosed you will find the requested uname and dmesg log.

1) Linux BB-Satellite 2.6.22-14-generic #1 SMP Tue Feb 12 07:42:25 UTC 2008 i686 GNU/Linux

Here is the lscpi file.

Changed in linux-source-2.6.22:
status: Incomplete → Confirmed
matt (dogscoff) wrote :

Dale, you have several people desperately trying to get hold of you. Please check you efficientpc email / launchpad.

Hardy Alpha 5 is also affected.

Hi there, I thin since the last updates, the problem got bigger. Now with every start of my system, I can't connect to my wireless network. Only if I run 5 or more times "sudo modprobe -r iwl4965" and "sudo modprobe iwl4965", it works. This is really a big problem and I don't know what the reason for this fault is.

Ok, now it has a bit changed. Since the last updates, I have to type only "sudo /etc/init.d/networking restart" and then the connection works fine. That's ok but the connection should be avaible on startup.

1) What can I do to automate the manual network restart
2) When will it be fixed?

John Carragher (jcarragher) wrote :

I believe I have an intermittent hardware fault whereby the wireless network hardware. Under Vista I sometimes get an amber LCD indication that wireless networking is operable (and it works then) but after moving the notebook the LCD is not lit, wireless networking is disabled and Vista prompts for drivers. Before installing Ubuntu I made sure that Vista was recognising the wireless hardware correctly.

When I ran dmesg it reported that the problem was to do with the wireless kill switch being turned on. From what I found on the Internet this seems to be a common problem. On the Acer 5720 there is no BIOS option to disable the kill switch and the Function F2 toggle does not work under Ubuntu 8.04.

I've tried various utilities for wireless network management etc. None no about the N speed and most don't know about anything except WEP for security. I did find that 2 of my neighbours wireless networks could be scanned whilst my own - less than a metre away - did not.

Congratulations on Ubuntu. It has reached the point where the only issues on my list are wireless network support and TV support. The latter is a separate issue.

It strikes me as though
 Beta has recognised the hardware.

DannyDei (dei-bnb) wrote :
  • dd Edit (79.9 KiB, text/plain)

Hello guys

I have a similar problem with my Samsung q45 ( uname,dmesg and lspci attached ) : the iwl4965 works always fine from XP professional and from Ubuntu with many routers and SSID but at home it won't get the signal of my own router which is perfectly fine with other PCs.

I thought it was because of the old USR9111 router in Gutsy but it was the same with Hardy and it is now the same with a new NETGEAR DG834PN : the iwl4965 works fine from XP with a driver dated back to 27th April 2007 11.1.0.100 but it won't work with Hardy.

I've followed the

https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.22/+bug/149214/comments/24

and tried the procedure with the drivers iwlwifi-4965-ucode-4.44 from version 14 to version 20 taken from the site

http://www.intellinuxwireless.org/?n=downloads&f=ucode&p=iwlwifi

no success !! I'm curious to go back t
o the office tomorrow and see what will happen with the netgear there which was spot on immediately !!

Anyone of you has got any idea ? It is so frustrating to use a cable with a Super Portable Laptop !!

Thank you in advance
Danny ( Florence Italy )

DannyDei (dei-bnb) wrote :

the iwl4965 doesn't work neither with the latest kernel 2.6.24.17 generic .

( attached the log file with uname + dmesg + lspci )

Peter Magnusson (kmpm) wrote :

I have the same problem on my Sony Vaio SZ71. I know the Vaio is a troublesome bastard in the linux world but I don't think that's the issue here.

I sometimes get the wireless up and running but I still haven't found out what procedures that makes it work.
The hardware kill switch seem to work, don't know of any software one in linux. When I dual-boot to Vista I am able to software-kill the nic.

It always works in Vista ( but I don't like spending time in there ).

I will get back with logs later.

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this bug to the new "linux" package. However, development has already began for the upcoming Intrepid Ibex 8.10 release. It would be helpful if you could test the upcoming release and verify if this is still an issue - http://www.ubuntu.com/testing . If the issue still exists, please update this report by changing the Status of the "linux" task from "Incomplete" to "New". We appreciate your patience and understanding as we make this transition. Thanks!

It was a hardware problem. Hardy is doing a great job now that the
notebook has been repaired. I've setup the notebook to dual boot and the
wireless network module stops working for either at times. When this
happens I run off battery for a bit and the problem goes away. It is an
ASUS design problem.

Thanks
John

On Mon, 2008-08-11 at 15:21 +0000, Launchpad Bug Tracker wrote:
> Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu
> kernel bugs need to be reported against the "linux" kernel package. We
> are automatically migrating this bug to the new "linux" package.
> However, development has already began for the upcoming Intrepid Ibex
> 8.10 release. It would be helpful if you could test the upcoming
> release and verify if this is still an issue -
> http://www.ubuntu.com/testing . If the issue still exists, please
> update this report by changing the Status of the "linux" task from
> "Incomplete" to "New". We appreciate your patience and understanding as
> we make this transition. Thanks!
>

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Everett Guerny (everett) wrote :

Hi,

I've never had a problem with my Intel 4965 card under Hardy, but just tried the Intrepid Alpha 5 LiveCD and found that the card is suddenly not working as others here have described, using the 2.6.27-2-generic kernel.

Is there any other information I can add to this bug in order to be more helpful?

My problem was due to an intermittent hardware fault. Acer repaired the
notebook and most of the time it works. I'm dual booting Visa and Ubuntu
8.04 and still have problems occasionally but when this happens both
operating systems are affected. I've found that removing mains power and
running off batteries for a bit always results in the card coming to
life. Strange but true.

I haven't had a chance to try Intrepid yet but will do so in the light
of your experience.

Regards
John

On Sun, 2008-09-07 at 18:40 +0000, Everett Guerny wrote:
> Hi,
>
> I've never had a problem with my Intel 4965 card under Hardy, but just
> tried the Intrepid Alpha 5 LiveCD and found that the card is suddenly
> not working as others here have described, using the 2.6.27-2-generic
> kernel.
>
> Is there any other information I can add to this bug in order to be more
> helpful?
>

Laurent Bigonville (bigon) wrote :

I have some problem with this card ans nm too.

Sometimes nm doesn't associate to the network (hidden) and I have to select it manually from the "connect to other network" dialog.

I'm pretty sure this was working with my previous laptop with an ipw2200 card

John Carragher (jcarragher) wrote :

My problem was not due to Ubuntu. It was a hardware issue caused erratic
behaviour. My Acer Aspire 5720 is now dual booting with Vista and after
the repair made by Acer I don't have a problem as often as before.

I find that when the battery is fully charged the network card is
recognised but does not work - with either operating system - but if I
run off the battery for 5 minutes and then reboot that both operating
systems deal with the network device again.

I downloaded 8.10 Alpha 6 today so that I could provide feedback as to
how it works on the notebook. After about 3 hours I've given up trying
to get it running in non-install mode on the notebook. I downloaded the
AMD 64 bit version and have tried that on my desktop machine and like
what I see.

I burnt the 32 bit version for the notebook at 4X rather than the
maximum speed of 52X and verified it. I also let the Ubuntu install
check the CD and it was 100% OK.

On the notebook I'm opting for running off the CD. The wireless network
indicator light comes on as does the blue tooth light. Under 8.04 the
wireless network light was not turned on even though wireless networking
was enabled.

The run from CD process (notebook) goes through the usual progress bar
stuff, brings up the X mouse cursor and the beige background then the
wait cursor. The wait cursor is static (ie no rotation effect). It is
now over 1/2 hour since this has been the case on the Acer notebook and
will probably be the case until hell freezes over or the power fails and
the battery dies.

Regards
John

On Thu, 2008-09-18 at 14:14 +0000, Laurent Bigonville wrote:
> I have some problem with this card ans nm too.
>
> Sometimes nm doesn't associate to the network (hidden) and I have to
> select it manually from the "connect to other network" dialog.
>
> I'm pretty sure this was working with my previous laptop with an ipw2200
> card
>

The bug is solved since a few months. If there are still issues for some users, please re-open this bug.

Problem solved

Changed in linux:
status: Incomplete → Invalid

Then I mark the bug as fixed! Thank you!

Changed in linux-backports-modules-2.6.27 (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers