[Hardy] Support Intel 82574L gigabit ethernet cards

Bug #805854 reported by Stefan Bader
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-backports-modules-2.6.24 (Ubuntu)
Wishlist
Stefan Bader

Bug Description

SRU Justification:

Impact: The e1000e driver shipped with Hardy does not support the 82574L cards found on some newer server boards. This prevents any network connection for those.

Fix: Pick the latest standalone driver from Intel and replace the current e1000e code in the backports modules package with that.

Testcase: Using the new backports driver network card(s) are detected and working. Before that no network card was detected.

Stefan Bader (smb)
Changed in linux-backports-modules-2.6.24 (Ubuntu):
assignee: nobody → Stefan Bader (stefan-bader-canonical)
importance: Undecided → Wishlist
status: New → In Progress
description: updated
Tim Gardner (timg-tpi)
Changed in linux-backports-modules-2.6.24 (Ubuntu):
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-backports-modules-2.6.24 - 2.6.24-30.42

---------------
linux-backports-modules-2.6.24 (2.6.24-30.42) hardy-proposed; urgency=low

  [Upstream Kernel Changes]

  * e1000e: Update driver to Intel v1.3.17
    - LP: #805854
 -- Herton Ronaldo Krzesinski <email address hidden> Mon, 07 Nov 2011 20:48:40 -0200

Changed in linux-backports-modules-2.6.24 (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
andy brian (chinaitvc) wrote :

Just for guys who may arrive here after searching:
1.there's kernel bug in intel 82574L e1000e driver on centos 6(MSI/MSI-X interrupts issue), we can resolve this by install kmod-e1000e package from ELrepo.org and later add pcie_aspm=off e1000e.IntMode=1,1 e1000e.InterruptThrottleRate=10000,10000 acpi=off to kernel parameters. You can read more info [URL="http://www.doxer.org/learn-linux/resolved-intel-e1000e-driver-bug-on-82574l-ethernet-controller-causing-network-blipping/"]Intel e1000e driver bug on 82574L Ethernet controller causing network blipping[/URL].
2.For the high Tx traffic, this was caused by port 53 dns flooding attack. I've resolved this by writing some iptable rules. More info here: [URL="http://www.doxer.org/learn-linux/resolved-port-53-dns-flooding-attack/"]port 53 dns flooding attack[/URL]

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers