FATAL: Error inserting wl (/lib/modules/2.6.24-21-generic/volatile/wl.ko): Unknown symbol in module

Bug #271191 reported by Nick Fox on 2008-09-17
6
Affects Status Importance Assigned to Milestone
linux-backports-modules-2.6.24 (Ubuntu)
High
Tim Gardner

Bug Description

2.6.24-21-generic #1 SMP Mon Aug 25 17:32:09 UTC 2008 i686 GNU/Linux

modprobe wl produces:

$ sudo modprobe wl
FATAL: Error inserting wl (/lib/modules/2.6.24-21-generic/volatile/wl.ko): Unknown symbol in module, or unknown parameter (see dmesg)

dmesg:

[ 148.379927] wl: Unknown symbol ieee80211_get_crypto_ops
[ 151.847992] wl: disagrees about version of symbol ieee80211_get_crypto_ops
[ 151.848005] wl: Unknown symbol ieee80211_get_crypto_ops

Mario Limonciello (superm1) wrote :

This is directly caused by having linux-backports-modules-hardy (and it's dependencies) installed. This is the case out of the Dell factory image.

The offending module is ieee80211_crypt.

To work around the scenario, you need to follow the following steps:

1) sudo apt-get remove linux-backports-modules-2.6.24-21-generic
2) sudo rmmod ieee80211_crypt
3) sudo modprobe wl

It should work properly going forward then, but this bug needs to be fixed before lrm is released from proposed.

Changed in linux-restricted-modules-2.6.24:
assignee: nobody → timg-tpi
status: New → Confirmed
Changed in dell:
importance: Undecided → High
status: New → Confirmed
Tim Gardner (timg-tpi) wrote :

I have this fixed in the LBM git repo, but I'm still having a build problem in the PPA.

Martin Pitt (pitti) wrote :

For the record, Tim just confirmed that this is solved with the recent linux-backports-modules upload.

Changed in linux-restricted-modules-2.6.24:
status: Confirmed → Fix Committed
Mario Limonciello (superm1) wrote :

That problem is fixed, but it appears that there are still problems when LBM is installed. I encounter RTNL: assertion failures. See the attached dmesg.

Changed in linux-backports-modules-2.6.24:
status: Fix Committed → Confirmed
Tim Gardner (timg-tpi) wrote :

I'm thinking this is fixed. I have a fulled updated Hardy laptop with LBM installed, and no issues.

Changed in linux-backports-modules-2.6.24:
importance: Undecided → High
milestone: none → ubuntu-8.04.2
status: Confirmed → Fix Released
Mario Limonciello (superm1) wrote :

I can confirm Tim's last upload did resolve this. Works for me now without assertion errors.

Changed in linux-backports-modules-2.6.24:
status: Fix Released → Fix Committed
Changed in dell:
status: Confirmed → Fix Committed
Changed in dell:
status: Fix Committed → Fix Released
Changed in linux-backports-modules-2.6.24:
status: Fix Committed → Fix Released
Changed in somerville:
importance: Undecided → High
status: New → Fix Released
no longer affects: dell
Timothy R. Chavez (timrchavez) wrote :

The bug task for the somerville project has been removed by an automated script. This bug has been cloned on that project and is available here: https://bugs.launchpad.net/bugs/1305501

no longer affects: somerville
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments