[regression] b44 module does not load in kernel 2.6.24-21

Bug #251538 reported by Sandro Mani on 2008-07-24
28
Affects Status Importance Assigned to Milestone
linux-backports-modules-2.6.24 (Ubuntu)
High
Tim Gardner
Hardy
High
Tim Gardner

Bug Description

Using kernel 2.6.24-21, the b44 module isn't loaded anymore at startup. Trying to load it manually fails, syslog reports:
Jul 24 17:34:04 PC3 kernel: [ 398.717597] b44: disagrees about version of symbol ssb_device_is_enabled
Jul 24 17:34:04 PC3 kernel: [ 398.717608] b44: Unknown symbol ssb_device_is_enabled
Jul 24 17:34:04 PC3 kernel: [ 398.717725] b44: disagrees about version of symbol ssb_pcicore_dev_irqvecs_enable
Jul 24 17:34:04 PC3 kernel: [ 398.717730] b44: Unknown symbol ssb_pcicore_dev_irqvecs_enable
Jul 24 17:34:04 PC3 kernel: [ 398.717939] b44: disagrees about version of symbol ssb_bus_may_powerdown
Jul 24 17:34:04 PC3 kernel: [ 398.717944] b44: Unknown symbol ssb_bus_may_powerdown
Jul 24 17:34:04 PC3 kernel: [ 398.718204] b44: disagrees about version of symbol ssb_pcihost_register
Jul 24 17:34:04 PC3 kernel: [ 398.718208] b44: Unknown symbol ssb_pcihost_register
Jul 24 17:34:04 PC3 kernel: [ 398.718622] b44: disagrees about version of symbol ssb_dma_set_mask
Jul 24 17:34:04 PC3 kernel: [ 398.718626] b44: Unknown symbol ssb_dma_set_mask
Jul 24 17:34:04 PC3 kernel: [ 398.718901] b44: disagrees about version of symbol ssb_device_enable
Jul 24 17:34:04 PC3 kernel: [ 398.718905] b44: Unknown symbol ssb_device_enable
Jul 24 17:34:04 PC3 kernel: [ 398.719243] b44: disagrees about version of symbol ssb_driver_unregister
Jul 24 17:34:04 PC3 kernel: [ 398.719247] b44: Unknown symbol ssb_driver_unregister
Jul 24 17:34:04 PC3 kernel: [ 398.719472] b44: disagrees about version of symbol __ssb_driver_register
Jul 24 17:34:04 PC3 kernel: [ 398.719476] b44: Unknown symbol __ssb_driver_register
Jul 24 17:34:04 PC3 kernel: [ 398.719648] b44: disagrees about version of symbol ssb_bus_powerup
Jul 24 17:34:04 PC3 kernel: [ 398.719652] b44: Unknown symbol ssb_bus_powerup
Jul 24 17:34:04 PC3 kernel: [ 398.720071] b44: disagrees about version of symbol ssb_clockspeed
Jul 24 17:34:04 PC3 kernel: [ 398.720075] b44: Unknown symbol ssb_clockspeed
Jul 24 17:34:04 PC3 kernel: [ 398.720214] b44: disagrees about version of symbol ssb_dma_translation
Jul 24 17:34:04 PC3 kernel: [ 398.720218] b44: Unknown symbol ssb_dma_translation

Michael Sparmann (theseven) wrote :

I can confirm this; it turned up after the update to 2.6.24-20, along with some other weirdnesses.

Confirming on a Dell Vostro 1500. lspci -vvn and dmesg follow.

description: updated
Mathieu Marquer (slasher-fun) wrote :
Mathieu Marquer (slasher-fun) wrote :
Changed in linux:
status: New → Confirmed
StingX (stingx) wrote :

I can confirm too. Same results in syslog.
Dell Inspiron 9400, network card: BCM4401-B0 100Base-TX

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: Confirmed → Triaged
Sandro Mani (sandromani) wrote :

The issue seems to be fixed in the linux-ubuntu-modules-2.6.24-20-generic package, version 2.6.24-20.29.

Tim Gardner (timg-tpi) wrote :

I think this is related to Hardy linux-backports-modules, which contains the upstream version of the wireless protocol stack (as well as the upstream ssb). I've uploaded LBM 2.6.24-20.21 with munged symbols so that this conflict no longer occurs.

Mathieu Marquer (slasher-fun) wrote :

Confirming, it works fine again with the last linux-backports-modules-2.6.24-20-generic update.

Tim Gardner (timg-tpi) wrote :

linux-backports-modules-2.6.24 (2.6.24-20.21) hardy-proposed; urgency=low

  [Tim Gardner]

  * Munged compat-wireless symbols and module names so as not to conflict with
    kernel/lum package symbols.
    Synced compat-wireless to master-2008-07-28
    - LP: #252630

 -- Tim Gardner <email address hidden> Tue, 29 Jul 2008 14:44:50 -0600

Changed in linux:
status: Triaged → Fix Released
Pete Graner (pgraner) on 2008-08-14
Changed in linux:
assignee: ubuntu-kernel-team → timg-tpi
Sandro Mani (sandromani) wrote :

Bug reappeared in kernel 2.6.24.21 update, dmesg:

b44: disagrees about version of symbol ssb_device_is_enabled
b44: Unknown symbol ssb_device_is_enabled
b44: disagrees about version of symbol ssb_pcicore_dev_irqvecs_enable
b44: Unknown symbol ssb_pcicore_dev_irqvecs_enable
b44: disagrees about version of symbol ssb_bus_may_powerdown
b44: Unknown symbol ssb_bus_may_powerdown
b44: disagrees about version of symbol ssb_pcihost_register
b44: Unknown symbol ssb_pcihost_register
b44: disagrees about version of symbol ssb_dma_set_mask
b44: Unknown symbol ssb_dma_set_mask
b44: disagrees about version of symbol ssb_device_enable
b44: Unknown symbol ssb_device_enable
b44: disagrees about version of symbol ssb_driver_unregister
b44: Unknown symbol ssb_driver_unregister
b44: disagrees about version of symbol __ssb_driver_register
b44: Unknown symbol __ssb_driver_register
b44: disagrees about version of symbol ssb_bus_powerup
b44: Unknown symbol ssb_bus_powerup
b44: disagrees about version of symbol ssb_clockspeed
b44: Unknown symbol ssb_clockspeed
b44: disagrees about version of symbol ssb_dma_translation
b44: Unknown symbol ssb_dma_translation

Mathieu Marquer (slasher-fun) wrote :

Reopening for kernel 2.6.24-21 since the problem is here again with it

description: updated
Changed in linux:
status: Fix Released → Confirmed
Brian Murray (brian-murray) wrote :

Could someone experiencing this with 2.6.24-21 please include the output of modinfo b44? Thanks in advance.

Changed in linux:
status: Confirmed → Incomplete
Sandro Mani (sandromani) wrote :

Here's the output of modinfo b44.

Tim Gardner (timg-tpi) wrote :

SRU Justification

The b44 driver, even though it is a PCI device, uses the SSB bus driver to perform I/O over the PCI bus. The SSB bus driver is actually the registrant for the PCI ID of the b44 device. Obviously, if the upstream SSB interfaces change (as did those from compat-wireless), then so does the b44 have to change.

Impact: b44 ethernet cannot load when Hardy linux-backports-modules is installed

Patch Description: Add upstream b44 to the compat-wireless tree (which includes the SSB bus driver)

Patch: http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-hardy-lbm.git;a=commit;h=f0a6bc770e8d58880294d6729892955658a430df

Test Case: see https://bugs.edge.launchpad.net/ubuntu/+source/linux/+bug/251538/comments/10

Tim Gardner (timg-tpi) wrote :
Changed in linux:
assignee: nobody → timg-tpi
importance: Undecided → High
milestone: none → ubuntu-8.04.2
status: New → Fix Committed
importance: Medium → High
milestone: none → ubuntu-8.04.2
status: Incomplete → Fix Committed
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Tim Gardner (timg-tpi) wrote :

Does not apply to Intrepid

Changed in linux-backports-modules-2.6.24:
status: Fix Committed → Invalid
Sandro Mani (sandromani) wrote :

The update fixed the problem on my system, thanks!

Steve Langasek (vorlon) wrote :

marking as verified; thanks for the feedback.

Martin Pitt (pitti) wrote :

linux-backports-modules-2.6.24 -21 copied to hardy-updates.

Changed in linux-backports-modules-2.6.24:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers