iwl3945 not functioning : microcode error

Bug #185470 reported by Jason Landry on 2008-01-23
138
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
High
linux (Ubuntu)
Medium
Unassigned
linux-backports-modules-2.6.24 (Ubuntu)
Medium
Unassigned

Bug Description

upgraded to Hardy, wifi stopped working with new iwl3945 was working fine in gutsy with ipw3945.

[ 74.877752] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 74.878127] ADDRCONF(NETDEV_UP): wlan0_rename: link is not ready
[ 75.021625] iwl3945: Microcode SW error detected. Restarting 0x82000008.
[ 75.021636] iwl3945: Error Reply type 0x00000005 cmd REPLY_SCAN_CMD (0x80) seq 0x4413 ser 0x0000004B
[ 76.030284] iwl3945: Can't stop Rx DMA.

Full dmesg output

description: updated
Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in linux which is the Launchpad package for the 2.6.24 kernel.

Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. There is a new version of the kernel available do you still have the issue with it? If so could you please add the output of 'lspci -vvnn' as an attachment to your bug report? Thanks in advance.

Changed in linux:
status: New → Incomplete

I went bact to 7.10 for the time being, I will upgrade again soon to test
this.

On Feb 5, 2008 4:18 PM, Brian Murray <email address hidden> wrote:

> Thank you for taking the time to report this bug and helping to make
> Ubuntu better. There is a new version of the kernel available do you
> still have the issue with it? If so could you please add the output of
> 'lspci -vvnn' as an attachment to your bug report? Thanks in advance.
>
> ** Changed in: linux (Ubuntu)
> Status: New => Incomplete
>
> --
> iwl3945 not functioning : microcode error
> https://bugs.launchpad.net/bugs/185470
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Brian Murray (brian-murray) wrote :

Just running a Hardy Heron Live CD would be sufficient to test this issue.

Jason Landry (jlandry) wrote :

Thanks I'll give that a try tommorrow.

On Feb 6, 2008 11:09 PM, Brian Murray <email address hidden> wrote:

> Just running a Hardy Heron Live CD would be sufficient to test this
> issue.
>
> --
> iwl3945 not functioning : microcode error
> https://bugs.launchpad.net/bugs/185470
> You received this bug notification because you are a direct subscriber
> of the bug.
>

I have the same problem too, I captured relevant information from dmesg (attached).

Notice that the Kill Switch is working though the LED is not blinking when I turn the wireless on.

Also, this is the output of:
islam@islam-laptop:~$ cat /proc/version
Linux version 2.6.24-8-generic (buildd@yellow) (gcc version 4.2.3 (Ubuntu 4.2.3-1ubuntu2)) #1 SMP Thu Feb 14 20:13:27 UTC 2008

My laptop is Acer Extensa 5620 with iwl3954. I am running Ubuntu Hardy Alpha 4 installed from the LiveCD

I forgot to add that the processor is 64-bit Intel Core 2 Duo and the I installed the amd64 version of Ubuntu

Another information:

Feb 20 22:40:27 islam-laptop kernel: [ 32.832883] iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, 1.2.0
Feb 20 22:40:27 islam-laptop kernel: [ 32.832888] iwl3945: Copyright(c) 2003-2007 Intel Corporation
Feb 20 22:40:27 islam-laptop kernel: [ 32.833556] iwl3945: Detected Intel PRO/Wireless 3945BG Network Connection
Feb 20 22:40:27 islam-laptop kernel: [ 33.972856] iwl3945: Tunable channels: 13 802.11bg, 0 802.11a channels

Also, from :islam@islam-laptop:~$ dpkg -S iwl3945
linux-ubuntu-modules-2.6.24-8-generic: /lib/modules/2.6.24-8-generic/ubuntu/wireless/iwlwifi/iwlwifi/compatible/iwl3945.ko

Thank you for your time

akhenaton (aky-home) wrote :

i can confirm this bug
i just upgraded from gutsy [7.10] to hardy alpha 5 and my intel 3945abg wireless card doesn't work anymore
my laptop is a toshiba satellite a100

(i only replaced mac address for the wired card)

akhenaton (aky-home) wrote :

sorry, can't edit the previous entry/post [to add the attachment]

Hello Akhenaton,

I can't see anything related to your iwl3945 module in the attached dmesg.txt. Are you sure that the iwl3945 module is loaded?

Try (as root):
# modprobe iwl3945
Then
# lsmod | grep iwl3945

akhenaton (aky-home) wrote :

hi, Islam Badrel-Dein

i did what you told me to, but to no avail
i'm sure my wireless lan card it's an intel 3945abg and it worked well in gutsy; now [with hardy alpha 5] i can't see the module for it - nor with lsmod/modprobe neither in restricted "hardware drivers" [and YES, the restricted drivers/multiverse is checked in my repo sources - as you can see: nvidia 3d binary driver is loaded!]
i attached the output for the "modprobe iwl3945", "lsmod | grep iwl3945" [which lists nothing as modprobe can't find the driver module named "iwl3945"] and "lsmod" [with all the loaded modules]

thanks

akhenaton (aky-home) wrote :

..and the lspci output

Hello Akhenaton,

On my machine:
islam@islam-laptop:~$ dpkg -S iwl3945
linux-ubuntu-modules-2.6.24-8-generic: /lib/modules/2.6.24-8-generic/ubuntu/wireless/iwlwifi/iwlwifi/compatible/iwl3945.ko

So, try to make sure that the package "linux-ubuntu-modules-2.6.24-8-generic" is properly installed and configured!

Please notify me as soon as your iwl3945 module loads correctly (lsmod)...

akhenaton (aky-home) wrote :

Hello Islam Badrel-Dein,

firstly i updated all with the last updates and then i followed your instructions [and 1) removed the old 2.6.22* kernel from previously installed stable gutsy - too pitty upgrade didn't handle to do this! -, 2) reinstalled/updated the linux-ubuntu-modules together with the updated version of kernel 2.6.24-10 - i should have thought of doing this but i haven't! -] and now all works as expected

thank you, man

It is STILL NOT FUNCTIONAL for me :( :(

Every time I try to configure the Wireless, I get:

[ 533.187480] iwl3945: Microcode SW error detected. Restarting 0x82000008.
[ 533.187497] iwl3945: Error Reply type 0x00000005 cmd REPLY_SCAN_CMD (0x80) seq 0x4435 ser 0x0000004B
[ 534.188007] iwl3945: Can't stop Rx DMA.

Am I the only one having this BUG ??? (O.o)

I can see it on other places as well. Just Google !

http://www.bughost.org/bugzilla/show_bug.cgi?id=1620
http://groups.google.com/group/fa.linux.kernel/msg/50151d3a045e5b87
http://lkml.org/lkml/2008/2/7/529

And also that's what I get with ping:
islam@islam-laptop:~$ ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
From 192.168.1.21 icmp_seq=1 Destination Host Unreachable
From 192.168.1.21 icmp_seq=3 Destination Host Unreachable
From 192.168.1.21 icmp_seq=4 Destination Host Unreachable
From 192.168.1.21 icmp_seq=5 Destination Host Unreachable
From 192.168.1.21 icmp_seq=7 Destination Host Unreachable
From 192.168.1.21 icmp_seq=8 Destination Host Unreachable
From 192.168.1.21 icmp_seq=9 Destination Host Unreachable
From 192.168.1.21 icmp_seq=12 Destination Host Unreachable
From 192.168.1.21 icmp_seq=13 Destination Host Unreachable

--- 192.168.1.1 ping statistics ---
14 packets transmitted, 0 received, +9 errors, 100% packet loss, time 13001ms
, pipe 3

ifconfig:
islam@islam-laptop:~$ ifconfig wlan0
wlan0 Link encap:Ethernet HWaddr 00:1b:77:f1:3b:8e
          inet addr:192.168.1.21 Bcast:192.168.1.255 Mask:255.255.255.0
          UP BROADCAST MULTICAST MTU:1500 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

and iwconfig:
islam@islam-laptop:~$ iwconfig wlan0
wlan0 IEEE 802.11g ESSID:"ihhs" Nickname:""
          Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
          Tx-Power=27 dBm
          Retry min limit:7 RTS thr:off Fragment thr=2346 B
          Power Management:off
          Link Quality:0 Signal level:0 Noise level:0
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0

akhenaton (aky-home) wrote :

hello Islam Badrel-Dein,

i was happy enough seeing the module problem solved to notice that wlan isn't quite working; i should have said "works as expected" only after at least one wireless succesfully established connection [i was using the wired connection and haven't switched to wireless immediately after module installation to test if it works]; well.. it doesn't work for me either

i switched back to stable [gutsy] after that [and some other breackages - bug reported on broked circular dependencies]

thanks again for your support

Hello Akhenaton,

I just need to confirm this bug. Would you please post the output of:

dmesg | grep iwl3945

after inserting the iwl3945 module? If you have the same MicroCode Error stuff.

You can use a LiveCD for that :)

Thanks much for your help!

techatdd (techatdd) wrote :

I am also affected by this bug. I just upgraded to Hardy Alpha 5 and have a i3945bg, unless lspci says 3945Abg.

dmesg gives me:

.
iwl3945: Tunable channels: 13 802.11bg, 0 802.11a channels
.
.
iwl3945: Microcode SW error detected. Restarting 9x82000008
iwl3945: Error Reply Type 0x00000005 cmd REPLY_SCAN_CMD (0x80) seq 0x4418 der 0x0000004B
iwl3945: Can't stop Rx DMA
.
.

Nm-applet do not find any wireless network and iwconfig says that eth1 (my wireless card in gutsy) have no wireless extension, instead of this i have a new if wlan0_renamewith the extension.

Nick Glynn (exosyst) wrote :

I am experiencing this error as well.

[12:38] nick@xerxes:~$ lsmod | grep iwl
iwl3945 89844 0
iwlwifi_mac80211 219108 1 iwl3945
cfg80211 15112 1 iwlwifi_mac80211

and from DMESG

[ 118.985613] wmaster0: Selected rate control algorithm 'iwl-3945-rs'
[ 119.189171] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 119.422660] iwl3945: Microcode SW error detected. Restarting 0x82000008.
[ 119.422676] iwl3945: Error Reply type 0x00000005 cmd REPLY_SCAN_CMD (0x80) seq 0x4418 ser 0x0000004B
[ 120.417651] iwl3945: Can't stop Rx DMA.

Any ideas on a fix?

Nick Glynn (exosyst) wrote :

Forgot to add, this is the latest hardy alpha release

Linux xerxes 2.6.24-12-generic #1 SMP Wed Mar 12 23:01:54 UTC 2008 i686 GNU/Linux

Changed in linux:
status: Unknown → In Progress
Brian Murray (brian-murray) wrote :

The upstream bug report mentions the following commits as possibly fixing this bug report:

commit 5c0eef960bdb87a53ba390aab7b069b2bc8d7f6d
tree 7c219792536fc1bfcbdf35ae2741a0621f3ccdea
parent 7878a5a4fcc5002e805c054730c4c5639c9d071d
author Mohamed Abbas Thu, 29 Nov 2007 11:10:14 +0800
committer David S. Miller Mon, 28 Jan 2008 15:05:36 -0800

    iwlwifi: fix ucode assertion for RX queue overrun

commit d68ab68066805fdfee1f5f29ec2ec0179fd92fe1
tree 6f457e23a5b44d759050e0039a68c9f8ce66ff18
parent c342a1b91f6ccd317c68defd3b4c7bb75397d967
author Mohamed Abbas Thu, 07 Feb 2008 13:16:33 -0800
committer John W. Linville Fri, 15 Feb 2008 13:44:18
-0500

    iwlwifi: earlier rx allocation

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: Incomplete → Triaged

I'm running wireless-compat from http://linuxwireless.org/en/users/Download , and it still craps out periodically. Presumably, being a daily snapshot, wireless-compat already includes these fixes.

Hello...

Hardy 8.04 Beta, new install on XPS m1210 laptop and wifi not working. I think this is weird because I actually get IP from my DLink wireless router (and good quality signal, I can see it in the wifi blue icon), but "ping 192.168.0.1" gives me *Destination Host Unreachable*.

Wired network in this box and wifi on another Dell laptop (Windows XP) are working without problems, so isn't a problem with DLink router. Before this install, Wifi on Windows XP and Gentoo was working.

Any ideas?

PD: Sorry about my english :s

Wireless (admin-istartup) wrote :

Hi
Im having very similar issues.
Thinkpad X60 Laptop with intel chipset, Intel Wireless 3945ABG card Not functioning.
Did a clean Installation of Hardy Beta release, Went through all the latest updates.
Getting the same read out of "Microcode SW error detected. Restarting 9x82000008" .
Im not near my laptop right now so i cannot post more logs and info. but i can say that the simptoms are:
1; Cannot scan for wireless networks around. typing "iwlist wlan0 scan" fails saysing it temporary unavailable.
2; Wifi LED light is not ON.

adc (a-dinc) wrote :

I'm facing the same problem with a samsung q45 and a intel iwl3945 wireless device.
when using iw-tools following error is printed to the syslog

iwl3945: Microcode SW error detected. Restarting 0x82000008.

shenshei (parmenion54) wrote :

I have the same problem with a samsung q45, and it's really disturbing.
On the gutsy the wireless works well with ipw3945 but now with iwl3945 it's bugged.

adc (a-dinc) wrote :

I'm happy to test any proposed fixes if needed.
There are many people having this error i spoke to in several channels.

Nick Glynn (exosyst) wrote :

Is there any news on if this was fixed upstream by the intel guys? It's just that by the gutsy beta all wireless/graphics glitches were fixed and this is still ongoing with the latest beta builds

adc (a-dinc) wrote :

i've testet kernel 2.6.25 kernel from git, but it produces the same error.

Yotam Benshalom (benshalom) wrote :

Same problem on LG-S1 laptop (core duo, 32-bit). wireless works well with gutsy kernel, broken with hardy's.

From my dmesg:

[ 58.341347] iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, 1.2.0
[ 58.341351] iwl3945: Copyright(c) 2003-2007 Intel Corporation
[ 58.341535] iwl3945: Detected Intel PRO/Wireless 3945BG Network Connection
[ 59.470957] iwl3945: Tunable channels: 13 802.11bg, 0 802.11a channels
[ 59.471321] wmaster0: Selected rate control algorithm 'iwl-3945-rs'
[ 77.007581] iwl3945: Microcode SW error detected. Restarting 0x82000008.
[ 77.007713] iwl3945: Error Reply type 0x00000005 cmd REPLY_SCAN_CMD (0x80) seq 0x4418 ser 0x0000004B
[ 78.001322] iwl3945: Can't stop Rx DMA.
[ 92.248829] ADDRCONF(NETDEV_UP): wlan0: link is not ready

Yotam Benshalom (benshalom) wrote :

A workaround is described in the forums: http://ubuntuforums.org/showthread.php?p=4612681#post4612681.
It is working for me.

Forceflow (baertman) wrote :

I updated from gutsy to hardy today, I've tried the following things:

- http://ubuntuforums.org/showthread.php?p=4612681#post4612681 (didn't work)
- booting to older kernel, and thus using ip(xxxx) module : works

So, the problem remains: I can see all Access Points in networkmanager, but connecting always fails.

Hi Everyone,

An updated version of the iwlwifi drivers (version 1.2.25) was recently added to the linux-backports-modules-2.6.24 package:

https://bugs.edge.launchpad.net/ubuntu/+bug/200950/comments/30 .

It would be good if you could retest once lbm with the update is published and available. Thanks.

Rami Al-Rfou' (rmyeid) wrote :

I confirm this Bug on ThinkPad R61 and these are the error messages :

Yotam Benshalom (benshalom) wrote :

This was fixed for me with latest kernel modules and network manager updates.

adc (a-dinc) wrote :

>This was fixed for me with latest kernel modules and network manager updates.

is this due to the workaround you are pointing to some comments above or is this because of new kernel modules? if the later one can you please tell us which packaged kernel version comes with the fix?

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: New → Triaged
38 comments hidden view all 118 comments
Aram Yegenian (aramyegenian) wrote :

Oops, my bad, the bug I mentioned is already being discussed here:
https://bugs.launchpad.net/ubuntu/+source/linux-ubuntu-modules-2.6.24/+bug/193970

Thanks.

Marco R (robado-m) wrote :

This bug seems to have been reported on the bugzilla mailing list of intellinuxwireless (http://www.intellinuxwireless.org/bugzilla/show_bug.cgi?id=1593). It seems no progress has been done on this bug since about two months. Maybe someone on the kernel team could work with the intellinuxwireless team to fix this bug as soon as possible. Also I suggest a change in the priority of the bug to critical since my wireless network doesn't work at all with a fresh intall of hardy.

Thanks

Sam Morris (yrro) wrote :
Nick Glynn (exosyst) wrote :

I needed my laptop for travel (and obviously wireless is a must!) so currently it's got Vista back on it but up until a week ago the wireless still didnt work under hardy so it's still not fixed. I agree that it is a critical bug as without wireless the mobility of laptops become pointless if you have to plug into a wall. Is there a bounty on this bug or anything I can chip in for?

Changed in linux:
status: Unknown → In Progress
Marco R (robado-m) wrote :

sorry my mistake I hadn't seen the remote bug watch section. Good work on that Sam.

I myself just tried creating the file /etc/modprobe.d/iwl3945 with the content mentioned above and it worked. As I understand it, it's only a temporary fix until bug is fixed at the root (am I right about that?). In any case since the fix works so can it be included in the default package even if it is temporary. It would at least keep people new to linux from switching back to windows (as what almost happened with my girlfriend since it is her laptop on with the wireless adapter doesn't work). I am sure it would be greatly appreciated by many people.

Thanks a lot for your great work.

  • unnamed Edit (2.0 KiB, text/html; charset=WINDOWS-1252)

In my case ASUS laptop, model PRO68, Ver A6JC with Intel 3945 ABG still not
work.
JP

On Fri, Jun 6, 2008 at 3:20 AM, marco R <email address hidden> wrote:

> sorry my mistake I hadn't seen the remote bug watch section. Good work
> on that Sam.
>
> I myself just tried creating the file /etc/modprobe.d/iwl3945 with the
> content mentioned above and it worked. As I understand it, it's only a
> temporary fix until bug is fixed at the root (am I right about that?).
> In any case since the fix works so can it be included in the default
> package even if it is temporary. It would at least keep people new to
> linux from switching back to windows (as what almost happened with my
> girlfriend since it is her laptop on with the wireless adapter doesn't
> work). I am sure it would be greatly appreciated by many people.
>
> Thanks a lot for your great work.
>
> --
> iwl3945 not functioning : microcode error
> https://bugs.launchpad.net/bugs/185470
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Jaime Pereira
http://uivemosjuntos.blogspot.com/
https://launchpad.net/~jaimepereira
OpenPGP keys: B4813835
---------------------------------------------------
Não mostre para os outros o endereço electrónico dos seus amigos.
Use "Cco" (ou "Bcc") – cópia oculta – ao enviar ou reenviar as suas
mensagens para vários destinatários.
Retire os endereços dos seus amigos no corpo da mensagem antes de
enviar/reenviar.
Dificulte a disseminação de Vírus, Spams e Banners.

Sten During (yappo) wrote :

LG TX Express Dual.
Intel 3945 ABG
Kubuntu 8.04

Backport modules installed in an attempt to fix this bug. Even
tried the /etc/modules stunt
At least the backport modules gave me my led-light back

The errors above.
As soon as I open up multiple connections (twelve tabs in my
Firefox on start) the connection shuts down as reported above.
This ONLY happens in WEP. Uncrypted connections are stable.

Led-light blacks, but restarting the wireless connection (right
click the network manager) usually gets me my connection
back for another five to ten minutes.

Installing updates with Adept-manager becomes a first class
nightmare, as multiple updates on average take me at least
half an hour due to repeated connection-losses.

I'm not insane enough to even contemplate torrents while
this bug lasts.

I have had not a whisper of a problem under 7.10 and iwp.
This is not a medium problem, this is the kind of problem
that makes laptop-owners change back to Windows from an
otherwise close to flawless Linux-installation. Thankfully it's
summer and I'm not dependent on the computer for work.
That WOULD force me to dig up my old XP-CDs.

Nightwing (jualin) wrote :

I think that the problem is now fixed on Hardy Heron. As suggested by hamster_billy in this thread <http://ubuntuforums.org/showpost.php?p=5300779&postcount=10> Installing the drivers from <http://wireless.kernel.org/en/users/Download> solves the problem. WEP and WPA Connection is possible after the installation of the drivers.

Alex Shtof (ist-alex) wrote :

It's not solved until it works with hardy-heron *without* installing any third-party software that doesn't come from Ubuntu. And it doesn't work on my laptop yet.

Jaime Pereira (jaimepereira) wrote :

What a shame!
About this problem: I'de install Fedora 9 and it works perfect!
jp

On Thu, Aug 14, 2008 at 6:19 PM, Alex Shtof <email address hidden> wrote:

> It's not solved until it works with hardy-heron *without* installing any
> third-party software that doesn't come from Ubuntu. And it doesn't work
> on my laptop yet.
>
> --
> iwl3945 not functioning : microcode error
> https://bugs.launchpad.net/bugs/185470
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Jaime Pereira
https://launchpad.net/~jaimepereira
OpenPGP keys: B4813835
---------------------------------------------------
Não mostre para os outros o endereço electrónico dos seus amigos.
Use "Cco" (ou "Bcc") – cópia oculta – ao enviar ou reenviar as suas
mensagens para vários destinatários.
Retire os endereços dos seus amigos no corpo da mensagem antes de
enviar/reenviar.
Dificulte a disseminação de Vírus, Spams e Banners.

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Antonio Pérez Pérez (aperez) wrote :

I've tried the Intrepid's 2.6.27 kernel on Hardy and it doesn't get the microcode error anymore.
BUT (yep, there's a but) now it fails to associate with my router.

So... a little bit closer but still not working :/

I'm attaching the dmesg output I've got trying the new kernel. Hope it helps.
If I can help trying other things or providing more info, let me know.

Cheers,
Antonio

PS: I'm using right now 2.6.22 with ipw3945 from Gutsy

I didn't get this bug with 2.6.24-19, but I _do_ get it with 2.6.27-1, using iwl3945 1.2.26 (the default version that comes with the 2.6.27 package, I guess).

Chunk of my syslog when I activate wireless:

Aug 29 14:32:47 dave-laptop NetworkManager: <info> (wlan0): device state change: 3 -> 2
Aug 29 14:32:47 dave-laptop NetworkManager: <info> (wlan0): deactivating device.
Aug 29 14:32:49 dave-laptop NetworkManager: <WARN> nm_device_wifi_set_enabled(): not in expected unavailable state!
Aug 29 14:32:49 dave-laptop NetworkManager: <info> (wlan0): bringing up device.
Aug 29 14:32:49 dave-laptop kernel: [ 3627.112400] iwl3945 0000:03:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
Aug 29 14:32:49 dave-laptop kernel: [ 3627.112775] firmware: requesting iwlwifi-3945-1.ucode
Aug 29 14:32:50 dave-laptop kernel: [ 3627.125018] iwl3945: iwlwifi-3945-1.ucode firmware file req failed: Reason -2
Aug 29 14:32:50 dave-laptop kernel: [ 3627.125018] iwl3945: Could not read microcode: -2
Aug 29 14:32:50 dave-laptop firmware_helper[10862]: main: error loading '/lib/firmware/iwlwifi-3945-1.ucode' for device '/class/firmware/0000:03:00.0' with driver 'iwl3945'
Aug 29 14:32:50 dave-laptop NetworkManager: <WARN> nm_device_hw_bring_up(): (wlan0): device not up after timeout!

Doh. Obviously, I need to install linux-restricted-modules for the 2.6.27 system.... I guess this happened automatically for the 2.6.24 kernels. Apologies for the irrelevant comment above.

Thanks for the updates so far. Jason, since you are the original bug reporter, would you be able to test and confirm if this is resolved or not. Alpha5 came out today so you should be able to test via a LiveCD.

Antonio, care to open a new bug report regarding the new issue you are seeing - https://bugs.launchpad.net/ubuntu/+source/linux/+filebug ? It's helpful to the kernel team if bug reports target one specific issue against a specific set of hardware. Thanks.

Jaime Pereira (jaimepereira) wrote :

I tried to run the Live CD of the Intrepid Alpha 5 but not succeeded.
He stops running, and anything happens.
Does anyone know if there is a bug on this?
Thanks

--
Jaime Pereira
https://launchpad.net/~jaimepereira
OpenPGP keys: B4813835
------------------------------------------------------------------------------------------------

On Sat, Sep 6, 2008 at 12:49 AM, Leann Ogasawara <email address hidden> wrote:

> Thanks for the updates so far. Jason, since you are the original bug
> reporter, would you be able to test and confirm if this is resolved or
> not. Alpha5 came out today so you should be able to test via a LiveCD.
>
> Antonio, care to open a new bug report regarding the new issue you are
> seeing - https://bugs.launchpad.net/ubuntu/+source/linux/+filebug ?
> It's helpful to the kernel team if bug reports target one specific issue
> against a specific set of hardware. Thanks.
>
> --
> iwl3945 not functioning : microcode error
> https://bugs.launchpad.net/bugs/185470
> You received this bug notification because you are a direct subscriber
> of the bug.
>

I just downloaded the Live CD of alpha 5 and tested it. At first, I got the same problem as Jaime Pereira - it wouldn't boot. But I rebooted and tried again, and this time I got the login window.

Network Manager came up with a long list of wireless networks, one of them being my own. I selected this one, put in the passphrase and connected! YES, it worked! For the first time, since installing Hardy, I am now able to connect to a wlan with my laptop :-)

Jaime Pereira (jaimepereira) wrote :

After having read the note from the Havard Bjastad I tested the Live CD on
my desktop and it runs well!
 I tested again in my laptop and now it runs smoothly too(?)
 I noticed that the wireless card works well now.
Thanks for helping
--
Jaime Pereira
https://launchpad.net/~jaimepereira
OpenPGP keys: B4813835
---------------------------------------------------

On Sun, Sep 7, 2008 at 9:16 PM, Havard Bjastad <email address hidden> wrote:

> I just downloaded the Live CD of alpha 5 and tested it. At first, I got
> the same problem as Jaime Pereira - it wouldn't boot. But I rebooted and
> tried again, and this time I got the login window.
>
> Network Manager came up with a long list of wireless networks, one of
> them being my own. I selected this one, put in the passphrase and
> connected! YES, it worked! For the first time, since installing Hardy, I
> am now able to connect to a wlan with my laptop :-)
>
> --
> iwl3945 not functioning : microcode error
> https://bugs.launchpad.net/bugs/185470
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Alex Shtof (ist-alex) wrote :

Will this driver be back-ported to Hardy any time soon?

RapteR (rapter) wrote :

HP Pavilion dv6236ea Ubuntu 8.10 alpha 6

dmesg in attach.

Chanchao (custom) wrote :

I have the same problem; Lenovo T61, one of the most popular laptops out there..

What's the best thing to do, go back to Gutsy or wait for this to be corrected in the next version?

Gergely Csépány (cheoppy) wrote :

Happened to me using 2.6.24-21.27 version of backported modules as well. But it occurs only randomly, eg. I can use my WPA2 wifi at home without problems, but it gets locked up easily when I use my university's open wifi. However my card seems to work fine without backported modules, so something is wrong with the backported modules package.

Changed in linux:
status: In Progress → Invalid
Changed in linux:
status: Invalid → Fix Released
Yann (lostec) wrote :

I juste got this error and understand why I randomly have wifi problems:
[ 1730.467073] iwl3945: Microcode SW error detected. Restarting 0x82000008.
[ 1732.454889] iwl3945: Can't stop Rx DMA.

On top of that, wlan interface does not restart until I do an ifdown/ifup sequence...

I use stock and up to date 2.6.24-21-generic

Also note there was a lot of netfilter traces of rejected packets when this occured... But when wlan is restarted, it can last all day long after that...

Note this pb is known and seems to be solved since several months:
http://www.intellinuxwireless.org/bugzilla/show_bug.cgi?id=1534

Regards

Yann (lostec) wrote :

This problem seems to be very old?!
http://kerneltrap.org/mailarchive/linux-kernel/2007/10/31/371297

Maybe some checks to be done with "rate scale algo" here?

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Yann (lostec) wrote :

Was working in 2.6.24-22/Hardy. Since update to 2.6.24-23, no connection anymore at boot until a "sudo /etc/init.d/networking restart"... and after that, connection is hasardous: can last 10mn or hours... Only booting back on -22 gives a reliable wifi, as well as booting on XP partition (=> not an hardware problem).

So I really don't understand why kernel team is kicking this bug out as problems are really phased with kernel updates! These wifi boards (intel, as 4965 seems as well concerned reading forums/newsgroups) are in a huge % of sold laptops... Maybe you have one somewhere to make tests before release :o))

Oleksiy Krivoshey (oleksiyk) wrote :

Ubuntu Intrepid 8.10
2.6.27-11-generic #1 SMP Thu Jan 29 19:24:39 UTC 2009 i686 GNU/Linux

Intel 3945 (iwl3956) just stopped working. I had no problems with this driver since I've installed Intrepid Alpha and today when I was working CPU loadsuddenly become very high, my internet connection was lost and I cannot make it to work since then.

No upgrades were running. No system programs were running. No configuration files changed. Nothing. It simply stopped working.

Here is what I get in the logs:

Feb 9 18:03:00 oleksiy-laptop kernel: [ 40.415759] iwl3945: Microcode SW error detected. Restarting 0x82000008.
Feb 9 18:03:00 oleksiy-laptop kernel: [ 40.415791] iwl3945: Error Reply type 0x00000005 cmd REPLY_RXON (0x10) seq 0x0402 ser 0x0000004B
Feb 9 18:03:00 oleksiy-laptop kernel: [ 40.415828] iwl3945: Error setting Tx power (-5).
Feb 9 18:03:00 oleksiy-laptop kernel: [ 40.912173] iwl3945: Error sending REPLY_TX_PWR_TABLE_CMD: time out after 500ms.
Feb 9 18:03:00 oleksiy-laptop kernel: [ 40.914749] Registered led device: iwl-phy0:radio
Feb 9 18:03:00 oleksiy-laptop kernel: [ 40.917862] Registered led device: iwl-phy0:assoc
Feb 9 18:03:00 oleksiy-laptop kernel: [ 40.918928] Registered led device: iwl-phy0:RX
Feb 9 18:03:00 oleksiy-laptop kernel: [ 40.919900] Registered led device: iwl-phy0:TX
Feb 9 18:03:01 oleksiy-laptop kernel: [ 40.925013] iwl3945: Can't stop Rx DMA.
Feb 9 18:03:02 oleksiy-laptop kernel: [ 42.270654] iwl3945: Microcode SW error detected. Restarting 0x82000008.
Feb 9 18:03:02 oleksiy-laptop kernel: [ 42.270679] iwl3945: Error Reply type 0x00000005 cmd REPLY_RXON (0x10) seq 0x0402 ser 0x0000004B
Feb 9 18:03:02 oleksiy-laptop kernel: [ 42.270701] iwl3945: Error setting Tx power (-5).
Feb 9 18:03:02 oleksiy-laptop kernel: [ 42.272864] Registered led device: iwl-phy0:radio
Feb 9 18:03:02 oleksiy-laptop kernel: [ 42.272922] Registered led device: iwl-phy0:assoc
Feb 9 18:03:02 oleksiy-laptop kernel: [ 42.272963] Registered led device: iwl-phy0:RX
Feb 9 18:03:02 oleksiy-laptop kernel: [ 42.273020] Registered led device: iwl-phy0:TX
Feb 9 18:03:02 oleksiy-laptop kernel: [ 42.277009] iwl3945: Can't stop Rx DMA.
Feb 9 18:03:02 oleksiy-laptop kernel: [ 43.376563] iwl3945: request scan called when driver not ready.
Feb 9 18:03:02 oleksiy-laptop kernel: [ 43.381228] wlan0: failed to restore operational channel after scan
Feb 9 18:03:03 oleksiy-laptop kernel: [ 43.880108] iwl3945: Error sending REPLY_TX_PWR_TABLE_CMD: time out after 500ms.
Feb 9 18:03:04 oleksiy-laptop kernel: [ 43.885062] iwl3945: Microcode SW error detected. Restarting 0x82000008.

Oleksiy Krivoshey (oleksiyk) wrote :

Moreover, 15 minutes later the same happened to my friend running on Ubuntu 8.04 2.6.24-22. Intel 3945 just stopped working with the same errors in the syslog as I've posted above.

As well as my setup - he had no problems with iwl3945 wifi for months. No upgrades, nothing. It just stopped working.

Changed in linux:
status: Fix Released → In Progress
Oleksiy Krivoshey (oleksiyk) wrote :

Following on my 2 previous posts: both network cards are working again now (from morning). Again nothing changed/installed. I guess the reason was in presence of some "unsupported" wirelless network nearby and some scanning bug in drivers. I've reported this issue here: http://www.intellinuxwireless.org/bugzilla/show_bug.cgi?id=1650 but infortunately can't test latest patch as they suggest cause it's working again...

Changed in linux:
status: In Progress → Fix Released
Oleksiy Krivoshey (oleksiyk) wrote :

Ubuntu 9.04 Beta:

2.6.28-11-generic #41-Ubuntu SMP Wed Apr 8 04:38:53 UTC 2009 i686 GNU/Linux

Exactly the same error:

Apr 10 13:42:29 oleksiy-laptop kernel: [ 5891.062103] iwl3945: Microcode SW error detected. Restarting 0x82000008.
Apr 10 13:42:29 oleksiy-laptop kernel: [ 5891.062134] iwl3945: Error Reply type 0x00000005 cmd REPLY_RATE_SCALE (0x47) seq 0x0405 ser 0x0000004B
Apr 10 13:42:29 oleksiy-laptop kernel: [ 5891.062180] iwl3945: Error setting HW rate table: FFFFFFFB
Apr 10 13:42:29 oleksiy-laptop kernel: [ 5891.560191] iwl3945: Error sending REPLY_TX_PWR_TABLE_CMD: time out after 500ms.

Changed in linux:
status: Fix Released → Confirmed
Mike Basinger (mike.basinger) wrote :

Seeing this also in Jaunty RC. It maybe causing my WPA Enterprise connection to drop.

dbasinge@mikebuntu:~$ dmesg | grep iwl3945
[ 9.538034] iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, 1.2.26ks
[ 9.538037] iwl3945: Copyright(c) 2003-2008 Intel Corporation
[ 9.538140] iwl3945 0000:0c:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[ 9.538154] iwl3945 0000:0c:00.0: setting latency timer to 64
[ 9.538238] iwl3945: Detected Intel Wireless WiFi Link 3945ABG
[ 9.538979] iwl3945 0000:0c:00.0: irq 2297 for MSI/MSI-X
[ 9.595952] iwl3945: Tunable channels: 11 802.11bg, 13 802.11a channels
[ 24.809948] iwl3945 0000:0c:00.0: firmware: requesting iwlwifi-3945-1.ucode
[ 2184.587041] iwl3945: Microcode SW error detected. Restarting 0x82000008.
[ 2184.587067] iwl3945: Error Reply type 0x00000005 cmd REPLY_TX (0x1C) seq 0x0046 ser 0x0000004B
[ 2184.589657] iwl3945: Can't stop Rx DMA.

Changed in linux:
status: Confirmed → In Progress
pablomme (pablomme) wrote :

I had never had this problem, but I recently bought a new wireless router which offers different security settings, and bumped into the "Microcode SW error" problem -- this consists in a lost connection after a few minutes (if that) of activity, which can be regained by simply asking for a reconnection in nm-applet.

In the router, if I set (according to Belkin):

 Security: WPA/WPA2-Personal(PSK)
 Authentication: WPA2-PSK
 Encryption: AES

I get the problem, whereas if I switch to:

 Security: WPA/WPA2-Personal(PSK)
 Authentication: WPA-PSK + WPA2-PSK
 Encryption: TKIP + AES

where the third option is forced by the second, the connection works fine. Hopefully this is useful info...

AceLan Kao (acelankao) wrote :

Mike, does the problem still exist in the Jaunty release?
And have you try the workaround provided by Pablomme and does it do any help?

Erdal Ronahi (erdalronahi) wrote :

I got this error on Jaunty with kernel 2.6.28-13-generic. The computer had worked flawlessly with everything from gutsy through Jaunty before.

Not all of a sudden it does not find any wireless network.

dmesg messages are:
[ 31.759063] iwl3945 0000:02:00.0: firmware: requesting iwlwifi-3945-1.ucode
[ 31.813429] iwl3945: iwlwifi-3945-1.ucode firmware file req failed: Reason -2
[ 31.813434] iwl3945: Could not read microcode: -2
[ 31.814806] iwl3945 0000:02:00.0: firmware: requesting iwlwifi-3945-1.ucode
[ 31.818154] iwl3945: iwlwifi-3945-1.ucode firmware file req failed: Reason -2
[ 31.818159] iwl3945: Could not read microcode: -2

Also reported this to the upstream bugzilla.

Changed in linux:
status: In Progress → Fix Released
AceLan Kao (acelankao) wrote :

I'm going to close this issue as the upstream claim that the bug had been fixed.
Erdal, you have another issue not the same with this one, please open a new report if you would like to discuss more.

Changed in linux (Ubuntu):
status: Triaged → Fix Released
bananenkasper (bananenkasper) wrote :

This bug affects me on Jaunty Kernel 2.28.17.

iwl3945 0000:03:00.0: Microcode SW error detected. Restarting 0x82000008.
kernel: [ 3823.004176] iwl3945 0000:03:00.0: Error Reply type 0x00000005 cmd REPLY_TX (0x1C) seq 0x02D9 ser 0x004E0000

It occurs randomly and depends on the access point.

Trevor Robinson (eztenia) wrote :

Karmic kernel 2.6.31-17-generic has this problem too.

iwl3945 0000:02:00.0: Microcode SW error detected. Restarting 0x82000008.
iwl3945 0000:02:00.0: Error Reply type 0x00000000 cmd REPLY_TX (0x1C) seq 0x0000 ser 0x00000000

The attached file is some other stuff that came up at about the same time.

Juanma (jm-mico) wrote :
Download full text (4.8 KiB)

Hello community,

Sorry to say, but I am having this bug in Ubuntu Lucid. The Microcode error appears after heavy load.

Similar, if not the same bug, has been reported also: http://bugzilla.intellinuxwireless.org/show_bug.cgi?id=1593 and at the end there is still a user with Ubuntu 9.10 RC having this issue.

Happens with kernel 2.6.32-19-generic-pae but also with 2.6.32-21-generic-pae-phc (low voltage tunning).

Mostly happens after heavy net loads (download a 150Mb file from another computer in the local network), after several seconds, sometimes it works sometimes hangs (too often).

I have tried to load the module with the debug parameter, as described in http://bugzilla.intellinuxwireless.org/show_bug.cgi?id=1593, which is: "modprobe iwl3945 debug=0x43fff " but got the error:
[ 1019.362270] iwl3945: Unknown parameter `debug'

So, here is my dmesg | grep iwl3945:

"[ 29.336229] iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, 1.2.26ks
[ 29.336232] iwl3945: Copyright(c) 2003-2009 Intel Corporation
[ 29.337551] iwl3945 0000:0c:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[ 29.337566] iwl3945 0000:0c:00.0: setting latency timer to 64
[ 29.453187] iwl3945 0000:0c:00.0: Tunable channels: 13 802.11bg, 23 802.11a channels
[ 29.453191] iwl3945 0000:0c:00.0: Detected Intel Wireless WiFi Link 3945ABG
[ 29.453424] iwl3945 0000:0c:00.0: irq 28 for MSI/MSI-X
[ 29.873686] iwl3945 0000:0c:00.0: firmware: requesting iwlwifi-3945-2.ucode
[ 29.896601] iwl3945 0000:0c:00.0: loaded firmware version 15.32.2.9
[ 202.230482] iwl3945 0000:0c:00.0: PCI INT A disabled
[ 211.879127] iwl3945: Unknown parameter `debug'
[ 259.926254] iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, 1.2.26ks
[ 259.926258] iwl3945: Copyright(c) 2003-2009 Intel Corporation
[ 259.926361] iwl3945 0000:0c:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[ 259.926383] iwl3945 0000:0c:00.0: setting latency timer to 64
[ 259.983051] iwl3945 0000:0c:00.0: Tunable channels: 13 802.11bg, 23 802.11a channels
[ 259.983055] iwl3945 0000:0c:00.0: Detected Intel Wireless WiFi Link 3945ABG
[ 259.983208] iwl3945 0000:0c:00.0: irq 28 for MSI/MSI-X
[ 259.998847] iwl3945 0000:0c:00.0: firmware: requesting iwlwifi-3945-2.ucode
[ 260.017170] iwl3945 0000:0c:00.0: loaded firmware version 15.32.2.9
[ 999.566361] iwl3945 0000:0c:00.0: PCI INT A disabled
[ 1019.362270] iwl3945: Unknown parameter `debug'
[ 1197.464932] iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, 1.2.26ks
[ 1197.464937] iwl3945: Copyright(c) 2003-2009 Intel Corporation
[ 1197.465036] iwl3945 0000:0c:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[ 1197.465057] iwl3945 0000:0c:00.0: setting latency timer to 64
[ 1197.522048] iwl3945 0000:0c:00.0: Tunable channels: 13 802.11bg, 23 802.11a channels
[ 1197.522053] iwl3945 0000:0c:00.0: Detected Intel Wireless WiFi Link 3945ABG
[ 1197.522204] iwl3945 0000:0c:00.0: irq 28 for MSI/MSI-X
[ 1197.538119] iwl3945 0000:0c:00.0: firmware: requesting iwlwifi-3945-2.ucode
[ 1197.541683] iwl3945 0000:0c:00.0: loaded firmware version 15.32.2.9
[ 1408.575504] iwl3945 0000:0c:00.0: Mic...

Read more...

Juanma (jm-mico) wrote :

Hello,

As "AceLan Kao wrote on 2009-07-27: "

I am opening a new bug report :
https://bugs.launchpad.net/ubuntu/+bug/577189

Changed in linux:
importance: Unknown → High

Is this fixed now in Ubuntu 10.04 / 12.04 ?

Changed in linux-backports-modules-2.6.24 (Ubuntu):
status: Triaged → Incomplete
Changed in linux-backports-modules-2.6.24 (Ubuntu):
status: Incomplete → Invalid
Displaying first 40 and last 40 comments. View all 118 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.