[xps1330] microphone built-in doesn't work

Bug #147682 reported by LEVIS Cyril on 2007-10-01
44
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-backports-modules-2.6.22 (Ubuntu)
Medium
Ben Collins

Bug Description

How to get working the built in mic on the xps 1330 please?

Could you update alsa ?

Tim Gardner (timg-tpi) wrote :

If you want a temporary workaround, then run this command:

sudo echo "options snd-hda-intel model=5stack" >> /etc/modprobe.d/alsa-base

Make sure your speakers and microphone are not muted. I think the best mixer for that is gnome-alsamixer.

I am implementing a fix in Gutsy l-u-m that detects this particular codec and initializes it correctly.

Tim Gardner (timg-tpi) wrote :

Gutsy lum commit d3faeaae0bedf8e643b9e20b0e893c169a387a22

Changed in linux-ubuntu-modules-2.6.22:
assignee: nobody → timg-tpi
importance: Undecided → Medium
status: New → Fix Committed
Nicola Gallo (nicola-ga) wrote :

i attached at the end of the file /etc/modprobe.d/alsa-base
options snd-hda-intel model=5stack
but the built-in mic does not work anyway. even after checking many times alsamixer settings. Only the plugged one works.

Tim Gardner (timg-tpi) wrote :

I guess my earlier comment was misleading. Setting model=5stack only enables the external microphone. I don't have the right pinout to get the internal microphone working.

Need to figure out how to fix internal microphone.

Changed in dell:
importance: Undecided → Medium
status: New → In Progress
LEVIS Cyril (atlas95) wrote :

The same, i have the external mic working but not internant with 5stack

Kyle McMartin (kyle) wrote :

linux-ubuntu-modules-2.6.22 (2.6.22-13.33) gutsy; urgency=low

  [Ben Collins]

  * ubuntu/d-i: Add atl2 module to udeb
    - LP: #148532

  [Matthew Garrett]

  * Work around uvc suspend issues
    - LP: #147757
  * Force-enable speakers on recent Thinkpads
    - LP: #140609

  [Tim Gardner]

  * Added et131x Gigabit ethernet driver support.
    - LP: #102291
  * AppArmor patch for disconnected path reporting
  * prism javelin/xbow works out-of-box, but the module is not loaded by
    default
    - LP: #133823
  * System freeze when bringing up rt2500pci interface
    - LP: #129183
  * [xps1330] microphone built-in doesn't work
    - LP: #147682
  * FUJITSU SIEMENS XTB70 snd-hda-intel fix
    - LP: #147827
  * Add ivtv-fb and saa717x support
    - LP: #147886

 -- Kyle McMartin <email address hidden> Thu, 04 Oct 2007 16:09:03 +0000

Changed in linux-ubuntu-modules-2.6.22:
status: Fix Committed → Fix Released
LEVIS Cyril (atlas95) wrote :

Yeah!
This will be fixed so... I hope

Tim Gardner (timg-tpi) on 2007-10-05
Changed in linux-ubuntu-modules-2.6.22:
assignee: timg-tpi → nobody
Ben Collins (ben-collins) wrote :

Confirmed that this is not actually working, even with linux-backports-modules-2.6.22

Went through some debug items with #alsa, and came up with nothing. Looks like we may have to depend on the hardware vendor for some help here.

Changed in linux-ubuntu-modules-2.6.22:
assignee: nobody → ben-collins
status: Fix Released → In Progress
LEVIS Cyril (atlas95) wrote :

How can I help you?

Jesper de Jong (jespdj) wrote :

I have a Dell XPS M1330 too and I am also affected by this bug.

Is there anything I can do to help you solve this?
If so, please let me know: <email address hidden>

Tim Gardner (timg-tpi) wrote :

wget http://people.ubuntu.com/~rtg/linux-backports-modules-2.6.22-14-generic_2.6.22-14.11UNRELEASED_i386.deb
sudo dpkg -i linux-backports-modules-2.6.22-14-generic_2.6.22-14.11UNRELEASED_i386.deb
sudo reboot

LEVIS Cyril (atlas95) wrote :

Hmm, now I have 3 Input source, howto get it working? I must set the 3 source to "Front Mic" or 'Mic"?Or other...
Thanks yet

Nizar Kerkeni (nizarus) wrote :

I have a dell dimension e521 and I can't use the microphone in gutsy amd64 !

Antoine Büsch (antoine-busch) wrote :

Tim: I just tried the unrealeased linux-backport package you posted, it works well for me. It made "Digital Input Source" appear in gnome-volume-manager->Preferences. Then on the Options tab I could select "Digital Mic 1" for the "Digital Input Source" list. Thanks!

LEVIS Cyril (atlas95) wrote :

yes !
 the same today, i havn't find time yet for post it, this is working for too, thank you very, but i think a little clean is necessary? I have a lot of option and i don't know if they are all usefull.
;)

Christophe Dumez (hydr0g3n) wrote :

I have a Dell XPS M1330. I noticed that my internal microphone was not working after Gutsy install. I found this bug report and I installed linux-backports-modules-2.6.22-14-generic_2.6.22-14.11UNRELEASED_i386.deb but I don't get a Microphone entry in Volume Manager.

Before the new Package I had only "General Volume", Now I have "General Volume" and "PCM".

Also, the sound volume is very low when using internal speakers, even with volume at max.

Jesper de Jong (jespdj) wrote :

Thank you for the fix Tim, it works!

Christophe: Try the following. Open the GNOME volume manager by double-clicking on the volume icon in the top left of the screen. Then select Edit / Preferences and enable the following additional tracks: Front, Digital Input Source. Click Close.

Now you will have "Front" in the Playback tab. Set it a little higher and the sound from the internal speakers will get louder.

On the Options tab, select "Digital Mic 1" for the option "Digital Input Source".

On the Recording tab, you will have a slider named "Digital". Turn it up and click on the microphone icon on the bottom if it has a red cross on it to enable the microphone.

Try recording and playing back some sound, with for example the Sound Recorder (Applications / Sound & Video / Sound Recorder).

Nick Andrik (andrikos) wrote :

Sorry if I am off-topic but I have a Dell Latitude D630.
If I put model=5stack I can have the mic working, but I have the problem that the volume of the central channel starts rising automatically.
If I put model=dell-m42 like proposed in other threads I don't have the volume problem, but the mic is hardly heard.
Any ideas about the correct model for my laptop?
Thanks a lot

Christophe Dumez (hydr0g3n) wrote :

Thanks JesperDJ. It does work here too now.

Christophe Dumez (hydr0g3n) wrote :

However, internal mic volume is too low, and internel speakers volume is too low too. Even with mic volume at max, this is very difficult to hear. Concerning internal speakers, my volume is set pretty high too (and front is at max).

Christophe Dumez (hydr0g3n) wrote :

I think this appeared after I used the linux-backports-modules-2.6.22-14-generic_2.6.22-14.11UNRELEASED_i386.deb package:

When playing music (with rythmbox), the sound gets louder and louder with time (until it reaches max, pretty fast). However, if I look gnome sound control tool, the volume does not change (stays at ~50%). Is anyone experiencing the same problem?

Christophe Dumez (hydr0g3n) wrote :

I confirm that the increasing sound volume problem is due to linux-backports-modules-2.6.22-14-generic_2.6.22-14.11UNRELEASED_i386.deb. I replaced it by linux-backports-modules-2.6.22-14-generic (v 2.6.22-14.10) and now my sound volume is stable.

Nick Andrik (andrikos) wrote :

Christophe which computer model and which model=XXX in your /etc/modprobe.d/alsa-base do you have?
You are using linux-backports-modules-2.6.22-14-generic (v 2.6.22-14.10), right?
Thanks in advance

Christophe Dumez (hydr0g3n) wrote :

I have an XPS M1330, the increasing volume problem happens with linux-backports-modules-2.6.22-14-generic_2.6.22-14.11UNRELEASED only. I now downgraded to v 2.6.22-14.10 and the volume is stable again. I can reinstall the UNRELEASED one if you need more info (temporarily because it is unusable).

chris@chris-laptop:~$ cat /etc/modprobe.d/alsa-base
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe --quiet snd-ioctl32 ; : ; }
install snd-pcm /sbin/modprobe --ignore-install snd-pcm && { /sbin/modprobe --quiet snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer && { /sbin/modprobe --quiet snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq && { /sbin/modprobe --quiet snd-seq-midi ; /sbin/modprobe --quiet snd-seq-oss ; : ; }
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi && { /sbin/modprobe --quiet snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe -Qb saa7134-alsa ; : ; }

# Load snd-seq for devices that don't have hardware midi;
# Ubuntu #26283, #43682, #56005; works around Ubuntu #34831 for
# non-Creative Labs PCI hardware
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe -Qb snd-seq ; }
# Prevent abnormal drivers from grabbing index 0
options snd-bt87x index=-2
options cx88-alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-usx2y index=-2
options snd-usb-caiaq index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388

Albert (albert-mahonis) wrote :

Hi people, I managed to get the mic working on my XPS M1330, but with this update, the master volume is no more controlled by the special keys over the keyboard (the ones with de led blue lights). Do you know how to restore the control?

Nick Andrik (andrikos) wrote :

@ Christophe
Thanks but it seems that in my Latitude D630 things are a bit different. I should find a more appropriate bug in launchpad to ask there

@Albert
System -> Preferences -> Sound
The last sub-window has a list of the channels controlled by buttons. Select the one(s) you want.

Albert (albert-mahonis) wrote :

Thanks a lot I didn't noticed it had to be selected somehow.

Mark Taylor (markt-cck) wrote :

Hi all. I'm running the amd64 version of Gutsy and when I try and install the package I get an error "package architecture (i386) does not match system (amd64)". I couldn't see an amd64 version to download, or maybe I'm misinterpreting the versioning. Is it safe to do a --force-architecture install or is that bad?

Nizar Kerkeni (nizarus) wrote :

Mark I think that forcing this kernel version it's a bad idea !!

Mark Taylor (markt-cck) wrote :

Hi Nizar, thanks for your advice. I'll wait for an official release.

linux-backports-modules-2.6.22-14.11 in gutsy-proposed repo has fix.

Changed in dell:
status: In Progress → Fix Committed
ninocass (ninocass) wrote :

Hi all, firstly thanks for the fix but i have a small problem.

I can only hear any music/sounds from my speakers when the volume sliver is moved above the 50% mark.

any ideas for a fix would be greatly appreciated.

Please tell me if I'm in the wrong place. I have a Dell Inspiron 8120 and I recently loaded Gutsy. I installed Skype and intended to use the mic plug with my corded headset, but it doesn't work. I've searched everywhere and tried many lines of code to no avail. Can I get my mic plug to work on this machine with Ubuntu??

Thanks,
miershpedankl

Nick Andrik (andrikos) wrote :

I have a Latitude D630 so I don't know if it applies to you.
What I did is to use the
options snd-hda-intel model=5stack
line in the /etc/modprobe.d/alsa-base file.

I still have the problem of the volume going automatically up but my microphone is functioning ok.
I still did not manage to make my soundcard fully functional without bugs.
If there is anyone having managed it I would really appreciate it to learn how :)

Benson Margulies (bimargulies) wrote :

After installing the backport, I still don't get the 'digital input source' option in alsamixer or anywhere else.

However, I had previously followed the instructions in https://wiki.ubuntu.com/Gutsy_Intel_HD_Audio_Controller under 'method A'.

At this instant, the alsa-base file in modprobe.d says 'snd-hda-intel model=3stack'.

I have an XPS m1330. I would be most grateful for any advice about sorting out all these conflicting instructions.

Jake B (jbrownson) wrote :

I have a Dell M1530 and am having the same problem. If I apply the deb in this post I don't see any options in the Digital Input Source on the options tab.

Should I open a new bug for this?

Jake,

Try the following Dell-custom l-b-m:

http://linux.dell.com/files/ubuntu/linux-backports-modules-2.6.22-14-generic_2.6.22-14.50_i386.deb

Works on M1330, should work on M1530 as well.

PJSingh5000 (pjsingh5000) wrote :

Experiencing same problem with Kubuntu Gusty on AOpen MP965, Intel x64 platform. Unable to record audio from the mic. (Ubuntu hardware database entry : 1066f073a4b1c56bc959c0edafbda24f). Is the above backport solution available for x64 architecture?

Jose,

Installed the l-u-b from linux.dell.com on M1530 running Gutsy, rebooted, and still no microphone. Neither Skype nor Ekiga work.

It did fix some of the user interface problems though and now I can at least control volume. Before this, it was either off or 100%.

Kenneth,

The custom l-b-m v50 was not tested or qualified on the XPS 1530, and even though I suspect the 1530 is highly leveraged off the XPS 1330 (where it was tested and it does work), it's very possible this fix may not work on the 1530.

Make sure all your alsamixer settings are unmuted and raise their volume level. Also make sure the Digital Input Source is set to Digital. Test with the Sound Recorder tool in Applications -> Sound & Video.

Glad to know that volume is now working correctly, didn't know that was an issue on the 1530. Like I said, we have not tested Ubuntu on the XPS 1530.

If you're still having problems, then please open a separate bug.

Jose,

Thanks for all the hard work you guys are doing. Let me know if I can help on the M1530.

I'm going to put in a separate bug for the XPS 1530 microphone issue.

Works on latest Hardy release with linux-image-generic-2.6.24-7-generic and linux-ubuntu-modules-2.6.24-7.12

Changed in dell:
status: Fix Committed → Fix Released
Mikael B (mikaelbje) wrote :

I have an XPS M1530 running on amd64 and have the same problem as others have reported. Is there an amd64 linux-backports-modules?

Mikael B,

You can 'apt-get install linux-backports-modules' and it'll pick up the amd64 version if your kernel is amd64.

IOW, it does the 'right thing'. I would probably do a reboot afterwards, just to be sure, but its not required.

At this point, the 1530 microphone still does not work with the linux-backports-modules. There's another bug report against the 1530 and backports, but its status is still undecided (and the title still says m1330, no one with authority has fixed that yet!). I installed the backports modules so it would show up in updates as soon as its released.

...Ken

Mikael B (mikaelbje) wrote :

Kenneth,

I installed linux-backports-modules and rebooted. The sound volume was now at 100% and I was unable to decrease it nor change sound device from Preferences->Sound or the Sound Volume applet. I was however able to decrease it to 97% through the volume keys on the PC. Sound recorder would not open and complained something along these lines: "The sound recording settings are not correct. Please correct these in Multimedia and retry"

I removed linux-backports-modules and I'm now back to my old volume settings as well as being able to change the volume. The mic is of course still not working.

Should I try enabling gutsy-proposed and try with the packages in that repo? Is there any chance it will help?

Mikael B (mikaelbje) wrote :

Also please link to the other topic so I can subscribe to it. Thanks.

Mikael,

Here's the link - subject says 1330, but content is 1530

https://bugs.launchpad.net/ubuntu/+source/linux-backports-modules-2.6.22/+bug/186805

I have never tried the gutsy-proposed, but I'm going to give it a try. Back in a bit.

Andreas Peer (andipeer) wrote :

Hi,
I was wondering whether or not there exists a solution that works also on AMD64? This question was already asked several times, but I couldn't find a satisfiable answer...

jorges (jorgesmbox-ml) wrote :

Hi,
My question is the following: Where can I find the source code diff related to this bug? I run gentoo and I have this problem, and I would like know what changes need to be done in order to get the internal mic working. Thanks in advance.

jorges

Bernhard Bock (bernhard-bock) wrote :

As a sidenote:

If you added "option snd-hda-intel model=3stack" to /etc/modprobe.d/alsa-base in Gutsy (as proposed in some places and working for me) and do an upgrade to Hardy, you have to remove that option again to make the mic work with Hardy!

asdir (dirkroettgers) wrote :

Just so anyone notices: This bug seems to be prevalent in Hardy. I just had to use the fix described in the first post on a Dell XPS m1330.

beefcurry (jonzwong) wrote :

its not just internal, my external doesn't work either even with the 5-stack fix shown above, it used to work in Gutsy but when I did a fresh install of Hardy nothing works.

Mario Limonciello (superm1) wrote :
Changed in linux-backports-modules-2.6.22:
status: In Progress → Won't Fix
Javier Jardón (jjardon) wrote :

I confirm this bug in Ubuntu Hardy 8.04.1

The microphone works out-of-the-box but you have to configure it, however:

1. Double-click the volume control icon in the top right of the screen.
2. Select Edit / Preferences.
3. Add "Digital" and "Digital Input Source" to the list of visible tracks.
4. On the Options tab, select "Digital Mic 1" for "Digital Input Source".
5. On the Recording tab, set the volume for the microphone.

TKFRC (tkfrc) wrote :

I had the same problem on my Ubuntu XPS 1330

To get around it I opened up the sound preferences. In sound preferences I opened edit->preferences from the menu bar and turned all checks on. Then I turned everything way up. A few of the sources were initially muted. "Digital Input Source" in the Options menu chooses between the two mics. I'm getting feedback from the built-in mic but I'm sure the volume settings just need tweaking (something I'm not particularly interested in right now)

TF

Adnan (adnan-zein) wrote :

What about this bug in ubuntu 8.10? on my M1330 neither internal or external microphones are working! I'm unable to voice chat!

Javier Jardón (jjardon) wrote :

Hello Adnan,

> What about this bug in ubuntu 8.10? on my M1330 neither internal or external microphones are working! I'm unable to voice chat!

Maybe you have the bug #275998 instead this

Adnan (adnan-zein) wrote :

Hello Javier,
I think the bug you pointed isn't the one. I've seen some people talk about a bug that corresponds to mine, but no dedicated bug thread.
In the Volume Control applet, with the Device set to HDA Intel (Alsa mixer), the Recording tab shows all controls (Capture, Digital, Mux) with the audio recording toggled OFF (small red cross on the mic. icon under each vertical slider). Even after toggling the icon, it goes back to toggled off the next time the volume control is opened.
I'm new to launchpad actually, what should I do then?

Canx (canchete) wrote :

I also have the same bug than Adnan on a Dell Studio 1537 (Ubuntu 8.10 64bits, with proposed packages). Also a newbie :)

Changed in somerville:
importance: Undecided → Medium
status: New → Fix Released
no longer affects: dell
Timothy R. Chavez (timrchavez) wrote :

The bug task for the somerville project has been removed by an automated script. This bug has been cloned on that project and is available here: https://bugs.launchpad.net/bugs/1306071

no longer affects: somerville
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers