Ubuntu

Dell Inspiron 1520 no audio

Reported by Tim Gardner on 2007-09-07
30
Affects Status Importance Assigned to Milestone
alsa-driver (Mandriva)
New
Undecided
Unassigned
linux-backports-modules-2.6.22 (Ubuntu)
Medium
Unassigned

Bug Description

There does not appear to be an upstream fix yet, Sigmatel PCI ID 1028:01f1.

Tim Gardner (timg-tpi) on 2007-09-07
Changed in linux-ubuntu-modules-2.6.22:
assignee: nobody → timg-tpi
importance: Undecided → Medium
status: New → Confirmed
Tim Gardner (timg-tpi) wrote :

ALSA 1.0.15rc2 works, but I've not been able to backport the tweaks to Gutsy l-u-m.

Changed in linux-ubuntu-modules-2.6.22:
status: Confirmed → In Progress

Good news still. You think it's doable for Getsy beta or final?

Changed in dell:
importance: Undecided → Medium
status: New → In Progress
SKiAt (skiat) wrote :

in Mandriva I resolved with the cooming soon Mandriva 2008 & kernel 2.6.22

Olivier Guéry (nemolivier) wrote :

On my Inspiron 1520, no audio too (no card found) but it’s not a sigmatel, but an intel one :

00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)

I can’t push the volume like in this bug : https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.22/+bug/130559 … there’s no card found.

Compiling the alsa drivers like in the post #305 in this thread : http://ubuntuforums.org/showthread.php?p=3412671#post3412671 give me sound. But with the headphone bug.

Tel me if you need more informations.

Tim Gardner (timg-tpi) wrote :

Try this:

sudo echo "options snd-hda-intel model=3stack" >> /etc/modprobe.d/alsa-base

However, if you've polluted your kernel by installing ALSA 1.0.15rc2, it will likely not make a difference.

Pitabred (ubuntu-pitabred) wrote :

I've got an Intel sound card in my 1520 here, and I've tried both the "3stack" and "dell-laptop" options for the snd-hda-intel module. Nothing working yet. I've got a bog-standard Kubuntu Gutsy install, latest updates as of this posting. I can get any system logs, etc. that might be useful. With the 2.6.22-10 kernel, it detects the sound card but nothing works. With the 2.6.22-12, it just doesn't find anything. Tribe5 livecd doesn't work, and that's as old as I can go with the kernels and such.

Pitabred (ubuntu-pitabred) wrote :

A little bit more info here. With the 3stack option set, I get this in the dmesg output when I grep for hda:

[ 19.332000] hda_intel: azx_get_response timeout, switching to polling mode...
[ 20.336000] hda_intel: azx_get_response timeout, switching to single_cmd mode...
[ 23.980000] hda_codec: No auto-config is available, default to model=ref
[ 31.284000] hda-intel: no codecs initialized

Michael (mike984) wrote :

This bug may be connected to the same issue - please see https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/129972

Emanuel Goscinski (emu-) wrote :

And is surely related to this Bug #131577

Maybe somebody should gather all Bugs related to issues, where no Intel High Definition sound card were found.

Jairo Serrano (jairo-serrano) wrote :

works with this patch...

http://www.klabs.be/~fpiat/linux/debian/Lenny_on_Thinkpad_T61/#Sound

but the mic dont work.. :(

Hi everybody,

Please forgive my n00bness but I have an oddity to report about this issue on the Dell 1520 with intel audio card. When I boot from the normal desktop Gutsy live cd, audio works partially : the loudspeakers are mute but at least there is perfect output from the headphones jack. On the contrary, after the installation not only the sound is completely off but the audio card is not seen at all. I have been trying to import brute force the settings from the live cd session to the regular one but, provided it can be done, it seems beyond my skill.

It's a tiny bit of information but I hope it helps...

Keep in touch,

Daniele

P.S. I know many people says that on the 1520 you should use the alternate cd, but I got everything else working from the standard one out of the box.

Hi folks,

I got it working but I'm not sure exactly how I did it (luck of the beginner one might think). I found a piece of info on some forum saying to enter the commands below from the CLI:

sudo apt-get install module-assistant
sudo m-a update
sudo m-a prepare
sudo m-a a-i alsa

I am very sorry but in the ordeal of copy+paste notes on possible workarounds I can't find the original author to give him the credit he deserves (that's not me anyway). I copy+pasted these entries in this order and after restarting it worked.

I ran a couple of other scripts before (among the others the one signalled by Jairo Serrano before in this topic) but none of them seemed to work, however I don't exclude that in my disordinate tweaking I might have touched something else without noticing so I am not really sure.

I just know that now I have a working sound. Please let me know if I shall upload any log for your pleasure to look into some mess :).

Daniele

Ben Collins (ben-collins) wrote :

linux-backports-modules-2.6.22 was just uploaded with alsa 1.0.15rc3. As soon as it is built and in the archive, this command should install it for you:

sudo apt-get install linux-backports-modules-generic

After a reboot, please test sound again, and report back on results.

Thanks

Changed in linux-ubuntu-modules-2.6.22:
milestone: ubuntu-7.10-beta → ubuntu-7.10

Thankyou Ben, I get the error message below. It's in Italian, however it says that the he cannot resolve the dependency from linux-backports-modules-2.6.22-14-generic.
Daniele

daniele@daniele-laptop:~$ sudo apt-get install linux-backports-modules-generic
[sudo] password for daniele:
Lettura della lista dei pacchetti in corso... Fatto
Generazione dell'albero delle dipendenze in corso
Reading state information... Fatto
Alcuni pacchetti non possono essere installati. Questo può voler
dire che è stata richiesta una situazione impossibile oppure, se
si sta usando la distribuzione "unstable", che alcuni pacchetti
richiesti non sono ancora stati creati o rimossi da incoming.

Poiché è stata richiesta solo una singola operazione è molto facile che
il pacchetto semplicemente non sia installabile, si consiglia
di inviare un "bug report" per tale pacchetto.
Le seguenti informazioni possono aiutare a risolvere la situazione:

I seguenti pacchetti hanno dipendenze non soddisfatte:
  linux-backports-modules-generic: Dipende: linux-backports-modules-2.6.22-14-generic ma non è installabile
E: Pacchetto non integro

Hi. I'm having the same troubles. Danielle's solution has works for me but when I plug headphones the internal speakers don't stop. I've found a link (https://wiki.ubuntu.com/Gutsy_Intel_HD_Audio_Controller) to Ubuntu Wiki in witch it is said some possible solutions. In mi case, my laptop is a Dell Inspiron 1720. I've test the solution that they say works with this laptop but it haven't works.

I've also tried to install linux-backports-modules-generic but i receive the same problem than Daniele, but in Spanish jeje. Thanks, and sorry for my possible mistakes writing in English.

Steve Langasek (vorlon) wrote :

linux-backports-modules-generic should be installable now with this fix; could you please test again and report back?

I can confirm that sound is now working, good work!

Changed in dell:
status: In Progress → Fix Released

I have set up linux-backports-modules-generic and it works but I still have the same problem as Jesus with the speakers that keep going after plugging the headphones. I have noticed that if I turn on the computer with the headphones plugged I get the contrary: headphones functioning but no speakers not even when I umplug them. Practically it does not "sense" the switch after reading it in the first place. However it's a minor annoyance and with the reboot trick, albeit not ideal, you can still avoid annoying people when you enjoy a movie on the train, kudos the support team.

It works for me, even, the problem of the speakers is resolved. Thanks a lot.

Olivier Guéry (nemolivier) wrote :

It works for me (hope it’s the package and not the compilation I made two days ago)

Michael (mike984) wrote :
Tim Gardner (timg-tpi) on 2007-10-23
Changed in linux-backports-modules-2.6.22:
assignee: timg-tpi → nobody
status: In Progress → Fix Released
Changed in somerville:
importance: Undecided → Medium
status: New → Fix Released
no longer affects: dell
Timothy R. Chavez (timrchavez) wrote :

The bug task for the somerville project has been removed by an automated script. This bug has been cloned on that project and is available here: https://bugs.launchpad.net/bugs/1306158

no longer affects: somerville
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers