Ubuntu

Audio fails on resume from Hibernate on Dell Inspiron 1420

Reported by rez on 2007-06-24
20
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-backports-modules-2.6.22 (Ubuntu)
Medium
Ben Collins
linux-source-2.6.22 (Baltix)
Undecided
Unassigned
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned

Bug Description

Package: linux-image-2.6.20-16-generic

On resuming from Hibernate, audio does not work on Dell Inspiron 1420. I have tried setting HIBERNATE_MODE=platform and running "/etc/init.d/als-utils force-reload" on resume. None of them worked.
Doing a reboot will bring back the sound. Resuming from Suspend will also keep the audio working.

Changed in linux-source-2.6.20:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
Tim Gardner (timg-tpi) on 2007-06-26
Changed in redfish:
importance: Undecided → High
assignee: nobody → timg-tpi
Tim Gardner (timg-tpi) wrote :
Changed in redfish:
status: New → Confirmed
Changed in linux-source-2.6.20:
assignee: ubuntu-kernel-team → timg-tpi
status: New → Confirmed
Tim Gardner (timg-tpi) wrote :
rez (rezwanul-kabir) wrote :

The offending application seems to be mixer_applet2 ( that shows the speaker on the panel).
 By killing the applet before hibernating, the issue is resolved.
      So, I tested by creating a file, say, 71-sound-fix.sh in /etc/acpi/suspend.d/.
      In the file , I do, "killall mixer_applet2"

 However, the drawback is, upon resuming the user will see a message box which asks the user whether to load or not the volume control applet. If the user chooses to load, everything is perfect. But if he chooses not to load, then the speaker icon will be gone from the panel ( the user, however, can always add it back to panel manually).
      I don't know much about gnome applets. So, I don't know how to add and remove an applet to the panel programatically.

 The above will also let you unload the "snd_hda_intel" module. It seems mixer_applet2 is what was holding references to the module. And I have found unloading the module before hibernating and loading it back on resume does solve the problem as well. I tested this scenerio from the text console in recovery mode..

Tim Gardner (timg-tpi) wrote :

After some experimentation I think a better solution is this:

/etc/acpi/suspend.d/86-lanai-sound.sh:
killall mixer_applet2
modprobe -r snd_hda_intel

/etc/acpi/resume.d/66-lanai-sound.sh:
modprobe snd_hda_intel

This gets the sound module shut down and restored in the right order, and works for both hibernate and suspend. The Gnome mixer applet still annoys you on resume, but I'm not sure how to fix that in a user generic way.

Tim Gardner (timg-tpi) on 2007-06-27
Changed in redfish:
status: Confirmed → In Progress
Tim Gardner (timg-tpi) on 2007-07-02
Changed in linux-source-2.6.20:
assignee: timg-tpi → nobody

Issue still seen on Inspiron 1420 with tribe-5 and all updates as of 9/20/07

Tim Gardner (timg-tpi) wrote :

The Feisty fix works, but there is still that annoying mixer applet after resume.

Kyle M Weller (kylew) wrote :

issue still seen on Gutsy Beta with Dell Dimension 3000 onboard audio card, on hibernate resume volume applet has a / no smoking symbol on it
root@ion:~# uname -a
Linux ion 2.6.22-12-generic #1 SMP Sun Sep 23 18:11:30 GMT 2007 i686 GNU/Linux

Kyle M Weller (kylew) wrote :

here is my sound card modules that are effected:
root@ion:~# lsmod | grep snd
snd_intel8x0 34972 17
snd_ac97_codec 100644 1 snd_intel8x0
ac97_bus 3200 1 snd_ac97_codec
snd_pcm_oss 44672 0
snd_mixer_oss 17664 1 snd_pcm_oss
snd_pcm 80388 4 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_seq_dummy 4740 0
snd_seq_oss 33152 0
snd_seq_midi 9600 0
snd_rawmidi 25728 1 snd_seq_midi
snd_seq_midi_event 8448 2 snd_seq_oss,snd_seq_midi
snd_seq 53232 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer 24324 3 snd_pcm,snd_seq
snd_seq_device 9228 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd 54660 47 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore 8800 1 snd
snd_page_alloc 10888 2 snd_intel8x0,snd_pcm

description: updated
Ben Collins (ben-collins) wrote :

The updated alsa in linux-backports-modules-2.6.22 fixes the major portion of this failure. For some reason, sound is muted on resume still. Not know yet if this is the fault of the driver or alsa-lib userspace.

Work around is to adjust volume, or mute/unmute after resume (this can be automated by adding a script in /etc/acpi/resume.d/ to call "amixer set Front mute; amixer set Front unmute".

Changed in linux-ubuntu-modules-2.6.22:
assignee: timg-tpi → ben-collins
status: Confirmed → Fix Committed
Changed in linux-source-2.6.22:
status: New → Invalid
status: New → Invalid
Tim Gardner (timg-tpi) wrote :

Its not a mute problem, it appears that volume is not initialized on resume. The attached file restores volume after resume. Add it to /etc/acpi/resume.d.

I'll mark it as fixed for Gutsy. Should work natively for Hardy.

Changed in dell:
status: In Progress → Fix Released
Kunal Thakar (kunalt) wrote :

Its NOT fixed for Gutsy. I have a 1420N Inspiron and the problem persists. I have installed gutsy afresh.

Kunal Thakar (kunalt) wrote :

Even after trying out Tim Gardners resume script or Ben Collins', the sound doesn't come up after resuming. One reboot is required for the sound to come up.

same problem here, my dimension has no sound, and sometimes doesnt allow me
to resume from suspend/hibernate, how comes crappy m$ products got it
right?

For the script 99-restore-volume.sh to work, you must have linux-backports-modules-2.6.22-14-generic installed.

Owen Williams (ywwg) wrote :

The fixes described in this bug appear to have been automatically installed on my girlfriend's Dell 1420n, but she is still having trouble with no sound after resume. This is on Feisty with no funky package changes, default install. I've tried muting and muting as described. I tried the 99-restore-volume script, but amixer says it can't find a control called Master. The only relevant mixer controls are PCM, which doesn't have a mute option, and Front, which does.

Ivan Gagis (igagis) wrote :

Audio does not work after resume from Hibernate on Inspiron 1501 as well.
Ubuntu 8.10 RC.

CydeSwype (ircone) wrote :

Still an issue on 8.10 (intrepid ibex)

Linux ian-laptop 2.6.27-9-generic #1 SMP Thu Nov 20 21:57:00 UTC 2008 i686 GNU/Linux

Pieter (diepes) wrote :

Seeing similar problem on lenovo R61 laptop.
2.6.27-11-generic #1 SMP

Pieter (diepes) wrote :

ok, found one way to restore sound.
sudo alsa force-reload

Sergio Zanchetta (primes2h) wrote :

The 18 month support period for Gutsy Gibbon 7.10 has reached its end of life -
http://www.ubuntu.com/news/ubuntu-7.10-eol . As a result, we are closing the
linux-backports-modules-2.6.22 task. It would be helpful if you could test the
new Jaunty Jackalope 9.04 release and confirm if this issue remains -
http://www.ubuntu.com/getubuntu/releasenotes/904overview. If the issue still exists with the Jaunty
release, please update this report by changing the Status of the "linux (Ubuntu)"
task from "Incomplete" to "New". Thanks in advance.

Changed in linux-backports-modules-2.6.22 (Ubuntu):
status: Fix Committed → Won't Fix
milestone: ubuntu-7.10-rc → none
Changed in linux (Ubuntu):
status: New → Incomplete
Ivan Gagis (igagis) wrote :

I retested it on 8.10 Hardy with latest updates, the bug is not reproduced. Audio works after waking up from hibernate.

Changed in linux (Ubuntu):
status: Incomplete → Fix Released
Changed in somerville:
assignee: nobody → Tim Gardner (timg-tpi)
importance: Undecided → High
status: New → Fix Released
no longer affects: dell
Timothy R. Chavez (timrchavez) wrote :

The bug task for the somerville project has been removed by an automated script. This bug has been cloned on that project and is available here: https://bugs.launchpad.net/bugs/1305719

no longer affects: somerville
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers