apic test in kvm-unit-test failed on azure cloud with 4.13/4.14 kernel

Bug #1748103 reported by Po-Hsu Lin on 2018-02-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-kernel-tests
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Cosmic
Undecided
Unassigned
linux-azure (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Cosmic
Undecided
Unassigned
linux-azure-edge (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Cosmic
Undecided
Unassigned

Bug Description

With Joshua's comment in bug 1719524: "Nested KVM can only be tried on instance sizes with nested Hypervisor support: Ev3 and Dv3.", although the instance name is E4v3 here but I can start a KVM on it.

Test apic will timeout on it.

Steps:
1. git clone --depth=1 https://git.kernel.org/pub/scm/virt/kvm/kvm-unit-tests.git
2. cd kvm-unit-tests; ./configure; make
3. Run the apic test as root:

# TESTNAME=apic TIMEOUT=30 ACCEL= ./x86/run x86/apic.flat -smp 2 -cpu qemu64,+x2apic,+tsc-deadline
timeout -k 1s --foreground 30 /usr/bin/qemu-system-x86_64 -nodefaults -device pc-testdev -device isa-debug-exit,iobase=0xf4,iosize=0x4 -vnc none -serial stdio -device pci-testdev -machine accel=kvm -kernel x86/apic.flat -smp 2 -cpu qemu64,+x2apic,+tsc-deadline # -initrd /tmp/tmp.onXtr5JVp7
enabling apic
enabling apic
paging enabled
cr0 = 80010011
cr3 = 459000
cr4 = 20
apic version: 1050014
PASS: apic existence
PASS: xapic id matches cpuid
PASS: writeable xapic id
PASS: non-writeable x2apic id
PASS: sane x2apic id
FAIL: x2apic id matches cpuid
PASS: correct xapic id after reset
PASS: apic_disable: Local apic enabled
PASS: apic_disable: CPUID.1H:EDX.APIC[bit 9] is set
PASS: apic_disable: Local apic disabled
PASS: apic_disable: CPUID.1H:EDX.APIC[bit 9] is clear
PASS: apic_disable: Local apic enabled
PASS: apic_disable: CPUID.1H:EDX.APIC[bit 9] is set
x2apic enabled
PASS: x2apic enabled to invalid state
PASS: x2apic enabled to apic enabled
PASS: disabled to invalid state
PASS: disabled to x2apic enabled
PASS: apic enabled to invalid state
PASS: apicbase: relocate apic
PASS: apicbase: reserved physaddr bits
PASS: apicbase: reserved low bits
PASS: self ipi
starting broadcast (x2apic)
PASS: APIC physical broadcast address
PASS: APIC physical broadcast shorthand
PASS: nmi-after-sti
qemu-system-x86_64: terminating on signal 15 from pid 7246

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: linux-image-4.14.0-1004-azure-edge 4.14.0-1004.4
ProcVersionSignature: User Name 4.14.0-1004.4-username-edge 4.14.14
Uname: Linux 4.14.0-1004-azure-edge x86_64
ApportVersion: 2.20.1-0ubuntu2.15
Architecture: amd64
Date: Thu Feb 8 06:00:55 2018
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: linux-azure-edge
UpgradeStatus: No upgrade log present (probably fresh install)
---
ApportVersion: 2.20.1-0ubuntu2.15
Architecture: amd64
DistroRelease: Ubuntu 16.04
Package: linux-azure-edge
PackageArchitecture: amd64
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: User Name 4.13.0-1009.12-username 4.13.13
Tags: xenial uec-images
Uname: Linux 4.13.0-1009-azure x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm audio cdrom dialout dip floppy libvirtd lxd netdev plugdev sudo video
_MarkForUpload: True

Po-Hsu Lin (cypressyew) wrote :
description: updated

apport information

summary: - apic test in kvm-unit-test failed on E4v3 azure node with 4.14 kernel
+ apic test in kvm-unit-test failed on E4v3 azure node with 4.13/4.14
+ kernel
tags: added: apport-collected
description: updated

apport information

apport information

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1748103

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Po-Hsu Lin (cypressyew) on 2019-03-28
tags: added: cosmic
Sean Feole (sfeole) wrote :

Also have seen this in the following Azure instances

Standard_D2_v3
Standard_D2s_v3
Standard_DC2s
Standard_E2s_v3

summary: - apic test in kvm-unit-test failed on E4v3 azure node with 4.13/4.14
- kernel
+ apic test in kvm-unit-test failed on azure cloud with 4.13/4.14 kernel
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers