[Hyper-V] linux-azure cifs mount error caused by missing nls_utf8.ko module

Bug #1719624 reported by Marin Nedea on 2017-09-26
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux-azure (Ubuntu)
Medium
Marcelo Cerri
Xenial
Medium
Marcelo Cerri

Bug Description

While mounting the share with CIFS/version=2.1/charset=utf8 ansible breaks with an error.

Error "Can not access a needed shared library"...

Testing with ISO-8859 charset works. utf8 does not.

ls -ltr /lib/modules/4.11.0-1011-azure/kernel/fs/nls/
total 12
-rw-r--r-- 1 root root 9094 Sep 19 19:49 nls_iso8859-1.ko

It looks like the nls_utf8.ko module was not included in this kernel.

Marin Nedea (marin-n) wrote :

Installing linux-image-extra-4.11.0-1011-azure_4.11.0-1011.11_amd64.deb solves this issue, however it shouldn't be necessary from the beginning.

Plus, it adds more than needed:

ls -l /lib/modules/4.11.0-1011-azure/kernel/fs/nls/
total 1052
-rw-r--r-- 1 root root 11454 Sep 19 19:46 mac-celtic.ko
-rw-r--r-- 1 root root 10830 Sep 19 19:46 mac-centeuro.ko
-rw-r--r-- 1 root root 11454 Sep 19 19:46 mac-croatian.ko
-rw-r--r-- 1 root root 10526 Sep 19 19:46 mac-cyrillic.ko
-rw-r--r-- 1 root root 11142 Sep 19 19:46 mac-gaelic.ko
-rw-r--r-- 1 root root 10518 Sep 19 19:46 mac-greek.ko
-rw-r--r-- 1 root root 11454 Sep 19 19:46 mac-iceland.ko
-rw-r--r-- 1 root root 10830 Sep 19 19:46 mac-inuit.ko
-rw-r--r-- 1 root root 11454 Sep 19 19:46 mac-romanian.ko
-rw-r--r-- 1 root root 11758 Sep 19 19:46 mac-roman.ko
-rw-r--r-- 1 root root 11454 Sep 19 19:46 mac-turkish.ko
-rw-r--r-- 1 root root 8958 Sep 19 19:46 nls_ascii.ko
-rw-r--r-- 1 root root 10198 Sep 19 19:46 nls_cp1250.ko
-rw-r--r-- 1 root root 9894 Sep 19 19:46 nls_cp1251.ko
-rw-r--r-- 1 root root 10646 Sep 19 19:46 nls_cp1255.ko
-rw-r--r-- 1 root root 10198 Sep 19 19:46 nls_cp737.ko
-rw-r--r-- 1 root root 10198 Sep 19 19:46 nls_cp775.ko
-rw-r--r-- 1 root root 9886 Sep 19 19:46 nls_cp850.ko
-rw-r--r-- 1 root root 9886 Sep 19 19:46 nls_cp852.ko
-rw-r--r-- 1 root root 9886 Sep 19 19:46 nls_cp855.ko
-rw-r--r-- 1 root root 9574 Sep 19 19:46 nls_cp857.ko
-rw-r--r-- 1 root root 10510 Sep 19 19:46 nls_cp860.ko
-rw-r--r-- 1 root root 10822 Sep 19 19:46 nls_cp861.ko
-rw-r--r-- 1 root root 11134 Sep 19 19:46 nls_cp862.ko
-rw-r--r-- 1 root root 10822 Sep 19 19:46 nls_cp863.ko
-rw-r--r-- 1 root root 10510 Sep 19 19:46 nls_cp864.ko
-rw-r--r-- 1 root root 10822 Sep 19 19:46 nls_cp865.ko
-rw-r--r-- 1 root root 10198 Sep 19 19:46 nls_cp866.ko
-rw-r--r-- 1 root root 9886 Sep 19 19:46 nls_cp869.ko
-rw-r--r-- 1 root root 9710 Sep 19 19:46 nls_cp874.ko
-rw-r--r-- 1 root root 91798 Sep 19 19:46 nls_cp932.ko
-rw-r--r-- 1 root root 140398 Sep 19 19:46 nls_cp936.ko
-rw-r--r-- 1 root root 163470 Sep 19 19:46 nls_cp949.ko
-rw-r--r-- 1 root root 115846 Sep 19 19:46 nls_cp950.ko
-rw-r--r-- 1 root root 9542 Sep 19 19:46 nls_euc-jp.ko
-rw-r--r-- 1 root root 9590 Sep 19 19:46 nls_iso8859-13.ko
-rw-r--r-- 1 root root 9590 Sep 19 19:46 nls_iso8859-14.ko
-rw-r--r-- 1 root root 9590 Sep 19 19:46 nls_iso8859-15.ko
-rw-r--r-- 1 root root 9094 Sep 19 19:49 nls_iso8859-1.ko
-rw-r--r-- 1 root root 9582 Sep 19 19:46 nls_iso8859-2.ko
-rw-r--r-- 1 root root 9582 Sep 19 19:46 nls_iso8859-3.ko
-rw-r--r-- 1 root root 9582 Sep 19 19:46 nls_iso8859-4.ko
-rw-r--r-- 1 root root 9582 Sep 19 19:46 nls_iso8859-5.ko
-rw-r--r-- 1 root root 9278 Sep 19 19:46 nls_iso8859-6.ko
-rw-r--r-- 1 root root 9894 Sep 19 19:46 nls_iso8859-7.ko
-rw-r--r-- 1 root root 9278 Sep 19 19:46 nls_iso8859-9.ko
-rw-r--r-- 1 root root 10198 Sep 19 19:46 nls_koi8-r.ko
-rw-r--r-- 1 root root 5598 Sep 19 19:46 nls_koi8-ru.ko
-rw-r--r-- 1 root root 10198 Sep 19 19:46 nls_koi8-u.ko
-rw-r--r-- 1 root root 5518 Sep 19 19:46 nls_utf8.ko

Joshua R. Poulson (jrp) on 2017-10-03
summary: - linux-azure cifs mount error caused by missing nls_utf8.ko module
+ [Hyper-V] linux-azure cifs mount error caused by missing nls_utf8.ko
+ module
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux-azure (Ubuntu):
status: New → Confirmed
Joshua R. Poulson (jrp) wrote :

Yes, let's add nls_utf8.ko to the regular kernel package.

Marcelo Cerri (mhcerri) on 2017-10-04
Changed in linux-azure (Ubuntu):
assignee: nobody → Marcelo Cerri (mhcerri)
importance: Undecided → Medium
status: Confirmed → In Progress
Marcelo Cerri (mhcerri) wrote :
Changed in linux-azure (Ubuntu):
status: In Progress → Fix Committed
Changed in linux-azure (Ubuntu Xenial):
status: New → Fix Committed
importance: Undecided → Medium
assignee: nobody → Marcelo Cerri (mhcerri)

Can someone verify this bug is fixed with the kernel in -proposed?

Cascardo.

tags: added: verification-needed-xenial
Marcelo Cerri (mhcerri) on 2017-10-30
tags: added: verification-done-xenial
removed: verification-needed-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-azure - 4.11.0-1014.14

---------------
linux-azure (4.11.0-1014.14) xenial; urgency=low

  * linux-azure: 4.11.0-1014.14 -proposed tracker (LP: #1724060)

  * [Hyper-V] linux-azure cifs mount error caused by missing nls_utf8.ko module
    (LP: #1719624)
    - [config] azure: move nls_utf8.ko to linux-image package

 -- Thadeu Lima de Souza Cascardo <email address hidden> Mon, 16 Oct 2017 17:24:42 -0200

Changed in linux-azure (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers