linux-azure: persistent memory is not working

Bug #1715755 reported by Marcelo Cerri on 2017-09-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-azure (Ubuntu)
High
Marcelo Cerri
Xenial
High
Marcelo Cerri

Bug Description

When running opengcs with the linux-azure kernel (4.11.0-1008.8), persistent memory doesn't seem to be working.

A known issue was introduced by 4.11.2, and that might be related to the problem:

https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux-stable.git/commit/?h=linux-4.11.y&id=5a3651b4a92cbc5230d67d2ce87fb3f7373c7665

Marcelo Cerri (mhcerri) on 2017-09-07
Changed in linux-azure (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → High
Marcelo Cerri (mhcerri) wrote :

The revert alone doesn't solve the problem. We will run new tests enabling CONFIG_ND_BLK and CONFIG_ACPI_NFIT.

Marcelo Cerri (mhcerri) wrote :

The revert is not necessary anymore since the issue was fixed upstream by the commit id fd96b8da68d3 ("ext4: fix fault handling when mounted with -o dax,ro").

Marcelo Cerri (mhcerri) on 2017-09-15
Changed in linux-azure (Ubuntu Xenial):
status: New → Fix Committed
importance: Undecided → High
assignee: nobody → Marcelo Cerri (mhcerri)
Changed in linux-azure (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-azure - 4.11.0-1011.11

---------------
linux-azure (4.11.0-1011.11) xenial; urgency=low

  * linux-azure: 4.11.0-1011.11 -proposed tracker (LP: #1718265)

  * KVP scripts location for linux-azure image (LP: #1718264)
    - SAUCE: azure: hv_kvp_daemon: search for HV scripts in /usr/sbin/

  * [linux-azure] RTC options not present in kernel config (LP: #1718262)
    - [Config] azure: Enable RTC

linux-azure (4.11.0-1010.10) xenial; urgency=low

  * linux-azure: 4.11.0-1010.10 -proposed tracker (LP: #1717616)

  * linux-azure: persistent memory is not working (LP: #1715755)
    - ext4: fix fault handling when mounted with -o dax,ro
    - [Config] azure: CONFIG_ND_BLK=y
    - [Config] azure: CONFIG_ACPI_NFIT=y

  * [Hyper-V] 16.04 kexec-tools doesn't match linux-azure (LP: #1712867)
    - x86/KASLR: Fix kexec kernel boot crash when KASLR randomization fails

 -- Marcelo Henrique Cerri <email address hidden> Tue, 19 Sep 2017 15:47:22 -0300

Changed in linux-azure (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers