linux-headers-4.18.0-1004-azure contains links to non-existing targets

Bug #1803335 reported by Po-Hsu Lin on 2018-11-14
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-kernel-tests
Undecided
Unassigned
linux-azure-edge (Ubuntu)
Undecided
Jesse Sung
Bionic
Undecided
Jesse Sung

Bug Description

This issue was spotted on Bionic 4.18 Azure in -proposed

$ ls /usr/src/linux-azure-edge-headers-4.18.0-1004
ls: cannot access '/usr/src/linux-azure-edge-headers-4.18.0-1004': No such file or directory

$ ll /usr/src/linux-headers-4.18.0-1004-azure
total 1240
drwxr-xr-x 8 root root 4096 Nov 14 11:19 ./
drwxr-xr-x 5 root root 4096 Nov 14 11:19 ../
-rw-r--r-- 1 root root 136487 Oct 25 13:59 .config
-rw-r--r-- 1 root root 130326 Oct 25 13:59 .config.old
-rw-r--r-- 1 root root 1229 Oct 25 13:59 .missing-syscalls.d
drwxr-xr-x 2 root root 4096 Oct 25 13:59 .tmp_versions/
lrwxrwxrwx 1 root root 53 Oct 25 13:59 Documentation -> ../linux-azure-edge-headers-4.18.0-1004/Documentation
lrwxrwxrwx 1 root root 46 Oct 25 13:59 Kbuild -> ../linux-azure-edge-headers-4.18.0-1004/Kbuild
lrwxrwxrwx 1 root root 47 Oct 25 13:59 Kconfig -> ../linux-azure-edge-headers-4.18.0-1004/Kconfig
lrwxrwxrwx 1 root root 48 Oct 25 13:59 Makefile -> ../linux-azure-edge-headers-4.18.0-1004/Makefile
-rw-r--r-- 1 root root 952862 Oct 25 13:59 Module.symvers
drwxr-xr-x 3 root root 4096 Nov 14 11:19 arch/
lrwxrwxrwx 1 root root 45 Oct 25 13:59 block -> ../linux-azure-edge-headers-4.18.0-1004/block
lrwxrwxrwx 1 root root 45 Oct 25 13:59 certs -> ../linux-azure-edge-headers-4.18.0-1004/certs
lrwxrwxrwx 1 root root 46 Oct 25 13:59 crypto -> ../linux-azure-edge-headers-4.18.0-1004/crypto
lrwxrwxrwx 1 root root 47 Oct 25 13:59 drivers -> ../linux-azure-edge-headers-4.18.0-1004/drivers
lrwxrwxrwx 1 root root 48 Oct 25 13:59 firmware -> ../linux-azure-edge-headers-4.18.0-1004/firmware
lrwxrwxrwx 1 root root 42 Oct 25 13:59 fs -> ../linux-azure-edge-headers-4.18.0-1004/fs
drwxr-xr-x 4 root root 4096 Nov 14 11:19 include/
lrwxrwxrwx 1 root root 44 Oct 25 13:59 init -> ../linux-azure-edge-headers-4.18.0-1004/init
lrwxrwxrwx 1 root root 43 Oct 25 13:59 ipc -> ../linux-azure-edge-headers-4.18.0-1004/ipc
drwxr-xr-x 2 root root 4096 Nov 14 11:19 kernel/
lrwxrwxrwx 1 root root 43 Oct 25 13:59 lib -> ../linux-azure-edge-headers-4.18.0-1004/lib
lrwxrwxrwx 1 root root 42 Oct 25 13:59 mm -> ../linux-azure-edge-headers-4.18.0-1004/mm
lrwxrwxrwx 1 root root 43 Oct 25 13:59 net -> ../linux-azure-edge-headers-4.18.0-1004/net
lrwxrwxrwx 1 root root 47 Oct 25 13:59 samples -> ../linux-azure-edge-headers-4.18.0-1004/samples
drwxr-xr-x 6 root root 12288 Nov 14 11:19 scripts/
lrwxrwxrwx 1 root root 48 Oct 25 13:59 security -> ../linux-azure-edge-headers-4.18.0-1004/security
lrwxrwxrwx 1 root root 45 Oct 25 13:59 sound -> ../linux-azure-edge-headers-4.18.0-1004/sound
lrwxrwxrwx 1 root root 43 Oct 25 13:59 spl -> ../linux-azure-edge-headers-4.18.0-1004/spl
drwxr-xr-x 3 root root 4096 Nov 14 11:19 tools/
lrwxrwxrwx 1 root root 46 Oct 25 13:59 ubuntu -> ../linux-azure-edge-headers-4.18.0-1004/ubuntu
lrwxrwxrwx 1 root root 43 Oct 25 13:59 usr -> ../linux-azure-edge-headers-4.18.0-1004/usr
lrwxrwxrwx 1 root root 44 Oct 25 13:59 virt -> ../linux-azure-edge-headers-4.18.0-1004/virt
lrwxrwxrwx 1 root root 43 Oct 25 13:59 zfs -> ../linux-azure-edge-headers-4.18.0-1004/zfs

$ uname -a
Linux b-la-edge-azure-edge-4-18-0-Basic-A1-qrt-kernel-security 4.18.0-1004-azure #4~18.04.1-Ubuntu SMP Thu Oct 25 14:25:41 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

$ dpkg -l | grep header
ii execstack 0.0.20131005-1 amd64 ELF GNU_STACK program header editing utility
ii linux-azure-headers-4.15.0-1030 4.15.0-1030.31 all Header files related to Linux kernel version 4.15.0
ii linux-azure-headers-4.18.0-1004 4.18.0-1004.4~18.04.1 all Header files related to Linux kernel version 4.18.0
ii linux-headers-4.15.0-1030-azure 4.15.0-1030.31 amd64 Linux kernel headers for version 4.15.0 on 64 bit x86 SMP
ii linux-headers-4.18.0-1004-azure 4.18.0-1004.4~18.04.1 amd64 Linux kernel headers for version 4.18.0 on 64 bit x86 SMP
ii linux-headers-azure 4.15.0.1030.30 amd64 Linux kernel headers for Azure systems.
ii linux-headers-azure-edge 4.18.0.1004.5 amd64 Linux kernel headers for Azure systems.

Po-Hsu Lin (cypressyew) on 2018-11-14
affects: ubuntu-kernel-tests → linux (Ubuntu)
Po-Hsu Lin (cypressyew) wrote :

This might be the cause of:
bug 1803333
bug 1803328
and
bug 1803330

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1803335

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: cosmic
Jesse Sung (wenchien) on 2018-11-15
Changed in ubuntu-kernel-tests:
assignee: nobody → Jesse Sung (wenchien)
Changed in linux (Ubuntu):
assignee: nobody → Jesse Sung (wenchien)
Changed in ubuntu-kernel-tests:
status: New → In Progress
assignee: Jesse Sung (wenchien) → nobody
status: In Progress → New
Po-Hsu Lin (cypressyew) on 2018-11-15
tags: added: package-from-proposed
affects: linux (Ubuntu) → linux-azure-edge (Ubuntu)
Changed in linux-azure-edge (Ubuntu):
status: Incomplete → In Progress
description: updated
Changed in ubuntu-kernel-tests:
status: New → Confirmed
Changed in linux-azure-edge (Ubuntu Bionic):
status: New → In Progress
assignee: nobody → Jesse Sung (wenchien)
Changed in linux-azure-edge (Ubuntu):
status: In Progress → Invalid
Changed in linux-azure-edge (Ubuntu Bionic):
status: In Progress → Fix Committed
Joshua R. Poulson (jrp) wrote :
Download full text (5.8 KiB)

It does not look different in 4.18.0-1005

$ ls /usr/src/linux-azure-edge-headers-4.18.0-1005
ls: cannot access '/usr/src/linux-azure-edge-headers-4.18.0-1005': No such file or directory

$ ll /usr/src/linux-headers-4.18.0-1005-azure
total 1240
drwxr-xr-x 8 root root 4096 Nov 26 20:06 ./
drwxr-xr-x 10 root root 4096 Nov 26 20:06 ../
-rw-r--r-- 1 root root 136487 Nov 16 06:08 .config
-rw-r--r-- 1 root root 130326 Nov 16 06:08 .config.old
-rw-r--r-- 1 root root 1229 Nov 16 06:08 .missing-syscalls.d
drwxr-xr-x 2 root root 4096 Nov 16 06:08 .tmp_versions/
lrwxrwxrwx 1 root root 48 Nov 16 06:08 Documentation -> ../linux-azure-headers-4.18.0-1005/Documentation/
lrwxrwxrwx 1 root root 41 Nov 16 06:08 Kbuild -> ../linux-azure-headers-4.18.0-1005/Kbuild
lrwxrwxrwx 1 root root 42 Nov 16 06:08 Kconfig -> ../linux-azure-headers-4.18.0-1005/Kconfig
lrwxrwxrwx 1 root root 43 Nov 16 06:08 Makefile -> ../linux-azure-headers-4.18.0-1005/Makefile
-rw-r--r-- 1 root root 953018 Nov 16 06:08 Module.symvers
drwxr-xr-x 3 root root 4096 Nov 26 20:06 arch/
lrwxrwxrwx 1 root root 40 Nov 16 06:08 block -> ../linux-azure-headers-4.18.0-1005/block/
lrwxrwxrwx 1 root root 40 Nov 16 06:08 certs -> ../linux-azure-headers-4.18.0-1005/certs/
lrwxrwxrwx 1 root root 41 Nov 16 06:08 crypto -> ../linux-azure-headers-4.18.0-1005/crypto/
lrwxrwxrwx 1 root root 42 Nov 16 06:08 drivers -> ../linux-azure-headers-4.18.0-1005/drivers/
lrwxrwxrwx 1 root root 43 Nov 16 06:08 firmware -> ../linux-azure-headers-4.18.0-1005/firmware/
lrwxrwxrwx 1 root root 37 Nov 16 06:08 fs -> ../linux-azure-headers-4.18.0-1005/fs/
drwxr-xr-x 4 root root 4096 Nov 26 20:06 include/
lrwxrwxrwx 1 root root 39 Nov 16 06:08 init -> ../linux-azure-headers-4.18.0-1005/init/
lrwxrwxrwx 1 root root 38 Nov 16 06:08 ipc -> ../linux-azure-headers-4.18.0-1005/ipc/
drwxr-xr-x 2 root root 4096 Nov 26 20:06 kernel/
lrwxrwxrwx 1 root root 38 Nov 16 06:08 lib -> ../linux-azure-headers-4.18.0-1005/lib/
lrwxrwxrwx 1 root root 37 Nov 16 06:08 mm -> ../linux-azure-headers-4.18.0-1005/mm/
lrwxrwxrwx 1 root root 38 Nov 16 06:08 net -> ../linux-azure-headers-4.18.0-1005/net/
lrwxrwxrwx 1 root root 42 Nov 16 06:08 samples -> ../linux-azure-headers-4.18.0-1005/samples/
drwxr-xr-x 6 root root 12288 Nov 26 20:06 scripts/
lrwxrwxrwx 1 root root 43 Nov 16 06:08 security -> ../linux-azure-headers-4.18.0-1005/security/
lrwxrwxrwx 1 root root 40 Nov 16 06:08 sound -> ../linux-azure-headers-4.18.0-1005/sound/
lrwxrwxrwx 1 root root 38 Nov 16 06:08 spl -> ../linux-azure-headers-4.18.0-1005/spl/
drwxr-xr-x 3 root root 4096 Nov 26 20:06 tools/
lrwxrwxrwx 1 root root 41 Nov 16 06:08 ubuntu -> ../linux-azure-headers-4.18.0-1005/ubuntu/
lrwxrwxrwx 1 root root 38 Nov 16 06:08 usr -> ../linux-azure-headers-4.18.0-1005/usr/
lrwxrwxrwx 1 root root 39 Nov 16 06:08 virt -> ../linux-azure-headers-4.18.0-1005/virt/
lrwxrwxrwx 1 root root 38 Nov 16 06:08 zfs -> ../linux-azure-headers-4.18.0-1005/zfs/

$ uname -r
4.18.0-1005-azure

$ dpkg -l | grep header
ii libpcap0.8-dev:amd64 1.8.1-6ubuntu1 ...

Read more...

Po-Hsu Lin (cypressyew) wrote :

Hello Joshua,

The problem here is that the softlink in linux-headers-4.18.0-1004-azure is pointing to a non-existing dir

lrwxrwxrwx 1 root root 53 Oct 25 13:59 Documentation -> ../linux-azure-edge-headers-4.18.0-1004/Documentation

$ ls /usr/src/linux-azure-edge-headers-4.18.0-1004
ls: cannot access '/usr/src/linux-azure-edge-headers-4.18.0-1004': No such file or directory

For the current kernel in proposed, 4.18.0-1006 Azure for Bionic, it's pointing to an existing directory:
lrwxrwxrwx 1 root root 48 Nov 26 22:59 Documentation -> ../linux-azure-headers-4.18.0-1006/Documentation/

$ ls /usr/src/linux-azure-headers-4.18.0-1006
Documentation Kconfig arch certs drivers fs init kernel mm samples security spl ubuntu virt
Kbuild Makefile block crypto firmware include ipc lib net scripts sound tools usr zfs

So we can call this fixed.
Thanks

Changed in ubuntu-kernel-tests:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-azure-edge - 4.18.0-1006.6~16.04.2

---------------
linux-azure-edge (4.18.0-1006.6~16.04.2) xenial; urgency=medium

  * linux-azure-edge: 4.18.0-1006.6~16.04.2 -proposed tracker (LP: #1805865)

  [ Ubuntu: 4.18.0-1006.6 ]

  * linux-azure: 4.18.0-1006.6 -proposed tracker (LP: #1805244)
  * Accelerated networking (SR-IOV VF) broken in 18.10 daily (LP: #1794477)
    - [Packaging] Move pci-hyperv and autofs4 back to linux-modules

 -- Marcelo Henrique Cerri <email address hidden> Fri, 30 Nov 2018 14:57:53 -0200

Changed in linux-azure-edge (Ubuntu):
status: Invalid → Fix Released
Brad Figg (brad-figg) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-bionic' to 'verification-done-bionic'. If the problem still exists, change the tag 'verification-needed-bionic' to 'verification-failed-bionic'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-bionic
Po-Hsu Lin (cypressyew) on 2019-03-04
tags: added: verification-done-bionic
removed: verification-needed-bionic
Po-Hsu Lin (cypressyew) wrote :

Works well with 4.18.0-1006.6~16.04.2
Kernel security test can be built (bug 1803333).

 test_072_strict_devmem (__main__.KernelSecurityTest)
 /dev/mem unreadable for kernel memory ... (using 0x198a05a28) (exit code 0) ok

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers