net and ftrace selftests failures due to missing test modules

Bug #1823407 reported by Seth Forshee on 2019-04-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-aws (Ubuntu)
High
Seth Forshee

Bug Description

SRU Justification

Impact: The test_bpf net selftest and a couple of ftrace selftests are failing due to missing modules. These modules are only for test purposes and have no other use, so they are not wanted in the linux-modules package.

Fix: Change the tests to treat the missing modules as skipped tests rather than failures.

Regression Potential: Minimal, since the changes are only to test cases which are already failing.

Test Case: Run the test cases with the patch applied and observe that they behave as skipped tests rather than failures.

Seth Forshee (sforshee) on 2019-04-05
description: updated
Seth Forshee (sforshee) on 2019-04-08
Changed in linux-aws (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-aws - 5.0.0-1002.2

---------------
linux-aws (5.0.0-1002.2) disco; urgency=medium

  * linux-aws: 5.0.0-1002.2 -proposed tracker (LP: #1823219)

  * Set CONFIG_RANDOM_TRUST_CPU=y (LP: #1823754)
    - [Config] CONFIG_RANDOM_TRUST_CPU=y

  * net and ftrace selftests failures due to missing test modules (LP: #1823407)
    - SAUCE: selftests: net: don't fail test_bpf when module is not present
    - SAUCE: selftests: ftrace: don't fail for unresolved tests

  * Please ship the ib_uverbs driver module in the main modules package
    (LP: #1822692)
    - [config] AWS: ib_uverbs.ko, ib_umad.ko moved to linux-modules package

  * Miscellaneous Ubuntu changes
    - [Config] update configs following rebase to 5.0.0-10.11

 -- Seth Forshee <email address hidden> Tue, 09 Apr 2019 11:13:53 -0500

Changed in linux-aws (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers