ubuntu_ltp_syscalls test will hang in the end on T/X AWS

Bug #1777779 reported by Po-Hsu Lin on 2018-06-20
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-kernel-tests
Undecided
Po-Hsu Lin
linux-aws (Ubuntu)
Undecided
Unassigned

Bug Description

The ubuntu_ltp_syscalls test will hang on Trusty (and Xenial) AWS, even though all the tests have been ran.

  INFO: ltp-pan reported some tests FAIL
  LTP Version: 20180515

         ###############################################################

              Done executing testcases.
              LTP Version: 20180515
         ###############################################################
  stderr:
  rm: cannot remove ‘/tmp/ltp-X72GtnsMYy/Q4ynCy/mntpoint’: Device or resource busy
10:19:14 INFO | END ERROR ubuntu_ltp_syscalls.syscalls ubuntu_ltp_syscalls.syscalls timestamp=1529403554 localtime=Jun 19 10:19:14
10:19:14 DEBUG| Persistent state client._record_indent now set to 1
10:19:14 DEBUG| Persistent state client.unexpected_reboot deleted
10:19:14 INFO | END GOOD ---- ---- timestamp=1529403554 localtime=Jun 19 10:19:14
10:19:14 DEBUG| Persistent state client._record_indent now set to 0
10:19:14 INFO | Report successfully generated at /home/ubuntu/autotest/client/results/default/job_report.html

If you log onto the node, you will see a zombie process. The jenkins job will continue when you have that zombie process's parent killed.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: linux-image-4.4.0-1024-aws 4.4.0-1024.25
ProcVersionSignature: User Name 4.4.0-1024.25-aws 4.4.134
Uname: Linux 4.4.0-1024-aws x86_64
ApportVersion: 2.14.1-0ubuntu3.29
Architecture: amd64
Date: Wed Jun 20 05:58:27 2018
Ec2AMI: ami-221f5c5a
Ec2AMIManifest: (unknown)
Ec2AvailabilityZone: us-west-2b
Ec2InstanceType: c3.large
Ec2Kernel: unavailable
Ec2Ramdisk: unavailable
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: linux-aws
UpgradeStatus: No upgrade log present (probably fresh install)

Po-Hsu Lin (cypressyew) wrote :
Stefan Bader (smb) wrote :

The same tests in the Xenial environment with the AWS kernel do work? Did the previous Trusty tests work (with the previous kernel)?

Po-Hsu Lin (cypressyew) wrote :

It will hang with Xenial AWS as well, I will update the bug.

This is the first run of this newly added test against these cloud kernels.

I think this is caused by some failed test cases inside this test suite, haven't had a chance to review them yet. (Seems that the failed test case number is bigger than the generic kernel)

summary: - ubuntu_ltp_syscalls test will hang in the end on Trusty AWS
+ ubuntu_ltp_syscalls test will hang in the end on T/X AWS
description: updated
Po-Hsu Lin (cypressyew) wrote :

Note that there is an issue with this, when the test gets killed, reports won't be copied to the jenkins server.

So I will need to review it on the jenkins job page.

Po-Hsu Lin (cypressyew) wrote :

This will hang with X-generic on AWS cloud as well, but not X-generic on our bare-metals

Po-Hsu Lin (cypressyew) wrote :

This seems to be caused by bug 1775165, with fanotify07 blacklisted this was never occurred again.

Changed in linux-aws (Ubuntu):
assignee: nobody → Po-Hsu Lin (cypressyew)
assignee: Po-Hsu Lin (cypressyew) → nobody
Changed in ubuntu-kernel-tests:
assignee: nobody → Po-Hsu Lin (cypressyew)
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers