Add ipvlan module to EC2 16.04 kernel

Bug #1729615 reported by Jim Robinson on 2017-11-02
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux-aws (Ubuntu)
Undecided
Kamal Mostafa

Bug Description

The stock Ubuntu kernel added ipvlan module support a long time ago:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1634705

However, the latest AWS EC2 Ubuntu 16.04 LTS, doesn't have ipvlan module included.

As a Docker user, I use ipvlan. And it's problematic to compile this module every time I upgrade the kernel.

Current kernel is 4.4.0-1039-aws
---
AlsaDevices: Error: command ['ls', '-l', '/dev/snd/'] failed with exit code 2: ls: cannot access '/dev/snd/': No such file or directory
AplayDevices: Error: [Errno 2] No such file or directory
ApportVersion: 2.20.1-0ubuntu2.10
Architecture: amd64
ArecordDevices: Error: [Errno 2] No such file or directory
CRDA: N/A
DistroRelease: Ubuntu 16.04
Ec2AMI: ami-996372fd
Ec2AMIManifest: (unknown)
Ec2AvailabilityZone: eu-west-2a
Ec2InstanceType: t2.large
Ec2Kernel: unavailable
Ec2Ramdisk: unavailable
IwConfig: Error: [Errno 2] No such file or directory
Lsusb: Error: command ['lsusb'] failed with exit code 1:
MachineType: Xen HVM domU
Package: linux (not installed)
PciMultimedia:

ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB:

ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-1038-aws root=UUID=3e13556e-d28d-407b-bcc6-97160eafebe1 ro console=tty1 console=ttyS0
ProcVersionSignature: Ubuntu 4.4.0-1038.47-aws 4.4.87
RelatedPackageVersions:
 linux-restricted-modules-4.4.0-1038-aws N/A
 linux-backports-modules-4.4.0-1038-aws N/A
 linux-firmware N/A
RfKill: Error: [Errno 2] No such file or directory
Tags: xenial ec2-images
Uname: Linux 4.4.0-1038-aws x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

_MarkForUpload: True
dmi.bios.date: 08/24/2006
dmi.bios.vendor: Xen
dmi.bios.version: 4.2.amazon
dmi.chassis.type: 1
dmi.chassis.vendor: Xen
dmi.modalias: dmi:bvnXen:bvr4.2.amazon:bd08/24/2006:svnXen:pnHVMdomU:pvr4.2.amazon:cvnXen:ct1:cvr:
dmi.product.name: HVM domU
dmi.product.version: 4.2.amazon
dmi.sys.vendor: Xen

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1729615

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: xenial

apport information

tags: added: apport-collected ec2-images
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
affects: linux (Ubuntu) → linux-aws (Ubuntu)
Changed in linux-aws (Ubuntu):
status: Confirmed → New
Changed in linux-aws (Ubuntu):
status: New → In Progress
assignee: nobody → Kamal Mostafa (kamalmostafa)
Changed in linux-aws (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (18.4 KiB)

This bug was fixed in the package linux-aws - 4.4.0-1041.50

---------------
linux-aws (4.4.0-1041.50) xenial; urgency=low

  * linux-aws: 4.4.0-1041.50 -proposed tracker (LP: #1732535)

  * xen hibernation support for linux-aws (LP: #1732512)
    - aws: [Config] disable SUSPEND
    - aws: [Config] disable XEN_FBDEV_FRONTEND, INPUT_XEN_KBDDEV_FRONTEND
    - xen: move xen_setup_runstate_info and get_runstate_snapshot to
      drivers/xen/time.c
    - xen/time: use READ_ONCE
    - xen: add steal_clock support on x86
    - xen: support runqueue steal time on xen
    - xen: introduce xen_vcpu_id mapping
    - x86/xen: use xen_vcpu_id mapping for HYPERVISOR_vcpu_op
    - xen: add static initialization of steal_clock op to xen_time_ops
    - x86/xen: update cpuid.h from Xen-4.7
    - x86/acpi: store ACPI ids from MADT for future usage
    - xen: update xen headers
    - xen: change the type of xen_vcpu_id to uint32_t
    - xen/blkfront: separate per ring information out of device info
    - xen/blkfront: pseudo support for multi hardware queues/rings
    - xen/blkfront: split per device io_lock
    - xen/blkfront: negotiate number of queues/rings to be used with backend
    - xen/blkfront: Cleanup of comments, fix unaligned variables, and syntax
      errors.
    - xen/blkfront: Remove duplicate setting of ->xbdev.
    - xen/blkfront: make persistent grants pool per-queue
    - xen/blkfront: correct setting for xen_blkif_max_ring_order
    - xen/blkfront: realloc ring info in blkif_resume
    - blk-mq: dynamic h/w context count
    - xen-blkfront: save uncompleted reqs in blkfront_resume()
    - xen-blkfront: fix places not updated after introducing 64KB page granularity
    - blk-mq: mark request queue as mq asap
    - blk-mq: Fix NULL pointer updating nr_requests
    - xen-blkfront: fix resume issues after a migration
    - xen-blkfront: introduce blkif_set_queue_limits()
    - xen/pvhvm: run xen_vcpu_setup() for the boot CPU
    - SAUCE: [aws] xen/manage: keep track of the on-going suspend mode
    - SAUCE: [aws] xen/manage: introduce helper function to know the on-going
      suspend mode
    - SAUCE: [aws] xenbus: add freeze/thaw/restore callbacks support
    - SAUCE: [aws] x86/xen: decouple shared_info mapping from
      xen_hvm_init_shared_info()
    - SAUCE: [aws] x86/xen: add system core suspend and resume callbacks
    - SAUCE: [aws] xen/time: introduce xen_{save,restore}_steal_clock
    - SAUCE: [aws] x86/xen: save and restore steal clock
    - SAUCE: [aws] xen/events: add xen_shutdown_pirqs helper function
    - SAUCE: [aws] x86/xen: close event channels for PIRQs in system core suspend
      callback
    - SAUCE: [aws] xen-netfront: add callbacks for PM suspend and hibernation
      support
    - SAUCE: [aws] xen-blkfront: add callbacks for PM suspend and hibernation
      support
    - SAUCE: [aws] x86/xen: handle CPU_UP_PREPARE_FROZEN for PM
      suspend/hibernation
    - SAUCE: [aws] xen-netfront: add longer default freeze timeout as a module
      parameter
    - SAUCE: [aws] PM / hibernate: update the resume offset on
      SNAPSHOT_SET_SWAP_AREA

  * Switch Vcs-Git: url to fully expanded form (LP: #1730648)
    - [Config] Change...

Changed in linux-aws (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers