linux-aws needs module: nls_utf8

Bug #1726493 reported by Kamal Mostafa on 2017-10-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-aws (Ubuntu)
Undecided
Kamal Mostafa
Xenial
Undecided
Unassigned

Bug Description

Amazon requests nls_utf8.ko be made available in the main linux-aws kernel image package.

Changed in linux-aws (Ubuntu):
status: New → In Progress
Changed in linux-aws (Ubuntu):
status: In Progress → Fix Committed
Changed in linux-aws (Ubuntu Xenial):
status: New → Fix Committed

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-xenial' to 'verification-done-xenial'. If the problem still exists, change the tag 'verification-needed-xenial' to 'verification-failed-xenial'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-xenial
tags: added: verification-done-xenial
removed: verification-needed-xenial
Launchpad Janitor (janitor) wrote :
Download full text (18.4 KiB)

This bug was fixed in the package linux-aws - 4.4.0-1041.50

---------------
linux-aws (4.4.0-1041.50) xenial; urgency=low

  * linux-aws: 4.4.0-1041.50 -proposed tracker (LP: #1732535)

  * xen hibernation support for linux-aws (LP: #1732512)
    - aws: [Config] disable SUSPEND
    - aws: [Config] disable XEN_FBDEV_FRONTEND, INPUT_XEN_KBDDEV_FRONTEND
    - xen: move xen_setup_runstate_info and get_runstate_snapshot to
      drivers/xen/time.c
    - xen/time: use READ_ONCE
    - xen: add steal_clock support on x86
    - xen: support runqueue steal time on xen
    - xen: introduce xen_vcpu_id mapping
    - x86/xen: use xen_vcpu_id mapping for HYPERVISOR_vcpu_op
    - xen: add static initialization of steal_clock op to xen_time_ops
    - x86/xen: update cpuid.h from Xen-4.7
    - x86/acpi: store ACPI ids from MADT for future usage
    - xen: update xen headers
    - xen: change the type of xen_vcpu_id to uint32_t
    - xen/blkfront: separate per ring information out of device info
    - xen/blkfront: pseudo support for multi hardware queues/rings
    - xen/blkfront: split per device io_lock
    - xen/blkfront: negotiate number of queues/rings to be used with backend
    - xen/blkfront: Cleanup of comments, fix unaligned variables, and syntax
      errors.
    - xen/blkfront: Remove duplicate setting of ->xbdev.
    - xen/blkfront: make persistent grants pool per-queue
    - xen/blkfront: correct setting for xen_blkif_max_ring_order
    - xen/blkfront: realloc ring info in blkif_resume
    - blk-mq: dynamic h/w context count
    - xen-blkfront: save uncompleted reqs in blkfront_resume()
    - xen-blkfront: fix places not updated after introducing 64KB page granularity
    - blk-mq: mark request queue as mq asap
    - blk-mq: Fix NULL pointer updating nr_requests
    - xen-blkfront: fix resume issues after a migration
    - xen-blkfront: introduce blkif_set_queue_limits()
    - xen/pvhvm: run xen_vcpu_setup() for the boot CPU
    - SAUCE: [aws] xen/manage: keep track of the on-going suspend mode
    - SAUCE: [aws] xen/manage: introduce helper function to know the on-going
      suspend mode
    - SAUCE: [aws] xenbus: add freeze/thaw/restore callbacks support
    - SAUCE: [aws] x86/xen: decouple shared_info mapping from
      xen_hvm_init_shared_info()
    - SAUCE: [aws] x86/xen: add system core suspend and resume callbacks
    - SAUCE: [aws] xen/time: introduce xen_{save,restore}_steal_clock
    - SAUCE: [aws] x86/xen: save and restore steal clock
    - SAUCE: [aws] xen/events: add xen_shutdown_pirqs helper function
    - SAUCE: [aws] x86/xen: close event channels for PIRQs in system core suspend
      callback
    - SAUCE: [aws] xen-netfront: add callbacks for PM suspend and hibernation
      support
    - SAUCE: [aws] xen-blkfront: add callbacks for PM suspend and hibernation
      support
    - SAUCE: [aws] x86/xen: handle CPU_UP_PREPARE_FROZEN for PM
      suspend/hibernation
    - SAUCE: [aws] xen-netfront: add longer default freeze timeout as a module
      parameter
    - SAUCE: [aws] PM / hibernate: update the resume offset on
      SNAPSHOT_SET_SWAP_AREA

  * Switch Vcs-Git: url to fully expanded form (LP: #1730648)
    - [Config] Change...

Changed in linux-aws (Ubuntu Xenial):
status: Fix Committed → Fix Released
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (15.2 KiB)

This bug was fixed in the package linux-aws - 4.4.0-1003.3

---------------
linux-aws (4.4.0-1003.3) trusty; urgency=low

  * linux-aws: 4.4.0-1003.3 -proposed tracker (LP: #1729277)

  * Remove vmbus-rdma driver from Xenial kernel (LP: #1721538)
    - [config] update config for master changes

  * NVMe timeout is too short (LP: #1729119)
    - SAUCE: nvme: update timeout module parameter type

  * update ENA driver to 1.3.0K from net-next (LP: #1727856)
    - MAINTAINERS: change ENA driver maintainers email domain
    - net: ena: Remove redundant unlikely()
    - net: ena: reduce the severity of some printouts
    - net: ena: fix rare kernel crash when bar memory remap fails
    - net: ena: fix wrong max Tx/Rx queues on ethtool
    - net: ena: improve ENA driver boot time.
    - net: ena: remove legacy suspend suspend/resume support
    - net: ena: add power management ops to the ENA driver
    - net: ena: add statistics for missed tx packets
    - net: ena: add new admin define for future support of IPv6 RSS
    - net: ena: increase ena driver version to 1.3.0

  * linux-aws needs module: nls_utf8 (LP: #1726493)
    - [config] AWS: nls_utf8.ko moved to linux-image package

  [ Ubuntu: 4.4.0-100.123 ]

  * linux: 4.4.0-100.123 -proposed tracker (LP: #1729273)
  * Xenial update to 4.4.95 stable release (LP: #1729107)
    - USB: devio: Revert "USB: devio: Don't corrupt user memory"
    - USB: core: fix out-of-bounds access bug in usb_get_bos_descriptor()
    - USB: serial: metro-usb: add MS7820 device id
    - usb: cdc_acm: Add quirk for Elatec TWN3
    - usb: quirks: add quirk for WORLDE MINI MIDI keyboard
    - usb: hub: Allow reset retry for USB2 devices on connect bounce
    - ALSA: usb-audio: Add native DSD support for Pro-Ject Pre Box S2 Digital
    - can: gs_usb: fix busy loop if no more TX context is available
    - usb: musb: sunxi: Explicitly release USB PHY on exit
    - usb: musb: Check for host-mode using is_host_active() on reset interrupt
    - can: esd_usb2: Fix can_dlc value for received RTR, frames
    - drm/nouveau/bsp/g92: disable by default
    - drm/nouveau/mmu: flush tlbs before deleting page tables
    - ALSA: seq: Enable 'use' locking in all configurations
    - ALSA: hda: Remove superfluous '-' added by printk conversion
    - i2c: ismt: Separate I2C block read from SMBus block read
    - brcmsmac: make some local variables 'static const' to reduce stack size
    - bus: mbus: fix window size calculation for 4GB windows
    - clockevents/drivers/cs5535: Improve resilience to spurious interrupts
    - rtlwifi: rtl8821ae: Fix connection lost problem
    - KEYS: encrypted: fix dereference of NULL user_key_payload
    - lib/digsig: fix dereference of NULL user_key_payload
    - KEYS: don't let add_key() update an uninstantiated key
    - pkcs7: Prevent NULL pointer dereference, since sinfo is not always set.
    - parisc: Avoid trashing sr2 and sr3 in LWS code
    - parisc: Fix double-word compare and exchange in LWS code on 32-bit kernels
    - sched/autogroup: Fix autogroup_move_group() to never skip sched_move_task()
    - f2fs crypto: replace some BUG_ON()'s with error checks
    - f2fs crypto: add missing locking for ...

Changed in linux-aws (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers