linux-aws needs modules: drm, drm_kms_helper

Bug #1694837 reported by Kamal Mostafa on 2017-05-31
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux-aws (Ubuntu)
Undecided
Kamal Mostafa

Bug Description

The modules drm.ko and drm_kms_helper.ko are needed to support future projects.

Kamal Mostafa (kamalmostafa) wrote :

I've confirmed that moving these into the aws.inclusion-list (allowing the modules into the linux-aws main package) successfully enables installation of other modules that depend on them.

Changed in linux-aws (Ubuntu):
status: In Progress → Fix Committed
Eric Nordlund (nrdlngr) wrote :

Thanks Kamal. Do you have an estimate on when this would be available in the repos?

Eric Nordlund (nrdlngr) wrote :

Any update?

Kamal Mostafa (kamalmostafa) wrote :

It just landed in the -proposed pocket as linux-aws (4.4.0-1019.28). This version will be promoted to the -updates pocket within a week, unless problems with it are discovered in the meantime. You can download and manually install the package (with dpkg -i) from:

https://launchpad.net/ubuntu/+archive/primary/+files/linux-image-4.4.0-1019-aws_4.4.0-1019.28_amd64.deb

We'd appreciate your confirmation that it works as expected. Thanks Eric!

Kamal Mostafa (kamalmostafa) wrote :

Version linux-aws (4.4.0-1019.28) which included this fix was bumped due to an unrelated important security fix. This fix is now scheduled to appear in the forthcoming linux-aws (4.4.0-1021.30) release. We'll post here once that version becomes available.

Eric Nordlund (nrdlngr) wrote :

I tried the linux-aws (4.4.0-1021.30) version, but my NVIDIA driver install still failed. I think I also need the corresponding linux-headers-4.4.0-1021-aws and linux-aws-headers-4.4.0-1021 packages. I could not find the linux-aws-headers-4.4.0-1021.

Can you share links for these packages and any other dependencies I need, and then I can try again?

Launchpad Janitor (janitor) wrote :
Download full text (19.2 KiB)

This bug was fixed in the package linux-aws - 4.4.0-1022.31

---------------
linux-aws (4.4.0-1022.31) xenial; urgency=low

  * linux-aws: 4.4.0-1022.31 -proposed tracker (LP: #1700549)

  [ Ubuntu: 4.4.0-83.106 ]

  * linux: 4.4.0-83.106 -proposed tracker (LP: #1700541)
  * CVE-2017-1000364
    - Revert "UBUNTU: SAUCE: mm: Only expand stack if guard area is hit"
    - Revert "mm: do not collapse stack gap into THP"
    - Revert "mm: enlarge stack guard gap"
    - mm: vma_adjust: remove superfluous confusing update in remove_next == 1 case
    - mm: larger stack guard gap, between vmas
    - mm: fix new crash in unmapped_area_topdown()
    - Allow stack to grow up to address space limit

linux-aws (4.4.0-1021.30) xenial; urgency=low

  * linux-aws: 4.4.0-1021.30 -proposed tracker (LP: #1699069)

  * linux-aws: disable floppy driver (LP: #1696193)
    - [config] AWS: disable CONFIG_BLK_DEV_FD

  * linux-aws needs modules: drm, drm_kms_helper (LP: #1694837)
    - [config] AWS: drm.ko, drm_kms_helper moved to linux-image package

  [ Ubuntu: 4.4.0-82.105 ]

  * linux: 4.4.0-82.105 -proposed tracker (LP: #1699064)
  * CVE-2017-1000364
    - SAUCE: mm: Only expand stack if guard area is hit
  * linux-aws/linux-gke incorrectly producing and using linux-*-tools-
    common/linux-*-cloud-tools-common (LP: #1688579)
    - [Config] make linux-tools-common and linux-cloud-tools-common protection
      consistent
  * CVE-2017-9242
    - ipv6: fix out of bound writes in __ip6_append_data()
  * CVE-2017-9075
    - sctp: do not inherit ipv6_{mc|ac|fl}_list from parent
  * CVE-2017-9074
    - ipv6: Prevent overrun when parsing v6 header options
  * CVE-2017-9076
    - ipv6/dccp: do not inherit ipv6_mc_list from parent
  * CVE-2017-9077
    - ipv6/dccp: do not inherit ipv6_mc_list from parent
  * CVE-2017-8890
    - dccp/tcp: do not inherit mc_list from parent
  * Module signing exclusion for staging drivers does not work properly
    (LP: #1690908)
    - SAUCE: Fix module signing exclusion in package builds
  * extend-diff-ignore should use exact matches (LP: #1693504)
    - [Packaging] exact extend-diff-ignore matches
  * Dell XPS 9360 wifi 5G performance is poor (LP: #1692836)
    - SAUCE: ath10k: fix the wifi speed issue for kill 1535
  * Upgrade Redpine WLAN/BT driver to ver. 1.2.RC12 (LP: #1694607)
    - SAUCE: Redpine: Upgrade to ver. 1.2.RC12
  * [DP MST] No audio output through HDMI/DP/mDP ports in Dell WD15 and TB15
    docking stations (LP: #1694665)
    - drm/i915: Store port enum in intel_encoder
    - drm/i915: Eliminate redundant local variable definition
    - drm/i915: Switch to using port stored in intel_encoder
    - drm/i915: Move audio_connector to intel_encoder
    - drm/i915/dp: DP audio API changes for MST
    - drm/i915: abstract ddi being audio enabled
    - drm/i915/audio: extend get_saved_enc() to support more scenarios
    - drm/i915: enable dp mst audio
  * Xenial update to 4.4.70 stable release (LP: #1694621)
    - usb: misc: legousbtower: Fix buffers on stack
    - usb: misc: legousbtower: Fix memory leak
    - USB: ene_usb6250: fix DMA to the stack
    - watchdog: pcwd_usb: fix NULL-deref at probe
    - char: lp: fix possible...

Changed in linux-aws (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers