Ubuntu

Please merge lintian 2.4.2(main) from debian unstable(main)

Reported by Bhavani Shankar on 2010-06-28
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lintian (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: lintian

Debian changes:-

 lintian (2.4.2) unstable; urgency=low

   The "Policy 3.9.0" release.

   * Summary of tag changes:
     + Added:
       - arch-wildcard-in-binary-package
       - bad-provided-package-name
       - conflicts-with-version
       - copyright-refers-to-deprecated-bsd-license-file
       - init.d-script-depends-on-unknown-virtual-facility
       - team-upload-has-incorrect-version-number
       - xc-package-type-in-debian-control (pedantic)
     + Removed:
       - arch-any-in-binary-pkg (now in arch-wildcard-in-binary-package)
       - package-type-in-debian-control

   * checks/changes-file.desc:
     + [RA] Add references for file-size-mismatch-in-changes-file and
       checksum-mismatch-in-changes-file.
   * checks/control-file{,.desc}:
     + [RA] Remove package-type-in-debian-control now that dpkg-dev handles
       it as desired by the d-i team. xc-package-type-in-debian-control
       replaces it as a pedantic check to encourage switching to the
       official name. Thanks, Raphael Hertzog.
     + [RA] Add reference for debian-control-with-duplicate-fields.
   * checks/copyright-file{,.desc}:
     + [RA] Deprecate references to /usr/share/common-licenses/BSD in
       debian/copyright following the change in Policy 3.8.5.
   * checks/fields{,.desc}:
     + [RA] Allow Breaks without a version if the broken package is a
       virtual package.
     + [RG] Check for invalid package names in provided (virtual)
       packages.
     + [RG] Exclude dash from the depends-on-essential-package checks, as
       per discusion in debian-devel. (Closes: #587209)
     + [RA] Allow architecture wildcards in build relations and in the
       Architecture field of binary and source packages. (Closes: #582804)
     + [RA] Rename arch-any-in-binary-pkg to arch-wildcard-in-binary-package
       and diagnose any architecture wildcard, not just "any".
     + [RA] Warn of using Conflicts with a version, which should normally
       be Breaks instead, but only at wild-guess certainty for now.
   * checks/huge-usr-share{,.desc}:
     + [RA] Count file size from the tar listing rather than using du. The
       results of du vary based on file system and other factors and make
       the tag difficult to test.
   * checks/init.d{,.desc}:
     + [RG] Check for init.d scripts depending on unknown virtual
       facilities.
     + [RA] Remove checkroot from the list of scripts that should use a
       virtual dependency since $local_fs is not quite the same and some
       packages (cryptsetup) care about the difference. (Closes: #580082)
   * checks/manpages{,.desc}:
     + [RA] Run man page checks using the en_US.UTF-8 locale now that we
       guarantee it exists. Should hopefully fix occasional problems with
       col complaining about bad multibyte characters. (Closes: #575661)
   * checks/menu-format.desc:
     + [RA] Fix typo in long description of duplicated-key-in-desktop-entry.
       Thanks, Niels Thykier. (Closes: #580700)
   * checks/menus:
     + [RG] Recognise call to update-menus when using 'exec.'
     + [RA] Skip Haskell library documentation when warning about
       documentation not registered with doc-base. Patch from Erik de
       Castro Lopo. (Closes: #586877)
   * checks/nmu{,.desc}:
     + [RA] Recognize team uploads and do not treat them like NMUs. Patch
       from Charles Plessy. (Closes: #582741)
   * checks/rules.desc:
     + [RA] Add reference for debian-rules-makemaker-prefix-is-deprecated.
   * checks/scripts:
     + [RG] Correctly handle variables at the beginning of a call to
       dpkg-divert. Thanks, Andreas Beckmann. (Closes: #586984)

   * collection/objdump-info:
     + [RG] Disable etch compatibility code.
   * collection/strings:
     + [RG] Correctly handle ELF binaries with whitespaces in their name.
       (LP: #540342)

   * data/fields/architectures:
     + [RG] Refresh against dpkg 1.15.7.2. (Closes: #581314, #584743)
   * data/fields/virtual-packages:
     + [RA] Update to current unstable and add the old xserver-xorg video
       and input virtual packages.
   * data/files/locale-codes:
     + [RG] Refresh to reflect change to private/refresh-locale-codes.
   * data/files/triplets:
     + [RG] Refresh against dpkg 1.15.7.2.
   * data/init.d/virtual_facilities
     + [RG] New list of virtual facilities that exist in the archive.
   * data/output/ftp-master-fatal:
     + [RA] Remove arch-any-in-binary-pkg.
   * data/output/manual-references:
     + [RA] Update against latest Debian Policy and devref.
   * data/spelling/corrections:
     + [RG] Add more spelling corrections.
   * data/spelling/corrections-case:
     + [RG] Add capitalization correction for OAuth. (Closes: #582353)
   * data/standards-version/release-dates:
     + [RA] Add Debian Policy 3.9.0.

   * frontend/lintian:
     + [RA] Set a PATH of /bin:/usr/bin if PATH is completely unset.
       Thanks, Carsten Hey.

   * lib/Lintian/Collect/Binary.pm:
     + [RG] Correctly handle ELF binaries with whitespaces in their name.
   * lib/Lintian/Relation.pm:
     + [RA] Rather than allowing only a package name or a substvar, allow
       substvars mixed into the package name. (Closes: #580494)
   * lib/Lintian/Schedule.pm:
     + [ADB] Add missing "use Lintian::Output", required for the use of
       warning(). (Closes: #583555)

   * private/refresh-insserv-data:
     + [RG] New script to collect insserv data from the archive.
   * private/refresh-locale-codes:
     + [RG] Print elements with values only once.
   * private/refresh-virtual-packages-data:
     + [RA] Fix handling of # Keep: lines to work correctly now that
       virtual packages mentioned only once are excluded.

 -- Russ Allbery <email address hidden> Sun, 27 Jun 2010 22:08:59 -0700

Bhavani Shankar (bhavi) wrote :
Changed in lintian (Ubuntu):
status: New → Confirmed
Bhavani Shankar (bhavi) wrote :
Launchpad Janitor (janitor) wrote :
Download full text (5.8 KiB)

This bug was fixed in the package lintian - 2.4.2ubuntu1

---------------
lintian (2.4.2ubuntu1) maverick; urgency=low

  * Merge from debian unstable. (LP: #599372) Remaining changes:
    - Don't warn about a symlinked changelog file in Ubuntu due to CDBS.

lintian (2.4.2) unstable; urgency=low

  The "Policy 3.9.0" release.

  * Summary of tag changes:
    + Added:
      - arch-wildcard-in-binary-package
      - bad-provided-package-name
      - conflicts-with-version
      - copyright-refers-to-deprecated-bsd-license-file
      - init.d-script-depends-on-unknown-virtual-facility
      - team-upload-has-incorrect-version-number
      - xc-package-type-in-debian-control (pedantic)
    + Removed:
      - arch-any-in-binary-pkg (now in arch-wildcard-in-binary-package)
      - package-type-in-debian-control

  * checks/changes-file.desc:
    + [RA] Add references for file-size-mismatch-in-changes-file and
      checksum-mismatch-in-changes-file.
  * checks/control-file{,.desc}:
    + [RA] Remove package-type-in-debian-control now that dpkg-dev handles
      it as desired by the d-i team. xc-package-type-in-debian-control
      replaces it as a pedantic check to encourage switching to the
      official name. Thanks, Raphael Hertzog.
    + [RA] Add reference for debian-control-with-duplicate-fields.
  * checks/copyright-file{,.desc}:
    + [RA] Deprecate references to /usr/share/common-licenses/BSD in
      debian/copyright following the change in Policy 3.8.5.
  * checks/fields{,.desc}:
    + [RA] Allow Breaks without a version if the broken package is a
      virtual package.
    + [RG] Check for invalid package names in provided (virtual)
      packages.
    + [RG] Exclude dash from the depends-on-essential-package checks, as
      per discusion in debian-devel. (Closes: #587209)
    + [RA] Allow architecture wildcards in build relations and in the
      Architecture field of binary and source packages. (Closes: #582804)
    + [RA] Rename arch-any-in-binary-pkg to arch-wildcard-in-binary-package
      and diagnose any architecture wildcard, not just "any".
    + [RA] Warn of using Conflicts with a version, which should normally
      be Breaks instead, but only at wild-guess certainty for now.
  * checks/huge-usr-share{,.desc}:
    + [RA] Count file size from the tar listing rather than using du. The
      results of du vary based on file system and other factors and make
      the tag difficult to test.
  * checks/init.d{,.desc}:
    + [RG] Check for init.d scripts depending on unknown virtual
      facilities.
    + [RA] Remove checkroot from the list of scripts that should use a
      virtual dependency since $local_fs is not quite the same and some
      packages (cryptsetup) care about the difference. (Closes: #580082)
  * checks/manpages{,.desc}:
    + [RA] Run man page checks using the en_US.UTF-8 locale now that we
      guarantee it exists. Should hopefully fix occasional problems with
      col complaining about bad multibyte characters. (Closes: #575661)
  * checks/menu-format.desc:
    + [RA] Fix typo in long description of duplicated-key-in-desktop-entry.
      Thanks, Niels Thykier. (Closes: #580700)
  * checks/menus:
 ...

Read more...

Changed in lintian (Ubuntu):
status: Confirmed → Fix Released
tags: added: patch
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers