Ubuntu Lintian shouldn't do the nmu checks

Bug #36505 reported by Jérémie Corbier on 2006-03-24
8
Affects Status Importance Assigned to Milestone
lintian (Ubuntu)
Wishlist
Jérémie Corbier

Bug Description

As far as there is no NMU process in Ubuntu nmu checks should be disabled in lintian.

With this patch nmu checks are disabled by default. They can be enabled again using -D or --debian switches on the commandline.

A simpler debdiff without dpatch since lintian is a Debian native package.

Paul Sladen (sladen) wrote :

Hello Jérémie,

Thanks for your report (and patch!). Could you send this straight upstream to Debian and work with the maintainer to make sure that they are happy with the command-line option you've chosen.

(Eg, they may suggest "--nmu" or their own preference, perhaps with defaults based on '/etc/lsb_release').

Jérémie Corbier (jcorbier) wrote :

I've just sent an email to <email address hidden>. Let's wait for an answer :-)

Jérémie Corbier (jcorbier) wrote :

Here is an answer from Jeroen van Wolffelaar:

"You might want to replace the list of distribution targets for Ubuntu too then, and revert that behaviour when --debian is invoked: #350114."

And:

"I don't see a problem with --debian at least, -D is of course abit
short, but I have no strong opinion here. In any case, I've just added a note in the source with the option processing, and we might decide to add this option (as a no-op in Debian) so that lintian --debian allways gives the same behaviour, on Ubuntu and on Debian and hopefully any other derivate.

Other lintian devs opinions? About -D, and about even maybe even adding it as no-op option?"

Next emails will be CCed to <email address hidden>.

Jérémie Corbier (jcorbier) wrote :

This has been "included" in the latest lintian release (1.23.16):

http://lists.debian.org/debian-lint-maint/2006/03/msg00106.html

I am polishing the patch so that it handles distribution field too for example.

Here is a cleaner version of the patch.

Changed in lintian:
assignee: nobody → jcorbier
status: Unconfirmed → In Progress

The same as the previous one adapted to lintian-1.23.16ubuntu2.

Emilio Pozuelo Monfort (pochu) wrote :

Jeremie:

Any news regarding this bug? Any chance to get this fixed?

Soren Hansen (soren) wrote :

Fixed since 1.23.31ubuntu1.

Changed in lintian:
status: In Progress → Fix Released
Geppo (g-valente) wrote :

urde im Westen heftig kritisiert. Unmittelbar nach der Erkl?rung lehnte die Nato den Vorsto? des russischen Pr?sidenten ab: Generalsekret?r Jaap de Hoop Scheffer sagte in Br?ssel, das Verhalten Russlands in den vergangenen Wochen stelle Moskaus Bekenntnis zu Frieden und Sicherheit im Kaukasus in Frage.Frankreich sprach von einer "bedauerlichen Entscheidung" Medwedews. Ein Sprecher des Au?enministeriums in Paris sagte, die franz?sische Regierung sei dabei, sich mit den europ?ischen Partnern abzustimmen, um eine gemeinsame Verurteilung des Schrittes zu erreichen. Der Organisation f?r Sicherheit und Zusammenarbeit in Europa nannte das Vorgehen Russlands "einen Versto? gegen grundlegende OSZE-Prinzipien. Wie alle OSZE-Staaten ist Russland verpflichtet, die Souver?nit?t und die territoriale Integrit?t anderer zu respektieren." Watch the video hereUS-Au?enministerin Condoleezza Rice bezeichnete den Vorsto? Russlands als "extrem bedauerlich". Es habe Gespr?che gegeben, wie man auf internationaler Ebene den Kaukasus-Konflikt l?sen k?nne. Russland sei dem Ausgang dieser Diskussionen nun zuvorgekommen. Beide abtr?nnigen Regionen seien Teile Georgiens und w?rden dies auch bleiben. Die USA w?rden mit ihrem Veto im Weltsicherheitsrat jeglichen russischen Versuch blockieren, an deren Status etwas zu ?ndern.Mit ungew?hnlich deutlichen Worten stellte Bundeskanzlerin Angela Merkel die Kooperation mit Moskau in Frage. Russlands Handeln sei "absolut nicht akzeptabel", sagte Merkel in Tallinn. "Dieses widerspricht dem Prinzip der territorialen Integrit?t, einem grundlegenden Prinzip des internationalen V?lkerrechts." Merkel schloss Konsequenzen f?r die erst vor wenigen Wochen begonnenen Verhandlungen mit Russland ?ber ein Partnerschafts- und Kooperationsabkommen mit der EU nicht aus. F?r Europa gelte es jetzt, mit Russland ?ber die gemeinsame Wertebasis zu diskutieren. Ein einfaches "Weiter so" k?nne es nicht geben. "Wir m?ssen als Europ?ische Union alles daran setzen, dass wir Georgien und genauso der Ukraine im Rahmen unserer Nachbarschaftspolitik beistehen", sagte Merkel.
Medwedew zeigt sich von Protesten des Westens unber?hrt

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers