Ubuntu

linphone crashes in startup

Reported by Jarno Suni on 2009-05-26
36
This bug affects 7 people
Affects Status Importance Assigned to Milestone
linphone (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: linphone

linphone Version: 2.1.1-1ubuntu2 / ubuntu 9.04

Linphone crashes without any user interaction.

$ linphone
ortp-error-MSV4l: cannot open video device (/dev/video0): No such file or directory.
*** stack smashing detected ***: linphone terminated
======= Backtrace: =========
/lib/tls/i686/cmov/libc.so.6(__fortify_fail+0x48)[0xb782cda8]
/lib/tls/i686/cmov/libc.so.6(__fortify_fail+0x0)[0xb782cd60]
/usr/lib/libmediastreamer.so.0[0xb7705f14]
/usr/lib/libmediastreamer.so.0[0xb77017fe]
/usr/lib/libmediastreamer.so.0(ms_load_jpeg_as_yuv+0x92)[0xb77018c2]
/usr/lib/libmediastreamer.so.0(ms_load_nowebcam+0x87)[0xb7701987]
/usr/lib/libmediastreamer.so.0[0xb76fca73]
/usr/lib/libmediastreamer.so.0(ms_filter_process+0x11)[0xb76f1e01]
/usr/lib/libmediastreamer.so.0[0xb76f2ffb]
/usr/lib/libmediastreamer.so.0[0xb76f310d]
/usr/lib/libmediastreamer.so.0(ms_ticker_run+0x72)[0xb76f31b2]
/lib/tls/i686/cmov/libpthread.so.0[0xb78984ff]
/lib/tls/i686/cmov/libc.so.6(clone+0x5e)[0xb781349e]
======= Memory map: ========
08048000-0806a000 r-xp 00000000 08:0a 168253 /usr/bin/linphone
0806a000-0806b000 r--p 00021000 08:0a 168253 /usr/bin/linphone
0806b000-0806c000 rw-p 00022000 08:0a 168253 /usr/bin/linphone
091ea000-09787000 rw-p 091ea000 00:00 0 [heap]
b4bcc000-b4bd9000 r-xp 00000000 08:0a 3236 /lib/libgcc_s.so.1
b4bd9000-b4bda000 r--p 0000c000 08:0a 3236 /lib/libgcc_s.so.1
b4bda000-b4bdb000 rw-p 0000d000 08:0a 3236 /lib/libgcc_s.so.1
b4bec000-b4c4c000 rw-p b4bec000 00:00 0
b4c5d000-b4c83000 rw-s 00000000 00:09 950291 /SYSV00000000 (deleted)
b4c83000-b4ce6000 rw-s 00000000 00:09 917522 /SYSV00000000 (deleted)
b4ce6000-b4ce7000 ---p b4ce6000 00:00 0
b4ce7000-b54e7000 rw-p b4ce7000 00:00 0
b54e7000-b54e8000 ---p b54e7000 00:00 0
b54e8000-b5ce8000 rw-p b54e8000 00:00 0
b5ce8000-b5cf7000 r-xp 00000000 08:0a 4938 /lib/libbz2.so.1.0.4
b5cf7000-b5cf8000 r--p 0000f000 08:0a 4938 /lib/libbz2.so.1.0.4
b5cf8000-b5cf9000 rw-p 00010000 08:0a 4938 /lib/libbz2.so.1.0.4
b5cf9000-b5e2e000 r-xp 00000000 08:0a 20164 /usr/lib/libxml2.so.2.6.32
b5e2e000-b5e2f000 ---p 00135000 08:0a 20164 /usr/lib/libxml2.so.2.6.32
b5e2f000-b5e33000 r--p 00135000 08:0a 20164 /usr/lib/libxml2.so.2.6.32
b5e33000-b5e34000 rw-p 00139000 08:0a 20164 /usr/lib/libxml2.so.2.6.32
b5e34000-b5e35000 rw-p b5e34000 00:00 0
b5e35000-b5e66000 r-xp 00000000 08:0a 33773 /usr/lib/libcroco-0.6.so.3.0.1
b5e66000-b5e69000 rw-p 00030000 08:0a 33773 /usr/lib/libcroco-0.6.so.3.0.1
b5e69000-b5e9c000 r-xp 00000000 08:0a 33681 /usr/lib/libgsf-1.so.114.0.11
b5e9c000-b5e9d000 ---p 00033000 08:0a 33681 /usr/lib/libgsf-1.so.114.0.11
b5e9d000-b5e9f000 r--p 00033000 08:0a 33681 /usr/lib/libgsf-1.so.114.0.11
b5e9f000-b5ea0000 rw-p 00035000 08:0a 33681 /usr/lib/libgsf-1.so.114.0.11
b5ea0000-b5ea1000 rw-p b5ea0000 00:00 0
b5ea1000-b5ed2000 r-xp 00000000 08:0a 36170 /usr/lib/librsvg-2.so.2.26.0
b5ed2000-b5ed3000 r--p 00031000 08:0a 36170 /usr/lib/librsvg-2.so.2.26.0
b5ed3000-b5ed4000 rw-p 00032000 08:0a 36170 /usr/lib/librsvg-2.so.2.26.0
b5ee5000-b5f45000 rw-s 00000000 00:09 884753 /SYSV00000000 (deleted)
b5f45000-b5f5d000 r--s 00000000 08:0a 19768 /usr/share/mime/mime.cache
b5f5d000-b5f75000 r--s 00000000 08:0a 19768 /usr/share/mime/mime.cache
b5f75000-b5f8f000 r-xp 00000000 08:0a 52377 /usr/lib/gio/modules/libgvfsdbus.so
b5f8f000-b5f90000 r--p 00019000 08:0a 52377 /usr/lib/gio/modules/libgvfsdbus.so
b5f90000-b5f91000 rw-p 0001a000 08:0a 52377 /usr/lib/gio/modules/libgvfsdbus.so
b5f91000-b5fc7000 r-xp 00000000 08:0a 17234 /lib/libdbus-1.so.3.4.0
b5fc7000-b5fc8000 r--p 00035000 08:0a 17234 /lib/libdbus-1.so.3.4.0
b5fc8000-b5fc9000 rw-p 00036000 08:0a 17234 /lib/libdbus-1.so.3.4.0
b5fc9000-b5fdb000 r-xp 00000000 08:0a 53026 /usr/lib/libgvfscommon.so.0.0.0
b5fdb000-b5fdc000 r--p 00012000 08:0a 53026 /usr/lib/libgvfscommon.so.0.0.0
b5fdc000-b5fdd000 rw-p 00013000 08:0a 53026 /usr/lib/libgvfscommon.so.0.0.0
b5fe5000-b5fe6000 r-xp 00000000 08:0a 36146 /usr/lib/gtk-2.0/2.10.0/loaders/svg_loader.so
b5fe6000-b5fe7000 r--p 00000000 08:0a 36146 /usr/lib/gtk-2.0Aborted

Jarno Suni (jarnos) wrote :

changing configuration file ~/.gnome2/linphone helps

Andreas Moog (amoog) wrote :

Thanks for your report, is this still an issue on a fresh install of karmic?

Changed in linphone (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete
Colin Keenan (colinkeenan) wrote :

I have been trying the various SIP softphones and when I tried this one in Ubuntu 10.04 lucid, it behaved exactly as described here. Opened and closed before I could do anything. The installation does say this is console only though, so I tried it from terminal and got the following errors:

colin@ubuntu:~$ linphonec
ALSA lib conf.c:4600:(snd_config_expand) Unknown parameters 0
ALSA lib control.c:902:(snd_ctl_open_noupdate) Invalid CTL default:0
ALSA lib conf.c:4600:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2211:(snd_pcm_open_noupdate) Unknown PCM default:0
ALSA lib conf.c:4600:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2211:(snd_pcm_open_noupdate) Unknown PCM default:0
Your machine appears to be connected to an IPv6 network. By default linphone always uses IPv4. Please update your configuration if you want to use IPv6
Ready
Warning: video is disabled in linphonec, use -V or -C or -D to enable.
linphonec>

It leaves you in the linphonec program with a command prompt but I don't have any idea how to use it.

Tommy Trussell (tommy-trussell) wrote :
Download full text (10.1 KiB)

strangely enough, I installed and used linphone with no problems today under Ubuntu 9.10 Karmic, but I get the crash under 10.4 Lucid on this netbook. I tried the workaround in Bug #352339 with no improvement.

I also noticed several additional strangenesses:

1) the linphone command in the terminal does not work. I get a message saying

twt@eee-aem:~$ linphone
No command 'linphone' found, did you mean:
 Command 'linphonec' from package 'linphone-nox' (universe)
linphone: command not found

2) The linphone man page seems to be in some language other than English:

twt@eee-aem:~$ man --pager= linphone
linphone(1) linphone linphone(1)

JMÉNO
       linphone - Gnome rozhraní pro linphone, internetový telefon podporující SIP.

SYNTAXE
       linphone [--help] [--verbose]

POPIS
       Linphone mù¾e být spu¹tìn bez jakýchkoliv parametrù. V¹echny parametry jsou mìnitelné v nabídce Nastavení.

VOLBY
       --help Vypí¹e tuto nápovìdu a skonèí.

       --version
              Vypí¹e verzi programu a skonèí.

       --verbose
              Na standardní výstup vypisuje vnitøní hlá¹ení programu. Toto je vhodné pøi ladìní.

SOUBORY
       ~/.gnome2/linphone
       Odtud linphone naèítá svoji konfiguraci. Tento soubor nemusíte mìnit.

PROMÌNNÉ PROSTØEDÍ
PØÍKLADY
AUTOØI
       Simon MORLAT <email address hidden> Pro podrobnosti nahlédnìte do souboru AUTHORS, který je souèástí zdro‐
       jových kódù linphone.

VIZ TAKÉ
       linphonec(1) sipomatic(1)

Simon Morlat 1.0.0 linphone(1)
twt@eee-aem:~$

3) when I use command completion, I find the command linphone-3, which produces the crash results though my errors are different:

twt@eee-aem:~$ linphone-3

(linphone-3:6569): libglade-WARNING **: Radio button group video_item could not be found
ALSA lib conf.c:4600:(snd_config_expand) Unknown parameters 0
ALSA lib control.c:902:(snd_ctl_open_noupdate) Invalid CTL default:0
ALSA lib conf.c:4600:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2211:(snd_pcm_open_noupdate) Unknown PCM default:0
ALSA lib conf.c:4600:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2211:(snd_pcm_open_noupdate) Unknown PCM default:0
*** stack smashing detected ***: linphone-3 terminated
======= Backtrace: =========
/lib/tls/i686/cmov/libc.so.6(__fortify_fail+0x50)[0xb65350]
/lib/tls/i686/cmov/libc.so.6(+0xe22fa)[0xb652fa]
/usr/lib/libmediastreamer.so.0(+0x2a154)[0xd57154]
/usr/lib/libmediastreamer.so.0(+0x25cc8)[0xd52cc8]
/usr/lib/libmediastreamer.so.0(ms_load_jpeg_as_yuv+0x92)[0xd52e32]
/usr/lib/libmediastreamer.so.0(static_image_preprocess+0x3f)[0xd52f2f]
/usr/lib/libmediastreamer.so.0(ms_filter_preprocess+0x24)[0xd37a14]
/usr/lib/libmediastreamer.so.0(ms_ticker_attach+0xbf)[0xd392ff]
/usr/lib/libmediastreamer.so.0(video_preview_start+0x1cb)[0xd55d1b]
/usr/lib/liblinphone.so.3(+0xc804)[0xcd9804]
/usr/lib/liblinphone.so.3(linphone_core_iterate+0x4bd)[0xcdd27d]
linphone-3[0x8053992]
/lib/libglib-2.0.so.0(+0x3bd5c)[0x5c4d5c]
/lib/libglib-2.0.so.0(g_main_context_dispatch+0x1...

Tommy Trussell (tommy-trussell) wrote :

since there seems to be a packaging problem in linphone AND a new version of linphone was recently released, one alternative to fixing this might be getting the new version properly backported to 10.4 Lucid.

Tommy Trussell (tommy-trussell) wrote :

I believe my particular crash better matches Bug #582268 so for anyone seeing the "cannot open video device" error please ignore my comments above. If you find that linphone starts to draw its windows and immediately closes them, then open a terminal and try this command:

$ linphone-3

If you see a lot of text starting with
(linphone-3:1984): libglade-WARNING **: Radio button group video_item could not be found

 then head over to Bug #582268

amafernandes (amafernandes) wrote :

Hello, in my desktop that doesn't have a webcam, linphone crashed.
Then i tried the terminal, $ linphone, and it crashed then I tried $ linphone --iconified and it runs ok, and now it work normally, from menu, terminal ,etc

Vachigaggl (vachigaggl) wrote :

This problem persists. The linphone application crashes at startup in Lucid Lynx.

Steps needed to reproduce:

1. sudo apt-get install linphone
2. Either click on the linphone icon in start menu or call linphone-3 on a command line
3. watch it appear briefly and then crash without any further notification.

I have attached the output that I get when calling linphone-3 from console.

Changed in linphone (Ubuntu):
status: Incomplete → Confirmed
adam baroumand (adam-b3) wrote :

I'm running Ubuntu 10.04 and I was experiencing the same problem of linphone crashing on startup.

I believe i just solved this by doing the following, but I still have yet to test call it and relaunch linphone again after rebooting.

I just opened a terminal and typed:
linphonec -s

then quit and exit. pressed:
ctrl + c

then launched Linphone normally from the menu

Sérgio Faria (sergio91pt) wrote :

How can this be medium priority?? and open since 2009
just installed on lucid, and crashed when I tried to start it

thanks adam baroumand, it works!

Jarno Suni (jarnos) wrote :

There is no ~/.linphonerc after installation in ubuntu 10.04. Adding a proper file prevents crashing. The trick presented in #9 produces such a file.

ralphie (ralphie) wrote :

Thanks Adam! I can confirm that post #9 works to create the hidden .linphonerc file in the user's home directory. This file is totally necessary in order for Linphone to work. It is a configuration file. The program will just continue to crash without it. According to Linphone's website it is supposed to be automatically generated on first launch but this does not happen.

This should be a high priority bug for Ubuntu 10.04 as the program is basically useless until the user finds this post :) Maybe it's fixed in higher versions of Linphone >3.2.1. or Ubuntu >10.04 but what normal user would know how to get version 3.2.1. to work? Most people are probably gonna be like, "this is trash"... un-install.

I'm just glad there were clever, considerate people who took time and effort to understand the inner workings of this software and post a solution. Seriously, who can just know these things? Linphone is such a good choice too because of it's multi-platform support (Linux, smart-phone, Mac, and Windows compatible).

Sidenote: Once you get Linphone working... if it keeps crashing when you switch to Audio & Video mode. Leave the setting under "Nat and Firewall" as "Direct connection to the Internet." I'm behind a NAT/Firewall router so I entered my dynamic IP but it just kept crashing and defaulting to "Direct connection to the Internet." I left the NAT/Firewall setting as "Direct Connection to the Internet" and Video mode instantly started working. I haven't placed a call yet but I could at least see my self-view and verify Linphone and my camera were working. I'll report back once I make a few calls.

Thanks again guys!

ralphie (ralphie) wrote :

Well, it looks like it's working! I made a few calls from my cell phone using Fring*. Even though I was calling myself it worked, Linphone started ringing on my computer and I started having a conversation with myself :)

* (Fring is a mobile messenger app that allows you to use your SIP account to make calls from your cellphone, so it's basically a client application like Linphone or Ekiga, etc.)

The only thing I couldn't do was test and verify that the video capability was working because I don't know people with SIP accounts and webcams (My cellphone doesn't have a web cam). I'm gonna set up my wife with an SIP account soon and I'll report back.

One last note which is probably more of a hardware issue on my end is: Once in a blue moon my speakers and mic won't respond and Linphone is no fun. But I found that the easy fix in Ubuntu at least is to go to System > Preferences > Multimedia Systems Selector and just click on the Test buttons for Default output and Default input. After that everything is detected and works.

Happy VoIPing!

Colan Schwartz (colan) wrote :

I can confirm that the workaround in #9 does the trick, but only if you keep it in "Audio only" mode. If I try swiching it to Mode -> "Audio & Video", it crashes. So it won't work with video. I added tags stating that this is a regression; it used to work for me pre-Oneiric.

tags: added: oneiric regression-release
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers