xlinks shouldn't replace Firefox as /etc/alternatives/x-www-browser

Bug #538912 reported by Sam Cannell
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Won't Fix
Wishlist
Unassigned
links2 (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

Binary package hint: links2

Installing links2 in karmic will beat both firefox-2 and firefox-3.5 in selection for /etc/alternatives/x-www-browser. This is almost certainly not what users want or expect.

~ $ dpkg -s links2 | grep ^Version
Version: 2.2-1build1
~ $

~ $ update-alternatives --display x-www-browser
x-www-browser - auto mode
 link currently points to /usr/bin/xlinks2
/usr/bin/firefox-2 - priority 30
 slave x-www-browser.1.gz: /usr/share/man/man1/firefox-2.1.gz
/usr/bin/firefox-3.5 - priority 40
/usr/bin/xlinks2 - priority 69
 slave x-www-browser.1.gz: /usr/share/man/man1/xlinks2.1.gz
Current `best' version is /usr/bin/xlinks2.
~ $

~ $ lsb_release -cd
Description: Ubuntu 9.10
Codename: karmic
~ $

Revision history for this message
Lenin (gagarin) wrote :

i guess the firefox priorities were lowered. have a look at the source package debian/postinst, you can easily change the values there and rebuild the package.

Evan Broder (broder)
Changed in links2 (Ubuntu):
status: New → Confirmed
Revision history for this message
Axel Beckert (xtaran) wrote :

This is an Ubuntu specific bug. Iceweasel in Debian does have a priority of 70, xlinks2 a priority of 69. Works fine. Ubuntu's firefox-3.5 in Karmic has priority of 40.

No idea, why Ubuntu uses a different priority for Firefox compared to Debian. This probably causes the same problem with many other web browsers which are used as unmodified Debian packages on Ubuntu, too.

Revision history for this message
Anders Kaseorg (andersk) wrote :

This should probably be fixed by bumping the priority of /usr/bin/firefox up to 70, analagously to Iceweasel on Debian.

Changed in firefox (Ubuntu):
status: New → Confirmed
Revision history for this message
Chris Coulson (chrisccoulson) wrote :

I was thinking about bumping the priority a couple of weeks ago, but backed out the change at the last minute before the recent upload. TBH, this isn't likely to change for Maverick, and it's not something that's going to be a priority for us to change in the future either. The alternatives system is not a good way of managing the default browser anyway, and it's pretty difficult (or nearly impossible) to pick a priority that will please everyone and won't make some users upset.

This is probably just best left alone IMO

Changed in firefox (Ubuntu):
importance: Undecided → Wishlist
status: Confirmed → Opinion
Revision history for this message
Geoffrey Thomas (geofft) wrote :

> The alternatives system is not a good way of managing the default
> browser anyway

Perhaps, but it's what apps that use sensible-browser (alpine, xpdf, end up using, which is why I really care. Perhaps another solution would be to make ubufox or something make sensible-browser unconditionally open Firefox...

(It is kind of telling that the first page of Google results for sensible-browser are mostly people trying to figure out how to make their Ubuntu sensible-browser Firefox.)

> and it's pretty difficult (or nearly impossible) to pick a priority
> that will please everyone and won't make some users upset.

Well, there's a little Firefox icon in the gnome-panel, and that seems to be sufficient, and I imagine people would replace that icon if for some reason it were a launcher for xlinks2 or Iceweasel or Epiphany instead.

I would claim that that means that Firefox is Ubuntu's default browser, and so that's what sensible-browser should launch. If people want to change their preferences on a case-by-case basis, they can set $BROWSER.

See also bug #204858 for people ultimately wanting sensible-browser to open Firefox (or Konqueror on Kubuntu). I'm perfectly cool with deciding that we don't want to do this with alternatives or xdg-open or whatever, but I think sensible-browser should be fixed on Ubuntu.

If you think that this should be a different bug, and we should wontfix the current one about xlinks, I'm happy to file a new bug.

Revision history for this message
Anders Kaseorg (andersk) wrote :

> and it's pretty difficult (or nearly impossible) to pick a priority
> that will please everyone and won't make some users upset.

Really? Obviously, the current priority of 40 makes some users upset, but why would anyone complain about setting the priority to 70 to match Debian’s choice?

I think what’s going on here is that firefox-2 used a priority of 70:
  http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/maverick/firefox/maverick/annotate/44/debian/firefox.postinst
but then a new firefox-trunk package was created for Firefox 3 alphas with a lower priority, and the priority was never bumped back to 70 when firefox-trunk became firefox-3. There were no user complaints about the old priority of 70 AFAIK; it was changed accidentally.

Revision history for this message
Jonathan Reed (jdreed) wrote :

>I would claim that that means that Firefox is Ubuntu's default browser

Indeed, Ubuntu claims this too. See https://help.ubuntu.com/community/WebBrowsers
(Yes, I know it's community documentation, but it's help.ubuntu.com, not the wiki)

Changed in firefox (Ubuntu):
status: Opinion → Confirmed
Revision history for this message
Axel Beckert (xtaran) wrote :

JFTR: There are tons of other browers in Ubuntu which are even above the discussed 70 as used by Debian:

 * 0 /usr/bin/google-chrome 200 auto mode
   1 /usr/bin/arora 90 manual mode
   2 /usr/bin/epiphany-browser 85 manual mode
   3 /usr/bin/firefox 40 manual mode
   4 /usr/bin/google-chrome 200 manual mode
   5 /usr/bin/konqueror 30 manual mode
   6 /usr/bin/xlinks2 69 manual mode

Actually only Konqueror has a lower value than Firefox in the above example. I'd tend to close this bug as wontfix or so for links2.

Revision history for this message
Micah Gersten (micahg) wrote :

Sorry, alternative priority wars won't help anything. I'd suggest filing bugs for anything still relying on that alternative as opposed to xdg-open or something else which parses the default settings.

Changed in firefox (Ubuntu):
status: Confirmed → Won't Fix
Revision history for this message
Anders Kaseorg (andersk) wrote :

Micah: bug 204858 was exactly that bug (sensible-browser should use xdg-open instead of relying on alternatives), but it was closed as invalid. Should it be reopened?

Lenin (gagarin)
Changed in links2 (Ubuntu):
status: Confirmed → Fix Committed
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers