package initramfs-tools 0.103ubuntu8 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Bug #1385261 reported by martin suc on 2014-10-24
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
lilo (Ubuntu)
High
Unassigned

Bug Description

apt-cache policy initramfs-tools
initramfs-tools:
  Installed: 0.103ubuntu8
  Candidate: 0.103ubuntu8
  Version table:
 *** 0.103ubuntu8 0
        500 http://archive.ubuntu.com/ubuntu/ utopic/main amd64 Packages
        100 /var/lib/dpkg/status

ProblemType: Package
DistroRelease: Ubuntu 14.10
Package: initramfs-tools 0.103ubuntu8
ProcVersionSignature: Ubuntu 3.16.0-23.31-generic 3.16.4
Uname: Linux 3.16.0-23-generic x86_64
NonfreeKernelModules: nvidia wl
ApportVersion: 2.14.7-0ubuntu8
Architecture: amd64
Date: Fri Oct 24 12:46:37 2014
DuplicateSignature: package:initramfs-tools:0.103ubuntu8:subprocess installed post-installation script returned error exit status 1
ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationDate: Installed on 2014-10-21 (2 days ago)
InstallationMedia:

PackageArchitecture: all
SourcePackage: initramfs-tools
Title: package initramfs-tools 0.103ubuntu8 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: No upgrade log present (probably fresh install)

martin suc (martin-suc) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in initramfs-tools (Ubuntu):
status: New → Confirmed
Changed in initramfs-tools (Ubuntu):
importance: Undecided → High
seeker5528 (seeker5528) wrote :

initramfs-tools failed to upgrade for me too. doing

dpkg --configure -a

indicated no space left on /tmp

df -h indicated /tmp mounted on overflow 1m total 0 free.

I logged out, switched to a VT, logged in and did

sudo su
export TMPDIR=/var/tmp
dpkg --configure -a

which allowed the initramfs-tools and kernel upgrades to complete.
Rebooted and everything seems fine for the moment.

Andy Whitcroft (apw) wrote :

Processing triggers for initramfs-tools (0.103ubuntu8) ...
update-initramfs: Generating /boot/initrd.img-3.16.0-23-generic
W: mdadm: /etc/mdadm/mdadm.conf defines no arrays.
Warning: LBA32 addressing assumed
Fatal: Can't put the boot sector on logical partition 0x0808
run-parts: /etc/initramfs/post-update.d//runlilo exited with return code 1
dpkg: error processing package initramfs-tools (--configure):
 subprocess installed post-installation script returned error exit status 1

Changed in initramfs-tools (Ubuntu):
status: Confirmed → Triaged
Steve Langasek (vorlon) on 2018-03-28
affects: initramfs-tools (Ubuntu) → lilo (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers