Reboot needed after domainjoin before login into Gnome as a domain user

Bug #352934 reported by Buddha on 2009-04-01
4
Affects Status Importance Assigned to Milestone
likewise-open (Ubuntu)
Medium
Thierry Carrez
likewise-open5 (Ubuntu)
High
Thierry Carrez
ubuntu-docs (Ubuntu)
Wishlist
Joel Goguen

Bug Description

Binary package hint: likewise-open5

I struggled for a good title to this bug report. I would just like to report my experience with this package which has been less than good.

I have tried this package twice from clean and updated installs, once on Ubuntu 9.04 Alpha 6 and twice on the Beta. No other third party sw/ is installed. This in vanilla 9.04 updated with likewise-open5.

I am running using the AMD64 alternate install on a Dell D820 Laptop (wired networking).

On both attempts at using this package, it installed correctly. Using the likewise-open5-gui package I joined an AD domain. However, on first (and every) domain login, I get a Failed to initialise HAL error. After that I get continuous launch of something. I can't say what as my the "something" is started again and again and again filling my task panel with no end. The only option I have to stop this is to log out. If I login with a domain account I get the same again.

So, sod it I think. Not ready yet. Not released, no problems, I'll just uninstall it and I'll be OK.

When uninstalling the package it says it leaves the domain. This seems to be from a client perspective only as the laptop is still visible AD and has to be removed on the domain controller.

After the uninstall, and reboot, when I login (with a local account) my network no longer works. I just see the animated connecting icon. This never stops and I never get an address. If I reconfigure to use a static address, then networking is OK. If I change back to DHCP (good for home and work), then no address again. Not good.

The only way I know of getting everything working again then is to reinstall the laptop.

I'm sure you probably would like a bit more detail for this. Depending on what is requested I will be able to repeat, but given the amount of time it consumes to get everything working again I don't want to repeat too many times so please be explicit as to what is needed. Note I am on GMT+12 (NZ).

Currently I have likewise 4 installed and will try to join the domain, login, leave the domain tomorrow.

I see there is perhaps a feature freeze exception for likewise-open5 such that it might officially get into 9.04. From my perspective it really does not look good (on AMD64).

Thierry Carrez (ttx) wrote :

Thanks for testing and reporting those bugs.
There are in fact several separate issues. I'll keep this bug centered on the main issue you reported, "Failed to initialize HAL" followed by various breakage when logging in as a domain user just after joining the domain.

Likewise Open 5 apparently requires DBUS to be completely restarted when likewise-open 4 was happy with DBUS just reloading the configuration. Since restarting DBUS when logged in also results in various desktop breakage, I think we need to ask the user to reboot after joining the domain.

Could you please test that if you:
- Install Likewise Open 5
- Join the domain
- Reboot your machine
- Log in as domain user

Then you don't get the "Failed to initialise HAL" error or other issues ?
If you confirm that it avoids the issue, then we'll add some dialog to ask the user to reboot after a domain join.

Changed in likewise-open5 (Ubuntu):
assignee: nobody → ttx
importance: Undecided → High
status: New → Confirmed
summary: - Painful
+ Can't login into Gnome as a domain user after domain join

See bug 354498 for the issue of DHCP NetworkManager breakage after domain leave.

Thierry Carrez (ttx) wrote :

Solution seems to be requiring a reboot after domain join, by adding to ConfigureLogin:
  /usr/share/update-notifier/notify-reboot-required
  touch /var/lib/update-notifier/dpkg-run-stamp

Will have to doublecheck if reboot is required after domain leaving (my guess is no).

Changed in likewise-open5 (Ubuntu):
status: Confirmed → Triaged
Buddha (lord-buddha) wrote :

I will try again on likewise 5 again as per your instructions on Sunday.

Will also check leaving the domain (without reboot ) to check networking and that all .orig files are correctly restored.

Buddha (lord-buddha) wrote :

Yes it worked after rebooting immediately after joining the domain.

...However, on first attempt the likewise domain gui crashed when joining the domain (and in fact crashed before the domain join was complete. I re-ran and successfully joined the domain. So I left the domain, rebooted, put back all the files not restored on leaving and rebooted again. I then tried joined the domain using the command line. This worked with no issue.

Thierry Carrez (ttx) on 2009-04-06
Changed in likewise-open5 (Ubuntu):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package likewise-open5 - 5.0.3991.1-0ubuntu2

---------------
likewise-open5 (5.0.3991.1-0ubuntu2) jaunty; urgency=low

  * debian/patches/ask-for-reboot.diff: Ask for a reboot after domain join
    since it is necessary before domain graphical logins (LP: #352934)
  * Removed debian/patches/graceful_dbus_restart.diff since it is not
    sufficient and we now ask for a reboot
  * debian/patches/abstractions-cleanup.diff: Use a more precise mark to
    delimitate likewise mods, to avoid destructive cleanup of the appamor.d
    abstractions/nameservice file (LP: #354498)
  * debian/likewise-open5-lsass.prerm: Fix typo preventing pam-auth-update
    profile from being unregistered (LP: #354568)
  * debian/likewise-open5.NEWS: Added note about upgrading/replacing an
    existing likewise-open (4.1) install (LP: #347250)

 -- Thierry Carrez <email address hidden> Mon, 06 Apr 2009 13:51:17 +0200

Changed in likewise-open5 (Ubuntu):
status: In Progress → Fix Released
Thierry Carrez (ttx) wrote :

It would be great if the Server doc also insisted on the need to reboot, adding ubuntu-docs task.

summary: - Can't login into Gnome as a domain user after domain join
+ Reboot needed after domainjoin before login into Gnome as a domain user
Changed in ubuntu-docs (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
markofealing (mark-ferns16) wrote :

I second that about the documentation, page numbers would also be good!

Thierry Carrez (ttx) on 2009-04-08
Changed in likewise-open (Ubuntu):
assignee: nobody → ttx
importance: Undecided → Medium
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package likewise-open - 4.1.2982-0ubuntu2

---------------
likewise-open (4.1.2982-0ubuntu2) jaunty; urgency=low

  * debian/patches/ask-for-reboot.diff: Ask for a reboot after domain join
    since it is necessary before domain graphical logins (LP: #352934)
  * Removed debian/patches/graceful_dbus_restart.diff since it is not
    sufficient and we now ask for a reboot
  * debian/patches/abstractions-cleanup.diff: Use more precision when removing
    likewise mods from appamor.d/abstractions/nameservice file, to avoid
    very destructive cleanup (LP: #354498)
  * Added debian/patches/autoconf-ftbfs-fix.diff to fix FTBFS

 -- Thierry Carrez <email address hidden> Wed, 08 Apr 2009 17:32:39 +0200

Changed in likewise-open (Ubuntu):
status: In Progress → Fix Released
Joel Goguen (jgoguen) on 2009-05-03
Changed in ubuntu-docs (Ubuntu):
assignee: nobody → Joel Goguen (jgoguen)
status: Confirmed → In Progress
Joel Goguen (jgoguen) wrote :

Adding a note that a reboot is required before attempting to authenticate against the newly-joined domain.

Seems to be a good patch. No typos and has a clear message.

Matthew East (mdke) on 2009-05-04
tags: added: patch
Adam Sommer (asommer) wrote :

Thanks for the patch Joel, I committed your patch to revision 302.

Changed in ubuntu-docs (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-docs - 9.10.2

---------------
ubuntu-docs (9.10.2) karmic; urgency=low

  * General:
    - fix menu entry for gparted; patch from Artur Szymanski, LP: #371851
    - a few corrections to use US not UK spelling, patch from Nathan Handler
    - remove unnecessary use of alt+f2 to start apps available from the menu, Dean Sas
  * Hardware:
    - fix instructions to lock screen with new FUSA applet, patch from Artur Szymanski, LP: #371930
  * Add-applications:
    - new section on PPA, patch from Nathan Handler
  * Musicvideophotos:
    - generalise photo import instructions, from Stephanie Mardell
    - update section on listening to online audio streams is outdated, patch from Shane Fagan
    - Rhythmbox has a tag editor, patch from Shane Fagan
  * Keeping-safe:
    - fix link to removing programs, patch from Artur Szymanski
  * Internet:
    - document easiest way to change preferred email client, Dougie Richardson, LP: #356894
    - java is no longer installed by ubuntu-restricted-extras, Dean Sas, LP: #366039
  * Serverguide:
    - Clarify read only explanation in samba section, patch from Connor Imes, LP: #281702
    - Patch by Joel Goguen adding note about restarting after joining a domain, LP: #352934.
    - Patch by Nathan Handler to remove information about dhcdbd that is no longer needed, LP: #373867.
    - Merge from Connor Imes: 2009-05-06 Fix bad flag in useradd command, LP: #371730
  * Games:
    - remove confusing lines from supertux instructions, patch from Shane Fagan, LP: #346892

 -- Matthew East <email address hidden> Sun, 17 May 2009 09:45:19 +0100

Changed in ubuntu-docs (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers