[armel] likewise-open needs porting to ARM

Bug #517300 reported by Michael Casadevall on 2010-02-04
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
likewise-open (Ubuntu)
High
Michael Casadevall
Lucid
High
Michael Casadevall
Natty
High
Michael Casadevall

Bug Description

Binary package hint: likewise-open

Likewise currently requires porting to ARM. I'm working done on this for now, and working on getting the code t compile. This bug tracks the progress of my porting.

Changed in likewise-open (Ubuntu):
assignee: nobody → Michael Casadevall (mcasadevall)
importance: Undecided → High
status: New → In Progress

WIP patch for porting attached.

Oliver Grawert (ogra) on 2010-02-09
summary: - [armel] likewise-open needs porting to armel
+ [armel] likewise-open needs proper CPU detection for disabling parallel
+ builds

The patch attached fixes all outstanding build issues with likewise-open, but has been blocked on copyright assignment with likewise (thus resolved), and validation with an armel box, and a Windows Server box. I'm reassigning this to the server team, but will assist with running the likewise client on ARM hardware. I don't have the time or resources to setup an active domain controller to test this.

Changed in likewise-open (Ubuntu):
assignee: Michael Casadevall (mcasadevall) → Ubuntu Server Team (ubuntu-server)
summary: - [armel] likewise-open needs proper CPU detection for disabling parallel
- builds
+ [armel] likewise-open needs porting to ARM
Changed in likewise-open (Ubuntu):
status: In Progress → Triaged
Oliver Grawert (ogra) on 2010-03-02
tags: added: armel
Changed in likewise-open (Ubuntu Lucid):
milestone: none → ubuntu-10.04-beta-1
Thierry Carrez (ttx) wrote :

Not a server team package

Changed in likewise-open (Ubuntu Lucid):
assignee: Ubuntu Server Team (ubuntu-server) → nobody
Oliver Grawert (ogra) wrote :
Changed in likewise-open (Ubuntu Lucid):
assignee: nobody → Ubuntu Desktop (ubuntu-desktop)
Oliver Grawert (ogra) wrote :

it would be nice to get some instructions for testing so we can make sure the fixes work

Changed in likewise-open (Ubuntu Lucid):
assignee: Ubuntu Desktop (ubuntu-desktop) → Gerald Carter (coffeedude.jerry)
Martin Pitt (pitti) wrote :

Gerry, the debdiff looks quite okay to me (the autoreconf patch could be a little smaller, but that's just a nitpick). Can this be applied to your tree? Thanks!

Martin, Yup. I'm working on new packages currently. Trying to get this incorporated as well.

Michael, WIth the obvious exception of the changelog update, the debiff applied cleanly to
5.4.0.42111-1~ppa1~lucid in the likewise open development PPA. I'm testing a build locally
and then will upload this to PPA assuming all goes ok. I'll ping you if I have questions about
the new patches in the series file.

Changed in likewise-open (Ubuntu Lucid):
status: Triaged → In Progress

Request for sponsored upload in LP BUG #538616

Changed in likewise-open (Ubuntu Lucid):
status: In Progress → Fix Committed
Changed in likewise-open (Ubuntu Lucid):
status: Fix Committed → In Progress
Alexander Sack (asac) on 2010-03-19
Changed in likewise-open (Ubuntu Lucid):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package likewise-open - 5.4.0.42111-1

---------------
likewise-open (5.4.0.42111-1) lucid; urgency=low

  [ Michael Casadevall ]
  * LP: #517300
    - added debian/patches/disable_parallel_builds.diff to allow successful builds
      on non-x86 architectures caused by improperly parsing /proc/cpuinfo to
      determine the number of CPUs and set make -jX.
    - added debian/patches/correct_lwio_configure_detection.diff to correct configure
      tests for properly checking proc filesystems on non-x86 linux platforms
    - added ${misc:Depends} to Depends lines to satisfy lintian
    - Added debian/README.source to satisfy lintian
    - Bumped standards version to 3.8.3

  [ Gerald Carter ]
  * New upstream release. (LP: #538616)
  * likewise-open.install: Include uninstalled binaries and ncalrpc
      servers required for domainjoin-cli {join,leave}
  * patches/version-in-share.diff:
    - Corrected location of VERSION file in lsassd
 -- Gerald Carter <email address hidden> Sat, 13 Mar 2010 07:42:44 -0600

Changed in likewise-open (Ubuntu Lucid):
status: Fix Committed → Fix Released
Changed in likewise-open (Ubuntu Lucid):
status: Fix Released → In Progress
assignee: Gerald Carter (coffeedude.jerry) → Michael Casadevall (mcasadevall)
milestone: ubuntu-10.04-beta-1 → ubuntu-10.04

Updated debdiff attached

Thanks Michael. I've forward the patch to our dcerpc developer for review and testing it myself as well.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package likewise-open - 5.4.0.42111-2ubuntu1

---------------
likewise-open (5.4.0.42111-2ubuntu1) lucid; urgency=low

  * Properly fix ARM FTBFS (LP: #517300)
  * debian/patches/correct_lsass_configure_platform_detection.patch
    - Added support for lsass on ARM including location of the PC for
      likewise-open's backtracing
    - Modified configure to know what ARM is
  * debian/patches/dcerpc_support_arm.diff
    - Properly add ARM platform stubs and chitecture information.
    - Modified configure to know what ARM is
  * debian/patches/autoreconf_dcerpc.diff & autoreconf_lsass.conf
    - Regenerate autotools for configuration changes made to support armel
 -- Michael Casadevall <email address hidden> Fri, 09 Apr 2010 12:30:18 +0000

Changed in likewise-open (Ubuntu Lucid):
status: In Progress → Fix Released
Tobin Davis (gruemaster) on 2011-01-20
Changed in likewise-open (Ubuntu):
status: Fix Released → Triaged
milestone: ubuntu-10.04 → none
Jani Monoses (jani) wrote :

Reopening because FTBFS again in natty (no autoreconf after update to new upstream).
Michael's patch should go upstream anyway.

Changed in likewise-open (Ubuntu):
milestone: none → ubuntu-10.04
status: Triaged → Confirmed
Tobin Davis (gruemaster) wrote :

Reopening and nominating for Natty as upstream didn't take the fix.

Scott Salley (ssalley) wrote :

Just FYI: I don't know the entire reason why we (Likewise) didn't take the ARM patch, but I do know we will be supporting ARM, so I don't expect a patch to be needed for 11.11.

Steve Langasek (vorlon) wrote :

(removing the ubuntu-10.04 milestone; not sure if that was meant to be -11.04, but 10.04 is clearly wrong for a natty-targeted bug)

Changed in likewise-open (Ubuntu):
milestone: ubuntu-10.04 → none
tags: added: patch
Tobin Davis (gruemaster) on 2011-01-28
Changed in likewise-open (Ubuntu Natty):
milestone: none → ubuntu-11.04
Steve Langasek (vorlon) on 2011-02-15
tags: added: arm-porting-queue
Dave Walker (davewalker) wrote :

@Scott, Is there any update on the status of the patch landing upstream?

Jani Monoses (jani) wrote :

Fixed by regenerating a malformed patch in debian/patches

Changed in likewise-open (Ubuntu Natty):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers